Subject: sctp packet generator

From: [email-masked]
Date: Wed, 10 Oct 2007 17:33:19 +0000

I'm looking for a sctp packet generator that can generate packets with zero chunks. 

I've looked at sctp_test and sctp_darn in lksctp tools, but don't see any flags in those for sending sctp DATA packets that have zero chunks.

BTW, the purpose behind this is to test a netfilter implementation for the handling of sctp packets with zero chunks.

Best,

--
Bruce Rosenthal
Chief Architect, TranStrophe
Turning Information and Technology Into Business Opportunities

505 521 4879
510 432 7912

---

From: Vlad Yasevich <[email-masked]>
Date: Wed, 10 Oct 2007 14:05:22 -0400

> BTW, the purpose behind this is to test a netfilter implementation for the handling of sctp packets with zero chunks.

Take a look at:
http://sctp.fh-muenster.de/sctp-testtool.html

-vlad