Subject: Setting of SCTP options

From: Oliver Roll <[email-masked]>
Date: Fri, 04 Jan 2008 09:41:29 +0100

Dear all,

on Linux systems with lksctp there are tunables in /proc/sys/net/sctp
where one can set several options affecting SCTP associations on that
very system.
On BSD (7.0-BETA4) some of those options can be set via setsockopt and
some (all, as far as I can see) also via sysctl, but unfortunately not
all options are explained in sctp(4). Is documentation available for all
of sctp's options on BSD?

Regards,
Oliver

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 4 Jan 2008 12:56:22 +0100

Hi Oliver,

which options are not documented?

Best regards
Michael

---

From: Oliver Roll <[email-masked]>
Date: Fri, 04 Jan 2008 14:14:06 +0100

Hello Michael,

I've just picked some options for which I did not find a documentation
in the manpage:

net.inet.sctp.mobility_fasthandoff: 0
net.inet.sctp.mobility_base: 0
net.inet.sctp.pcbhashsize: 256
net.inet.sctp.tcbhashsize: 1024
net.inet.sctp.path_rtx_max: 5
net.inet.sctp.assoc_rtx_max: 10

Many of the sysctl-options (like path_rtx_max & assoc_rtx_max) are
self-explanatory but not all. Is documentation available for the
sysctl-options? And if yes, where can I find it?
I assume that all timer-values are given in milliseconds?

Thanks & regards,

Oliver

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 4 Jan 2008 15:04:46 +0100

Hi Oliver,

see my comments in-line.

Best regards
Michael

> net.inet.sctp.mobility_base: 0
These two are for an mobility feature which is normally
turned off. Not sure how stable and tested it is.
> net.inet.sctp.tcbhashsize: 1024
These are sizes for hash tables. If you do not have
a very large number if associations or end-points
you do not need to change them.
> net.inet.sctp.path_rtx_max: 5
This is the default number for the path error threshold
before the path is considered inactive.
Can be overwritten on a per path base by using the
spp_pathmaxrxt field in the SCTP_PEER_ADDR_PARAMS
option.
> net.inet.sctp.assoc_rtx_max: 10
This is the default number for the association error
threshold before the association is considered broken.
It can be overwritten on a per association base by using
the sasoc_asocmaxrxt field in the SCTP_ASSOCINFO option.

---

From: Randall Stewart <[email-masked]>
Date: Wed, 09 Jan 2008 08:15:08 -0500

> of sctp's options on BSD?
Oliver:

I see that Michael as answered most of your specific questions... the
reality is I have never gotten around to documenting all the sysctl's
in sctp(4) like I should. It is on my to-do list.. but its way
down there (unfortunately). I will get to it someday... when I
get the time .. sigh..

R

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)