Subject: [Secauth] secauth - version 2 authentication and authorization requirement draft

From: Hosnieh Rafiee <[email-masked]>
Date: Tue, 23 Sep 2014 13:30:01 +0000

Folks,

I have uploaded a new version of secauth requirement and use cases. Since I plan to request a BoF, I need your inputs to know that what else we need to consider to be ready for BoF request.

Therefore I welcome your inputs.

Thanks you,
Best,
Hosnieh

---

From: Hosnieh Rafiee <[email-masked]>
Date: Tue, 23 Sep 2014 13:47:17 +0000

Followup,

Sorry I forgot posting the link
It appears that IETF doesn't show the last version on a website. It is strange...

http://tools.ietf.org/html/draft-rafiee-secauth-usecase-01

---

From: "Hosnieh Rafiee" <[email-masked]>
Date: Wed, 24 Sep 2014 19:49:25 +0200

All,

Anybody had time to take a look on the new version?
Do we need to specify any charter at this point ? 

Thanks,
Best,
Hosnieh

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Thu, 25 Sep 2014 08:14:13 +0000

Hi Hosnieh and all,

I support your work and believe it's an interesting topic that should be worked in IETF.
Here are my comments:

1. I think SECAUTH intends to provide a authentication mechanism using existing network layer secure tech. In network layer, we must consider NAT issue.
e.g., in section 4.2 Verification of a User to an Application Over the Network，wash machine may supposed to be behind NAT，how does Alice get private IP address of wash machine to authenticate?
 
2. In IOT，one smart device could control another smart device，so there might be a case of verification of a device to a device over constrain network.

3. section 4.5 seems to be describing SDN security. What's the relationship with Verification of an App. To an App. Over Network in the title?

My 2 cents.

Regards,
Will (Shucheng LIU)

> -----Original Message-----
> From: Secauth [mailto:[email-masked]] On Behalf Of Hosnieh
> Rafiee
> Sent: Thursday, September 25, 2014 1:49 AM
> To: [email-masked]
> Subject: Re: [Secauth] secauth - version 2 authentication and authorization
> requirement draft
> 
> All,
> 
> _______________________________________________
> Secauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secauth