Subject: [Secauth] API vs Protocol

From: Hosnieh Rafiee <[email-masked]>
Date: Fri, 19 Sep 2014 13:19:36 +0000

Folks,

Based on some offlist discussions. One of folks suggested me to change secauth to protocol. 

Any thoughts?

I am gonna apply this change in the upcoming version. Share any ideas you might have about this change. I am still improving the document and anyone who is interested can access it via the public link which I shared in my last version (pre-version)

Thanks,
Best,
Hosnieh

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 22 Sep 2014 12:16:40 +0200

Hi Hosnieh,

some time ago there was a fairly good difference between a protocol and
an API, whereby the latter was an implementation dependent concept and
the protocol referred to the on-the-wire content.

This difference got blurred a bit when JavaScript became popular that
combined the API and the protocol components. The introduction of REST
APIs, which has nothing to-do with the actual implementation itself,
didn't help to clarify terminology either.

So, I would suggest you talk about protocol since you are most likely
concerned about the on-the-wire representation anyway.

Ciao
Hannes

On 09/19/2014 03:19 PM, Hosnieh Rafiee wrote:
> _______________________________________________
> Secauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secauth
>

---

From: Hosnieh Rafiee <[email-masked]>
Date: Mon, 22 Sep 2014 11:02:27 +0000

Hi Hannes,

Thanks for your message and sharing your thoughts.

> concerned about the on-the-wire representation anyway.

I agree with your suggestion. You are right, I am more concerned about on-the-wire. 

Best,
Hosnieh