Subject: [secdir] Secdir review of draft-ietf-idnabis-bidi

From: Sam Hartman <[email-masked]>
Date: Tue, 13 Oct 2009 14:46:59 -0400

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.
Feel free to forward to any appropriate forum.

This document describes a new rule for handling bidirectional
attributes of Unicode characters and the bidirectional text wrapping
algorithm.  I am not qualified to evaluate the security implications
of this draft: I do not understand all the implications, and recommend that the security ADs take a close look.

The draft is well written.  Even given my limited information on the
subject, I found the draft relatively clear--or, at least, clear
enough that I understood some of my gaps.

There is one major deficiency in the security considerations section.
The major attack against naming systems is incorrect mappings; in the
case of DNS mappings used by humans this broadly falls into the
category of phishing or other cases where humans are confused into
thinking they have accessed a desired resource but in fact have
accessed some other resource..  Section 3 discusses several
requirements that could not be met and several confusing situations.
However the security considerations section does not discuss the
security implications of this, or even discuss phishing/confusing
names at all.  I'll give the editors some slack here: I have no idea
what to write either.  However it seems like we should write
something.  I think advice from the security ADs on what level of detail would be desired in the security considerations section of this document would be in order.

I found section 3 particularly useful.  I think it is important than
someone who understands this better than I look at the attacks that
are enabled by the requirements that were considered and rejected to
understand how serious they are.

All in all, this is a great document.

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 16 Oct 2009 08:21:45 -0700

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments. Feel free to forward to any appropriate forum.

This document is one of a series of four that make up the revised IDNA protocol (draft-ietf-idnabis-defs, -tables, -protocol, -bidi). The four document are intertwined, so the security considerations for all should be considered at the same time. Having said that, I find no significant issues with the security considerations in any of the four documents, including this one. Given the messy nature of both internationalization and designing user input mechanisms, these documents do the best that they can, and are not noticeably worse (and are hopefully better) than the previous IDNA protocol.