Subject: [secdir] Security area review of draft-ietf-mpls-tp-nm-framework-04

From: "pat cain" <[email-masked]>
Date: Fri, 12 Feb 2010 19:27:29 -0500

Hi,

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

This document provides the network management framework for the
Transport Profile for Multi-Protocol Label Switching (MPLS-TP).

This framework relies on the management terminology from the ITU-T to
describe the management architecture that could be used for an
MPLS-TP management network.

The Security Considerations section is the basis of my comment. I don't
think the first two sentences are sentences. At least I think they need to
be restated to clarify their meaning. The section states: " 
   Provisions to any of the network mechanisms designed to satisfy the
   requirements described herein need to prevent their unauthorized use
   and provide a means for an operator to prevent denial of service
   attacks if those network mechanisms are used in such an attack.

   Solutions need to provide mechanisms to prevent private information
   from being accessed by unauthorized eavesdropping, or being directly
   obtained by an unauthenticated network element, system or user."

Using terminology from the document, I think the paragraphs should really
say something to the effect of:
"Many of the EMF Interfaces (Section 2.3) are critical to proper NE
operation and 
need to be protected from denial of service conditions or attack. The EMF
Interfaces
that use or access private information should be protected from
eavesdropping or being
accessed by unauthorized network elements, systems, or users. 
"
Since the next part of the section points the reader to the ITU and other
RFC documents, it should flow okay.

Although I am by no means an MPLS expert, the rest of the document looked
fine.

[As a side note, normally the term 'unauthorized eavesdropping' is not used.
Eavesdropping is always performed by an unauthorized party; if they are
authorized it's called 'network monitoring'.  ;) ]

Pat Cain

---

From: Scott Mansfield <[email-masked]>
Date: Mon, 15 Feb 2010 12:24:07 -0500

The editor's have reviewed the security directorate's comments and agree to replace the first two paragraphs of Section 8 by the paragraph suggested by Pat (with a slight modification that adds a sentence about who is authorized to access the interfaces)... 

Pat's original suggestion
"Many of the EMF Interfaces (Section 2.3) are critical to proper NE operation and need to be protected from denial of service conditions or attack. The EMF Interfaces that use or access private information should be protected from eavesdropping or being accessed by unauthorized network elements, systems, or users."

The editors proposal...

The ability for the authorized network operator to access EMF interfaces (section 2.3) when needed is critical to proper operation.  Therefore the EMF interfaces need to be protected from denial of service conditions or attack. The EMF Interfaces that use or access private information should be protected from eavesdropping or being accessed by unauthorized network elements, systems, or users.

Regards,
-scott.

-----Original Message-----
From: pat cain [mailto:[email-masked]] 
Sent: Friday, February 12, 2010 7:27 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Security area review of draft-ietf-mpls-tp-nm-framework-04

Hi,

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document provides the network management framework for the Transport Profile for Multi-Protocol Label Switching (MPLS-TP).

This framework relies on the management terminology from the ITU-T to describe the management architecture that could be used for an MPLS-TP management network.

The Security Considerations section is the basis of my comment. I don't think the first two sentences are sentences. At least I think they need to be restated to clarify their meaning. The section states: " 

Using terminology from the document, I think the paragraphs should really say something to the effect of:
"Many of the EMF Interfaces (Section 2.3) are critical to proper NE operation and need to be protected from denial of service conditions or attack. The EMF Interfaces that use or access private information should be protected from eavesdropping or being accessed by unauthorized network elements, systems, or users. 
"
Since the next part of the section points the reader to the ITU and other RFC documents, it should flow okay.

Although I am by no means an MPLS expert, the rest of the document looked fine.

[As a side note, normally the term 'unauthorized eavesdropping' is not used.
Eavesdropping is always performed by an unauthorized party; if they are authorized it's called 'network monitoring'.  ;) ]

Pat Cain