Subject: [secdir] Review of draft-ietf-netconf-4741bis-07

From: Tina Tsou <[email-masked]>
Date: Mon, 07 Feb 2011 18:05:05 -0800

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

It is well written, so only some editorial comments are below.

#1
"
2.2.  Authentication, Integrity, and Confidentiality
...
2.3.  Authentication
...
"

Perhaps the Titles of 2.2 and 2.3 can harmonize better to explain why there
are two "authentications" here.

#2
"
6.2.  Subtree Filter Components

   A subtree filter is comprised of XML elements and their XML
   attributes.  There are five types of components that may be present
   in a subtree filter:

   o  Namespace Selection

   o  Attribute Match Expressions

   o  Containment Nodes

   o  Selection Nodes

   o  Content Match Nodes
...
"

If a figure could be provided to describe the relationship among these 5
components and when it becomes what, it would be very helpful for readers to
understand more easily.

#3
"
6.2.3.  Containment Nodes

   Nodes that contain child elements within a subtree filter are called
   "containment nodes".  

I would say "Child Elements Nodes" or "Child Nodes" might be a little bit
more of straight forward than "Containment Nodes".

#4
"
7.2.  <edit-config>
...
Parameters:
...
merge:  The configuration data in the <config> parameter is
            merged with the configuration at the corresponding level in
            the target datastore.  This is the default behavior.
...
"
Has the <config> parameter been introduced before?

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Tue, 8 Feb 2011 11:06:06 +0100

Tina, thanks for your review and comments

All comments together are being considered by the editors and possibly will
result in a new revision.

We'll keep you updated. But I believe you are also on our netconf wg mailing 
list,
so you'll see it there too.

Bert Wijnen
Document Shepherd

----- Original Message ----- 
From: "Tina Tsou" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Tuesday, February 08, 2011 3:05 AM
Subject: Review of draft-ietf-netconf-4741bis-07

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Mon, 21 Feb 2011 09:21:02 +0100

Revision 9 is out and tried to address IETF LC comments

Here is the diff between the rev you reviewed and the latest one:
    http://tools.ietf.org/rfcdiff?url1=draft-ietf-netconf-4741bis-07&url2=draft-ietf-netconf-4741bis-09
Bert
document shepherd

On 2/8/11 3:05 AM, Tina Tsou wrote:
> 7.2.<edit-config>
> merge:  The configuration data in the<config>  parameter is
> Has the<config>  parameter been introduced before?
>
>
> Best Regards,
> Tina TSOU
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>