Subject: [secdir] Secdir review of draft-ietf-opsawg-oam-overview

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Jul 2011 07:57:11 -0700

Greetings. I am the Secdir reviewer for draft-ietf-opsawg-oam-overview. I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This draft is a comprehensive list of the protocols used for operations, administration, and maintenance of many IETF and non-IETF protocols (basically: monitoring link status). The descriptions go into detail about how each OAM mechanism is used in combination with the protocol it monitors.

The security considerations section reads, in its entirety:
   There are no security implications imposed by this document.
That is probably sufficient, assuming that every OAM mechanism listed does not expose any traffic to the administrator. However, it seems likely that some of the mechanisms might also allow link maintenance, such as turning off some links and starting up others. If that is the case, then this document absolutely needs a discussion of authentication and authorization; if it is not the case, then the NOOP for security considerations is reasonable.

--Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Jul 2011 16:28:21 -0700

On Jul 18, 2011, at 4:17 PM, Tal Mizrahi wrote:

> I understand your point.
> I think we can add a general description (1-2 paragraphs) of the security threats in OAM protocols, and list the security mechanisms defined in the protocols discussed in this document.
> I don't think we want to go into a detailed security threat analysis of EACH of the OAM protocols described in the document, since it is not really the scope of this document.

A short list in the Security Considerations section saying briefly what each OAM protocol currently has for security (even if it is "well, um, none") should be fine for a "catalog" document such as this.

--Paul Hoffman

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 19 Jul 2011 02:17:11 +0300

Hi Paul,

I understand your point.

Please let me know if my suggestion makes sense.

Thanks,
Tal.

-----Original Message-----
From: Paul Hoffman [mailto:[email-masked]] 
Sent: Monday, July 18, 2011 7:57 AM
To: secdir
Cc: [email-masked]
Subject: Secdir review of draft-ietf-opsawg-oam-overview

--Paul Hoffman