Subject: [secdir] SecDir Review of draft-ietf-lisp-alt-09

From: Catherine Meadows <[email-masked]>
Date: Mon, 28 Nov 2011 12:04:01 -0500

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  
These comments were written primarily for the benefit of the security area directors. 
Document editors and WG chairs should treat these comments just like any other last call comments. 

This document describes a distributed index system to be used
by the Locator/ID Separation Protocol (LISP) Ingress Tunnel Router
   (ITR) or Map Resolver (MR) to find the Egress Tunnel Router (ETR)
   which holds the mapping information for a particular Endpoint
   Identifier (EID).  The ITR or MR can then query the ETR to get the
information it needs.  This index, or Alternate Logical Topology, is built as an overlay
network on the Internet using the Border Gateway Protocol (BGP) and the
Generic Routing Encapsulation (GRE).

Since LISP+ALT relies on BGP, the authors correctly point out that that it shares many of
the security characteristics of BGP.  They should be commended, however, for not
merely pointing to the BGP document, but also addressing any new vulnerabilities
that could arise from using LISP+ALT.  These are mainly potential denial-of-service attacks, for which suggested
countermeasures are included.  Another is the
possibility that EID-prefixes would be more vulnerable to leakage since they will be more widely propagated out to
the global network.  The authors point out that addressing this problem requires more strict prefix filtering and authentication
on  the global routing system.  The authors also discuss, in a final paragraph (10.3), the potential use of emerging
BGP security mechanisms that would provide this authentication.

All in all, I think this is a very thorough and well-though-out discussion of the security considerations.  My only suggestion would be to include
a forward reference to paragraph 10.3 in the discussion of prefix leakage.

Catherine Meadows
Naval Research Laboratory
Code 5543
4555 Overlook Ave., S.W.
Washington DC, 20375
phone: 202-767-3490
fax: 202-404-7942
email: [email-masked]

---

From: Vince Fuller <[email-masked]>
Date: Mon, 28 Nov 2011 14:51:07 -0800

Thank you for the review.

> All in all, I think this is a very thorough and well-though-out
> discussion of the security considerations.  My only suggestion would
> be to include a forward reference to paragraph 10.3 in the
> discussion of prefix leakage.

I can certainly add such a reference as part of the forthcoming -10 draft.

Can you be more specific about where you feel that the reference belongs?
It looks like the topic of "route leakage" is mentioned on page 5 in the
Intoduction section, then in section 6.2 where the suggestion of a separate
SAFI for LISP+ALT is made, and, finally, in section 10.1.

	Thanks,
	--Vince

---

From: Catherine Meadows <[email-masked]>
Date: Mon, 28 Nov 2011 18:47:48 -0500

My apologies, I was thinking of the discussion in 10.1.

Cathy

Catherine Meadows

On Nov 28, 2011, at 5:51 PM, Vince Fuller wrote:

> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview

---

From: Vince Fuller <[email-masked]>
Date: Mon, 28 Nov 2011 16:11:27 -0800

> My apologies, I was thinking of the discussion in 10.1.

OK. I added a reference from 10.1 to 10.3 to the -10 draft.

	--Vince