Subject: [secdir] secdir review of draft-ietf-krb-wg-camellia-cts-01

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Thu, 27 Sep 2012 00:24:58 +0000

I have reviewed this document as part of the security directorate's 
ongoing effort to review all IETF documents being processed by the 
IESG.  These comments were written primarily for the benefit of the 
security area directors.  Document editors and WG chairs should treat 
these comments just like any other last call comments.

The only big  issue I see is that the draft uses a different key derivation than the simplified profile in RFC 3961.   What is the reason for this?  Assuming there is a suitable reason for this I think the draft is ready to go with some minor issues. 

1. I think in section 3 random2key should be random-to-key as in section 4.
2. It would be good to reference section 6 for random-to-key and RFC 3961 for k-truncate as well. 
3. Section 6 does not provide an entry for "string-to-key parameter format"
4. The encryption and decryption description in section 6 seems a little incomplete.  In particular the setting of newstate seems to be missing in the encryption.  In the decryption perhaps you should define how newIV is determined.  

Cheers,

Joe

---

From: Sam Hartman <[email-masked]>
Date: Wed, 26 Sep 2012 22:58:20 -0400

>>>>> "Joseph" == Joseph Salowey (jsalowey) <[email-masked]> writes:

This was discussed in the WG.  The simplified profile is showing its
age, and perhaps should be renamed the neither simple nor preferred
profile.
The authors and apparently WG felt that their mechanism represents
better cryptographic practice than the RFC 3961 profile.