Subject: Re: [secdir] secdir review of draft-ietf-lisp-mib

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 20 Jun 2013 22:58:20 +0100

although...

      lispMIBTuningParametersGroup OBJECT-GROUP
          OBJECTS { lispFeaturesMapCacheLimit,
                    lispFeaturesEtrMapCacheTtl
                  }
          STATUS  current
          DESCRIPTION
                  "A collection of writeable objects used to
                   configure LISP behavior and to tune performance."
          ::= { lispGroups 10 }

...might lead one to think that something here is writeable.

Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Warren Kumari
> Sent: 20 June 2013 19:26
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: Warren Kumari
> Subject: secdir review of draft-ietf-lisp-mib
> 
> Be ye not afraid..
> 
> I have reviewed this document as part of the security directorate's
> ongoing effort to review all IETF documents being processed by the
> IESG.  These comments were written primarily for the benefit of the
> security area directors.  Document editors and WG chairs should treat
> these comments just like any other last call comments.
> 
> This draft defines a MIB for monitoring LISP devices.
> This set off the standard "Nooooo. SNMP Write. Noooo.." alarm bells, but
> then I skipped down to the Security Considerations section and saw that
authors
> had anticipated my shrieks of despair and that the draft says that there are
no
> read-write / read-create objects.
> 
> The Security Considerations section seems well written and complete. It makes
a
> suggestion that SNMPv3, with crypto goodness, be used to access this MIB.
> It also claims that there is no exposed objects in the MIB that are considered
> sensitive. I don't LISP, and so don't know what all might be considered
sensitive,
> but from reading most of the descriptions, and applying some common-sense
> the claim seems reasonable.
> 
> -----------
> 
> Two questions / nits:
> 1: The DESCRIPTION for 'lispMIBTuningParametersGroup' says: "A collection of
> writeable objects used to." but these seem Read-only. It is possible I
> misunderstand the description.
> 
> 2: The Security Considerations section points out that SNMP prior to V3
doesn't
> have adequate security, and that there is no control who can GET/**SET**
> things (emphasis mine). I suspect that this was lifted verbatim from e.g
> http://tools.ietf.org/html/rfc5834.
> 
> As there is no set / write in this MIB I think that removing the mention of
setting
> things would be clearer.
> s/to access and GET/SET (read/change/create/delete) the objects/to access the
> objects/
> 
> 
> Apologies for how late this review is. I was filtering the SecDir assignments
into an
> incorrect folder and so missed it completely.
> 
> W
> 
> 
> 
> 
> --
> Some people are like Slinkies......Not really good for anything but they still
bring a
> smile to your face when you push them down the stairs.
>

---

From: Warren Kumari <[email-masked]>
Date: Thu, 20 Jun 2013 18:50:26 -0400

> ...might lead one to think that something here is writeable.

Yup, which I why I mentioned it…

W

--
Life is a concentration camp.  You're stuck here and there's no way out and you can only rage impotently against your persecutors.
                -- Woody Allen

---

From: "Gregg Schudel (gschudel)" <[email-masked]>
Date: Thu, 20 Jun 2013 23:35:24 +0000

> ...might lead one to think that something here is writeable.

thanks all

i'll re-word this in the final - it shouldnt have said that.
(about writable objects)

thanks for pointing it out
(it's amazing how carefully these have been read and yet small
details slip through… ;(

Best regards,
Gregg

--------------------------------------------------------------------
.:|:.:|:. | gregg schudel (ccie#9591) LISP technical marketing engr
  cisco   | mobile: +1 571 332 2222   email: [email-masked]
--------------------------------------------------------------------
cisco corporate legal statement: 
http://www.cisco.com/web/about/doing_business/legal/cri/index.html
--------------------------------------------------------------------

---

From: Uri Blumenthal <[email-masked]>
Date: Fri, 21 Jun 2013 06:16:20 -0500

So what's the problem making these writable under SNMPv3 protection (and stating this requirement)?

Sent from my iPad

On Jun 20, 2013, at 18:35, "Gregg Schudel (gschudel)" <[email-masked]> wrote:

> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 21 Jun 2013 16:00:09 +0100

Writable MIB objects are very out of fashion these days. But the Ops guys should
comment more.

My gripe was only that this Group says they are writable when the object
definitions say they are not.

Adrian

> > details slip through. ;(