Subject: [secdir] secdir review of draft-ietf-trill-directory-framework-06

From: Charlie Kaufman <[email-masked]>
Date: Wed, 7 Aug 2013 17:03:52 +0000

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes a framework for adding a central control mechanism to trill to replace or supplement its autoconfiguring mechanism of dynamically learning the locations of all addresses on the LAN. The specific protocols for supplying and consuming this configuration information will presumably appear in future specs. This sort of configuration control is useful in a datacenter where all connections are carefully configured rather than being plug and play. It is particularly applicable in a "cloud" environment where virtual machines are moved between physical machines by some sort of Virtual Machine Management System that will also assign addresses and place them.

This is a re-review. This latest draft incorporates all of my comments on -05, in particular an expanded description of the security advantages of this approach over the standard autoconfiguration in trill. I have no issues with it. I did find 2 typos:

Page 4 last paragraph: "Both items 3 and 4 above..." There are only three items above. I suspect it should say "Both items 2 and 3 above..."

Page 15 section 7 paragraph 3: "Perhaps S want steal" -> "Perhaps S wants to steal"

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 7 Aug 2013 22:01:21 -0400

Hi Charlie,

On Wed, Aug 7, 2013 at 1:03 PM, Charlie Kaufman <[email-masked]> wrote:
> I have reviewed this document as part of the security directorate's ongoing
> effort to review all IETF documents being processed by the IESG.  These
> comments were written primarily for the benefit of the security area
> directors.  Document editors and WG chairs should treat these comments just
> like any other last call comments.
>
> This document describes a framework for adding a central control mechanism
> to trill to replace or supplement its autoconfiguring mechanism of
> dynamically learning the locations of all addresses on the LAN. The specific
> protocols for supplying and consuming this configuration information will
> presumably appear in future specs. This sort of configuration control is
> useful in a datacenter where all connections are carefully configured rather
> than being plug and play. It is particularly applicable in a "cloud"
> environment where virtual machines are moved between physical machines by
> some sort of Virtual Machine Management System that will also assign
> addresses and place them.
>
> This is a re-review. This latest draft incorporates all of my comments on
> -05, in particular an expanded description of the security advantages of
> this approach over the standard autoconfiguration in trill. I have no issues
> with it. I did find 2 typos:
>
> Page 4 last paragraph: “Both items 3 and 4 above…” There are only three
> items above. I suspect it should say “Both items 2 and 3 above…”

Yes, should be as you suggest.

> Page 15 section 7 paragraph 3: “Perhaps S want steal” -> “Perhaps S wants to
> steal”

Yup, thanks for spotting the typo.

I'd be happy to make those changes and re-post but these are
sufficiently minor that I am not sure I should do that right now...

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]