Subject: [secdir] secdir review of draft-ietf-v6ops-rfc3316bis-03

From: Charlie Kaufman <[email-masked]>
Date: Fri, 30 Aug 2013 21:06:39 +0000

Resending with corrected mailing list name (if replying, please reply to this copy).

From: Charlie Kaufman
Sent: Friday, August 30, 2013 10:10 AM
To: [email-masked]; [email-masked]; [email-masked]'
Subject: secdir review of draft-ietf-v6ops-rfc3316bis-03

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This Informational (if approved) RFC is a cleanup update and refresh of RFC 3316, which discusses how to implement IPv6 on 3GPP Cellular hosts. It incorporates several RFCs that have come out since RFC 3316 along with other clarifications. There is a substantial Security Considerations section dealing with security considerations for dealing with a cellular environment, but this document mostly references other RFCs and does not introduce any security issues of its own.

Minor (non-security) issues:

This document does not use the MUST and SHOULD conventions of most RFCs. I've long believed these were inappropriate for Informational RFCs, but this is the first time I've seen anyone agree with me and remove them.

There are many places where referenced RFCs are not placed in brackets (e.g. "RFC 5095" instead of [RFC5095].

I found 2 typos:
Page 5: "build-in" -> "built-in"
Page 17: "causes no hard" -> "causes no harm"

                --Charlie

---

From: Jouni Korhonen <[email-masked]>
Date: Sat, 31 Aug 2013 22:46:19 +0300

Thanks Charlie for the review. I have corrected the references and the typos. They are actually already visible in the github in-progress version:

https://github.com/jounikor/draft-ietf-v6ops-rfc3316bis/blob/master/draft-ietf-v6ops-rfc3316bis-04.txt

- JOuni

On Aug 31, 2013, at 12:06 AM, Charlie Kaufman <[email-masked]> wrote:

> This document does not use the MUST and SHOULD conventions of most RFCs. I’ve long believed these were inappropriate for Informational RFCs, but this is the first time I’ve seen anyone agree with me and remove them.
>  
> There are many places where referenced RFCs are not placed in brackets (e.g. “RFC 5095” instead of [RFC5095].
>  
> I found 2 typos:
> Page 5: “build-in” -> “built-in”
> Page 17: “causes no hard” -> “causes no harm”
>  
>                 --Charlie
>