Subject: [secdir] SecDir review of draft-ietf-dime-app-design-guide-19

From: Yoav Nir <[email-masked]>
Date: Wed, 18 Sep 2013 11:10:44 +0000

Do not be alarmed.  I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

Summary: The document is ready for publication

This informational document provides guidance on extending Diameter applications and on creating new ones. It contains advice such as to re-use existing commands and AVPs, considerations for adding and deleting commands and AVPs, and accounting.

Section 5.11 talks about Diameter security mechanisms: (D)TLS or IPsec. Some might dislike that it still mentions IKEv1. I'm not sure why this section is necessary at all, as these security mechanisms apply to the base protocol rather than any particular extension.

There is a 2-page section dealing with registration considerations, but only a very short paragraph for security considerations. That section pretty much says that extensions may be related to security functionality, but the document does not give guidance on enhancing Diameter with respect to security. I agree that this is OK, and new security functionality should specify its own considerations. I do wonder, though, whether it makes sense to include advice about the content in new data and applications as it relates to security, specifically as it relates to data leakage or data aggregation or user privacy.

Nit:

Second sentence in the security considerations section:
OLD:
 Although such an extension may related to security functionality,
NEW:
 Although such an extension may be related to security functionality,

Yoav

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 18 Sep 2013 16:38:56 +0300

Thanks Yoav,

I'll make sure the authors provide enough reasoning if they intend keeping IKEv1 in the document.

We also try to figure out whether expanding security considerations on the points you mention would be justified within the context of this document.

- Jouni