Subject: [secdir] Review of draft-ietf-tictoc-security-requirements-05

From: Shawn M Emery <[email-masked]>
Date: Tue, 29 Oct 2013 01:18:05 -0600

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security
area directors. Document editors and WG chairs should treat these
comments just like any other last call comments.

This internet-draft describes the threat analysis for time protocols, such as
Precision Time Protocol (PTP) and the Network Time Protocol (NTP).

The draft itself discusses security considerations.  I believe the draft adequately
covers the various threats and how to mitigate such attacks.  I just have a few
comments below:

In regards to this paragraph in section 5.1.3:
    Authentication of slaves prevents unauthorized clocks from receiving
    time services. Preventing the master from serving unauthorized clocks
    can help in mitigating DoS attacks against the master. Note that the
    authentication of slaves might put a higher load on the master than
    serving the unauthorized clock, and hence this requirement is a
    SHOULD.

I think that this requirement of whether to allow for unauthorized clocks
should be a MAY (as does the prior text in this section) and should state
that the decision to do this should be based on the environment in which
the master and slaves are deployed.

In regards to this paragraph in section 5.2.1:
    The requirement level of the first requirement is 'SHOULD' since in
    the presence of recursive authentication (Section 5.1.2.) this
    requirement may be redundant.

This should state that this is the "second requirement", not the "first requirement".

In section 5.5.1 what's the difference between a replay and playback attack?  If there
is such a difference then playback needs to be defined.

In section 5.8, interception attacks is never explicitly described.

I don't understand this sentence:

The erroneous time may expose cryptographic
    algorithms that rely on time to prevent replay attacks.

Does this mean to say "security protocols" instead of "cryptographic algorithms"?

General comments:

None.

Editorial comments:

s/if a slave is/if a slave/

s/(Section 3.2.4.
    )/(Section 3.2.4.)/

s/Additional measure/Additional measures/

Looks like this sentence was truncated:

    The requirements in this subsection address MITM attacks such as the
    3.2.1.).

s/necessarily possible/possible/

s/5.1. ,/Section 5.1.,/

s/in the literature/in literature/

s/in [1588IPsec] and [Tunnel]/[1588IPsec] and [Tunnel]/

Shawn.
--

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 31 Oct 2013 09:58:31 +0200

Hi Shawn.

Thanks for your comments. 
We will accommodate them in the next draft.

Thanks,
Tal.

-----Original Message-----
From: Shawn M Emery [mailto:[email-masked]] 
Sent: Tuesday, October 29, 2013 9:18 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Review of draft-ietf-tictoc-security-requirements-05

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

This internet-draft describes the threat analysis for time protocols, such as Precision Time Protocol (PTP) and the Network Time Protocol (NTP).

The draft itself discusses security considerations.  I believe the draft adequately covers the various threats and how to mitigate such attacks.  I just have a few comments below:

I think that this requirement of whether to allow for unauthorized clocks should be a MAY (as does the prior text in this section) and should state that the decision to do this should be based on the environment in which the master and slaves are deployed.

In section 5.5.1 what's the difference between a replay and playback attack?  If there is such a difference then playback needs to be defined.

General comments:

None.

Editorial comments:

s/(Section 3.2.4.
    )/(Section 3.2.4.)/

s/5.1. ,/Section 5.1.,/

Shawn.
--