Subject: [secdir] SecDir review of draft-ietf-pce-vendor-constraints

From: Warren Kumari <[email-masked]>
Date: Fri, 29 Nov 2013 17:03:23 -0500

Be ye not afraid...
I have reviewed this document as part of the security directorate's 
ongoing effort to review all IETF documents being processed by the 
IESG.  These comments were written primarily for the benefit of the 
security area directors.  Document editors and WG chairs should treat 
these comments just like any other last call comments.

Summary: LGTM.

Version reviewed:
Conveying Vendor-Specific Constraints in the Path Computation
Element communication Protocol
draft-ietf-pce-vendor-constraints-11.txt

Notes: I did *not* perform a formal language check. At a quick glance it looks good though.

Nits: I would like to have a table of contents. This may be a personal preference though….

While performing this review I kept thinking "Mwahaha. This can be used to carry
arbitrary information with any PCEP object that supports TLVs....  I can kvetch about the
DoS potential". But, the authors foiled my plan to rant by mentioning this in the 
Security Considerations section and even mentioning a mitigation.
Curses! Foiled again.

W

-- 
Outside of a dog, a book is your best friend, and inside of a dog, it's too dark to read

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 29 Nov 2013 22:24:41 -0000

Thanks Warren,

Sorry to have disappointed you.

Adrian

> -----Original Message-----
> From: Warren Kumari [mailto:[email-masked]]
> Sent: 29 November 2013 22:03
> To: [email-masked]; [email-masked]
> Cc: Warren Kumari
> Subject: SecDir review of draft-ietf-pce-vendor-constraints
> 
> Be ye not afraid...
> Nits: I would like to have a table of contents. This may be a personal
preference
> though..
> arbitrary information with any PCEP object that supports TLVs....  I can
kvetch
> about the
> Outside of a dog, a book is your best friend, and inside of a dog, it's too
dark to
> read