Subject: [secdir] Security directorate review of draft-ietf-ccamp-oam-configuration-fwk

From: Magnus Nyström <[email-masked]>
Date: Sat, 4 Jan 2014 17:31:41 -0800

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area
directors. Document editors and WG chairs should treat these comments just
like any other last call comments.

This document describes extensions to RSVP-TE in support of the
establishment of Operation, Administration and Management entities in the
context of GMPLS .

The document seems well written. I would suggest removing the last sentence
of the Security Considerations section ("Cryptography can be used...")
since it does not really offer any hint as to how to use cryptography.
Instead, the previous sentence could be replaced with something like: "For
a more comprehensive discussion of GMPLS security, and attack mitigation
techniques, please see the Security Framework for MPLS and GMPLS Networks [
RFC5920 <http://tools.ietf.org/html/rfc5920>]."

-- Magnus

---

From: Attila Takacs <[email-masked]>
Date: Sun, 12 Jan 2014 06:43:05 +0000

Hi Magnus,
Thanks for the review!
We will update the Security section based on your proposal below.
Attila

From: Magnus Nyström [mailto:[email-masked]]
Sent: Saturday, January 04, 2014 5:32 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Security directorate review of draft-ietf-ccamp-oam-configuration-fwk

 I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes extensions to RSVP-TE in support of the establishment of Operation, Administration and Management entities in the context of GMPLS .

The document seems well written. I would suggest removing the last sentence of the Security Considerations section ("Cryptography can be used...") since it does not really offer any hint as to how to use cryptography. Instead, the previous sentence could be replaced with something like: "For a more comprehensive discussion of GMPLS security, and attack mitigation techniques, please see the Security Framework for MPLS and GMPLS Networks [RFC5920<http://tools.ietf.org/html/rfc5920>]."

-- Magnus