Subject: [secdir] Secdir review of draft-ietf-manet-nhdp-olsrv2-tlv-extension-01

From: Tero Kivinen <[email-masked]>
Date: Mon, 10 Feb 2014 16:05:32 +0200

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

This document seems to fix some cases in the NHDP and OLSRv2 TLVs
where the original document might have been considered saying that
unknown values in the TLVs can be used as a reason to reject message.
This document makes it clear how unknown values in the TLVs needs to
be processed. This document also creates several IANA registries for
the TLV values and changes couple of the TLV values from numbers to
bitfields (the existing values were already allocated so that the
numbers can be parsed as bitfield).

Security considerations section mentions that as this does not really
change the current implementations, it more or less describes how new
extensions should be processed with implementations it does not add
any new security considerations. New extensions might of course add
new security considerations but those should be addressed in the
documents which make those extensions.

The document is ready with nits.

Some nits:

In the IANA considerations section the IANA is used both in singular
and plural, i.e. it says both "IANA is requested" and "IANA are
requested". This should be fixed to say "IANA is requested". 
-- 
[email-masked]

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 10 Feb 2014 15:22:49 +0100

Thank you, Tero, for your review. 

As the non-native English speaker among the authors, thank you for your catch on the is/are in the IANA section...I am afraid that I have to assume that the fault there lies with me....

Respectfully,

Thomas

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 10 Feb 2014 16:07:16 +0000

Thanks you for your review and comments. IANA want a bit more clarity in their section, so we'll roll your nit in with that.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Tero Kivinen [mailto:[email-masked]] 
Sent: 10 February 2014 14:06
To: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir review of draft-ietf-manet-nhdp-olsrv2-tlv-extension-01

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document seems to fix some cases in the NHDP and OLSRv2 TLVs where the original document might have been considered saying that unknown values in the TLVs can be used as a reason to reject message.
This document makes it clear how unknown values in the TLVs needs to be processed. This document also creates several IANA registries for the TLV values and changes couple of the TLV values from numbers to bitfields (the existing values were already allocated so that the numbers can be parsed as bitfield).

Security considerations section mentions that as this does not really change the current implementations, it more or less describes how new extensions should be processed with implementations it does not add any new security considerations. New extensions might of course add new security considerations but those should be addressed in the documents which make those extensions.

Some nits:

In the IANA considerations section the IANA is used both in singular and plural, i.e. it says both "IANA is requested" and "IANA are requested". This should be fixed to say "IANA is requested". 
--
[email-masked]

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************