Subject: Re: [secdir] Secdir review of [email-masked]

From: "Haleplidis Evangelos" <[email-masked]>
Date: Wed, 1 Oct 2014 14:15:49 +0300

Greetings Magnus,

Having discussed the issue with Joel, in order to clarify the text you pointed out, we opted to replace the problematic sentence from:

“However as parallezation tasks have security issues, a designer or an implementer must take into account any security considerations that regards packet parallelization.”

To:

“This document does not attempt to analyze the presence or possibility of security interactions created by allowing parallel operations on packets.  Any such issues, if they exist, are for the designers of the particular data path, not the general mechanism.”

This way, we clearly state (the previous sentence didn’t manage to convey that meaning) that security considerations are for implementers and not for the general mechanisms we specify in the draft.

Does this resolve your comment?

Regards,

Evangelos.

From: Magnus Nyström [mailto:[email-masked]] 
Sent: Tuesday, September 30, 2014 9:26 AM
To: [email-masked]; [email-masked]
Subject: Secdir review of [email-masked]

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes how ForCES can model a network device's parallelization datapath to support parallel packet processing in the ForCES model. The document is intended to be published as an Experimental RFC.

Since the document does not change the ForCES model or the ForCES protocol, I agree with the Security Consideration section's statement that there's no impact on the security considerations for them. However, the document then goes on to state "However as parallezation [sic] tasks have security issues, a designer or an implementer must take into account any security considerations that regards packet parallelization." I don't know specifically what such security issues are in the context of parallel ForCES packet processing, and it seems that it would be good to include at least some example of them and how implementers should take them into account.

-- Magnus

---

From: <[email-masked]>
Date: Wed, 1 Oct 2014 14:41:15 +0000

Thanks Evangelos,

That sounds good with me as long as it is the case that ForCES packet parallelization in itself doesn’t present new security issues. If however there are known such issues then I think the draft should describe them.

Best,

Sent from Windows Mail

From: Haleplidis Evangelos
Sent: ‎Wednesday‎, ‎1‎ ‎October‎, ‎2014 ‎04‎:‎15
To: Magnus Nyström, [email-masked], [email-masked]

Greetings Magnus,

To:

Regards,

Evangelos.

 

 

 

-- Magnus

---

From: Joel Halpern <[email-masked]>
Date: Wed, 1 Oct 2014 15:02:21 +0000

There are not any known issues of this sort.
Yours,
Joel

________________________________
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, October 01, 2014 10:41 AM
To: Haleplidis Evangelos; [email-masked]; [email-masked]
Subject: Re: Secdir review of [email-masked]

Thanks Evangelos,

Sent from Windows Mail

From: Haleplidis Evangelos<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎1‎ ‎October‎, ‎2014 ‎04‎:‎15
To: Magnus Nyström<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Greetings Magnus,

Regards,
Evangelos.

-- Magnus