Subject: [secdir] Secdir review of [email-masked]

From: Charlie Kaufman <[email-masked]>
Date: Thu, 23 Oct 2014 23:24:29 -0700

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

This document specifies a conceptually minor change to the MANET
Neighborhood Discovery Protocol (NHDP) (RFC6130). It is a backwards
compatible optimization allowing neighbors accessible over links of marginal
quality to be processed more efficiently in the case where communication
bounces up and down due to the marginal link quality. It extends an
optimization already specified in RFC6130 for one-hop neighbors to also
apply to two-hop neighbors.

The security considerations section says that this change introduces no
additional security considerations beyond those in RFC6130, and I agree. If
anything, this change reduces the potential of one kind of an attack where a
node simulates a bouncing link to consume excessive resources on the target.
But I don't believe this minor security advantage is worth mentioning. it is
a consequence of the main point of the change which is to improve
performance (mostly responsiveness).

                --Charlie

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 24 Oct 2014 09:19:57 +0000

Charlie

Thank you for your comments. I note that the minor improvement you note was also made by our AD, one of the authors has already indicated that, like you, he feels the gain is minor and not worth calling out.

Christopher

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: Charlie Kaufman [mailto:[email-masked]]
Sent: 24 October 2014 07:24
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Secdir review of [email-masked]

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document specifies a conceptually minor change to the MANET Neighborhood Discovery Protocol (NHDP) (RFC6130). It is a backwards compatible optimization allowing neighbors accessible over links of marginal quality to be processed more efficiently in the case where communication bounces up and down due to the marginal link quality. It extends an optimization already specified in RFC6130 for one-hop neighbors to also apply to two-hop neighbors.

The security considerations section says that this change introduces no additional security considerations beyond those in RFC6130, and I agree. If anything, this change reduces the potential of one kind of an attack where a node simulates a bouncing link to consume excessive resources on the target. But I don't believe this minor security advantage is worth mentioning... it is a consequence of the main point of the change which is to improve performance (mostly responsiveness).

                --Charlie

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************