Subject: [secdir] Secdir review of draft-ietf-mpls-oam-ipv6-rao-02

From: Vincent Roca <[email-masked]>
Date: Thu, 29 Jan 2015 20:35:52 +0100

Hello,

I have reviewed this document as part of the security directorate’s ongoing
effort to review all IETF documents being processed by the IESG. These
comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

Summary: ready

This document specifies a new Router Alert Option Value for IPv6, to be used
by MPLS OAM tools in IPv6 environments.
It does not introduce any new mechanism that is likely to create security
threats. Additionally, RFC 6398 discusses the security aspects of IP Router
Alert in detail. The Security Considerations section of the present document
refers to this (and related RFCs) for security aspects which I think is appropriate.

Non-Security comments:

** The Introduction uses several terms that appear to me synonymous, namely:
       generic Option Value
       generic IPV6 Router Alert code point
       Value field in the Router Alert Option
       IPv6 Router Alert Option Value
And later in Section 3:
       option value            (i.e., without any upper case letter)
Or in Section 6:
       defines a new code point (value TBD1)
It's worth to harmonize them.

** Section 5: there's probably a missing word in:
       "...examine the packet the MPLS OAM purpose."

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 29 Jan 2015 19:50:00 -0000

Thanks Vincent. Good nits.
Adrian

> -----Original Message-----
> From: iesg [mailto:[email-masked]] On Behalf Of Vincent Roca
> Sent: 29 January 2015 19:36
> To: IESG; [email-masked]; [email-masked]
> Cc: Vincent Roca
> Subject: Secdir review of draft-ietf-mpls-oam-ipv6-rao-02
> 
> Hello,
> 
> I have reviewed this document as part of the security directorate's ongoing

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 30 Jan 2015 14:26:40 +0000

Thanks indeed, Vincent. 

Adrian, we fixed these two nits in our working copy.

Thanks,

— Carlos.

> On Jan 29, 2015, at 2:50 PM, Adrian Farrel <[email-masked]> wrote:
>