Subject: [secdir] Review of draft-ietf-ccamp-rwa-wson-encode-27

From: Shawn M Emery <[email-masked]>
Date: Mon, 23 Feb 2015 00:02:45 -0700

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security
area directors. Document editors and WG chairs should treat these
comments just like any other last call comments.

The draft specifies an encoding scheme for information on a Wavelength Switched Optical Network
(WSON).  Specifically, information that is used for Routing and Wavelength Assignment (RWA).

The security considerations section does exist and discloses that the draft does not impose
any security considerations in itself, but does admit that documents that reference this draft
would have considerations for privacy, spoofing, and tampering of any associated data.  I agree
with this assertion.

General comments:

None.

Editorial comments:

Usually the Abstract is the first section in the draft.
The abbreviations should have the expanded word with the corresponding capital letter.
GMPLS is not initially expanded in the Abstract section.
s/RB identifier./RB identifiers./

Shawn.
--

---

From: Dacheng <[email-masked]>
Date: Thu, 26 Feb 2015 17:30:22 +0800

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the  security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document specifies a registry of label format specifications.

I didn’t see any security issues in this document and consider it Ready To Publish.

Cheers

Dacheng