Subject: [secdir] Secdir review of draft-wkumari-dhc-capport-13

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 7 Jul 2015 08:47:41 +0100

I have reviewed this document as part of the security directorate's effort to review all IETF documents being processed by the IESG.

These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comment.

This document communicates the presence of a captive portal in a WiFi network using DHCP and RAs.

Recommendation:  Ready

The motivation of the document makes sense, namely to avoid interception of traffic, and the document is an easy extension to already available mechanisms (RA/DHCP). I was expecting to see a reference to Hotspot 2.0, which aims to make the interaction between hotspot providers and end devices more intelligent (but covers a much larger scope).

Minor nit:

In Section 4 you write:

"This document defines two DHCP Captive-Portal options, one for IPv6

   and one for IPv6."

It should of course read "..., one for IPv4 and one for IPv6."

Ciao

Hannes

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2548782

---

From: Warren Kumari <[email-masked]>
Date: Wed, 8 Jul 2015 11:28:58 -0400

[ Off-list ]

On Tue, Jul 7, 2015 at 3:47 AM, Hannes Tschofenig
<[email-masked]> wrote:
> I have reviewed this document as part of the security directorate's effort
> to review all IETF documents being processed by the IESG.
>
> These comments were written primarily for the benefit of the security area
> directors.  Document editors and WG chairs should treat these comments just
> like any other last call comment.
>

Thank you for the review....

> The motivation of the document makes sense, namely to avoid interception of
> traffic, and the document is an easy extension to already available
> mechanisms (RA/DHCP). I was expecting to see a reference to Hotspot 2.0,
> which aims to make the interaction between hotspot providers and end devices
> more intelligent (but covers a much larger scope).

I originally had this as an editor's note:
https://github.com/wkumari/draft-wkumari-dhc-capport/blob/de293471faef562517978b709aaca762d1d78dbe/README.md

"[ Ed note: This solution is somewhat similar / complements 802.11u /
   WiFi Passpoint Online Sign-up, but is much simpler, easier to deploy,
   and works on wired as well ]
"

I spent some time looking at the Hotspot 2.0 stuff, but after slogging
through much 4 color glossy type material it seemed that it more
allowed you to use different reaming providers / snap a RADIUS
connection back to another provider. I even spent some $$$ on
purchasing a spec, which I found largely unintelligible.
So, I decided to remove the vague / editorial note... :-)

If you happen to have any suggested text I'm happy to stick it in...

>
>
>
> Minor nit:
>
>
>
> In Section 4 you write:
>
>
>
> “This document defines two DHCP Captive-Portal options, one for IPv6
>
>    and one for IPv6.”
>
>
>
> It should of course read “…, one for IPv4 and one for IPv6.”

Thanks. I've fixed it in the editor version.

W

>
>
>
> Ciao
>
> Hannes
>
>
>
>
> -- IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ,
> Registered in England & Wales, Company No: 2557590
> ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ,
> Registered in England & Wales, Company No: 2548782
>
> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview
>

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

On Tue, Jul 7, 2015 at 3:47 AM, Hannes Tschofenig
<[email-masked]> wrote:
> I have reviewed this document as part of the security directorate's effort
> to review all IETF documents being processed by the IESG.
>
> These comments were written primarily for the benefit of the security area
> directors.  Document editors and WG chairs should treat these comments just
> like any other last call comment.
>
>
>
> The motivation of the document makes sense, namely to avoid interception of
> traffic, and the document is an easy extension to already available
> mechanisms (RA/DHCP). I was expecting to see a reference to Hotspot 2.0,
> which aims to make the interaction between hotspot providers and end devices
> more intelligent (but covers a much larger scope).
>
>
>
> Minor nit:
>
>
>
> In Section 4 you write:
>
>
>
> “This document defines two DHCP Captive-Portal options, one for IPv6
>
>    and one for IPv6.”
>
>
>
> It should of course read “…, one for IPv4 and one for IPv6.”
>
>
>
> Ciao
>
> Hannes
>
>
>
>
> -- IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ,
> Registered in England & Wales, Company No: 2557590
> ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ,
> Registered in England & Wales, Company No: 2548782
>
> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview
>

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf