Subject: [secdir] Sec-Dir Review: draft-mm-netconf-time-capability-05.tx

From: Olafur Gudmundsson <[email-masked]>
Date: Wed, 29 Jul 2015 17:15:51 -0400

I have reviewed this document as part of the security directorate's 
ongoing effort to review all IETF documents being processed by the 
IESG.  These comments were written primarily for the benefit of the 
security area directors.  Document editors and WG chairs should treat 
these comments just like any other last call comments.

This document is ready for publication
The document is well written.

The security considerations are clear and accurate. I would like highlight one omission though.  
This capability allows an attacker once it has gained access to schedule events in the future even 
though attackers access has been detected and revoked. 

Olafur

---

From: Andy Bierman <[email-masked]>
Date: Wed, 29 Jul 2015 14:39:42 -0700

Hi,

I am curious if this is a security concern.
When an event is scheduled, the ID and its scheduled time
are sent out in a notification to potentially all clients.

notification netconf-scheduled-message {
        leaf schedule-id {
          type string;
          description
            "The ID of the scheduled message.";
        }

        leaf scheduled-time {
          type yang:date-and-time;
          description
            "The time at which the RPC is scheduled to be performed.";
        }

        description
          "Indicates that a scheduled message was received.";

        reference
          "draft-mm-netconf-time-capability
<https://tools.ietf.org/html/draft-mm-netconf-time-capability>:
           Time Capability in NETCONF";
      }

Any client can get these notifications and know the ID (to cancel it)
and the scheduled time.

Is is a security issue that any client can get the schedule-id
and use it to cancel the scheduled RPC?

Andy

On Wed, Jul 29, 2015 at 2:15 PM, Olafur Gudmundsson <[email-masked]> wrote:

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 30 Jul 2015 06:43:02 +0000

Hi Andy,

You make a good point.
We intend to add text (see below) that describes this point in the next version of the draft.
Please let us know if you have further comments.

Here is the updated text on the last paragraph of the security section:

This YANG module defines the <cancel-schedule> RPC. This RPC may be considered sensitive or vulnerable in some network environments. Since the value of the <schedule-id> is known to all the clients that are subscribed to notifications from the server, the <cancel-schedule> RPC may be used maliciously to attack servers by canceling their pending RPCs. This attack is addressed in two layers: (i) security at the transport layer, limiting the attack only to clients that have successfully initiated a secure session with the server, and (ii) the authorization level required to cancel an RPC should be the same as the level required to schedule it, limiting the attack only to attackers with an authorization level that is equal to or higher than that of the client that initiated the scheduled RPC.

Thanks,
Tal.

From: Netconf [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Thursday, July 30, 2015 12:40 AM
To: Olafur Gudmundsson
Cc: [email-masked]; [email-masked]; ietf; Netconf
Subject: Re: [Netconf] Sec-Dir Review: draft-mm-netconf-time-capability-05.tx

Hi,

        leaf schedule-id {

          type string;

          description

        }

        leaf scheduled-time {

          type yang:date-and-time;

          description

        }

        description

        reference

          "draft-mm-netconf-time-capability<https://tools.ietf.org/html/draft-mm-netconf-time-capability>:

      }

Andy

On Wed, Jul 29, 2015 at 2:15 PM, Olafur Gudmundsson <[email-masked]<mailto:[email-masked]>> wrote:

Olafur

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 30 Jul 2015 06:44:26 +0000

Hi Olafur,

Thanks for the feedback.

>though attackers access has been detected and revoked.

We will add a paragraph that describes this potential threat to the next version of the draft.

Thanks,
Tal.

From: Netconf [mailto:[email-masked]] On Behalf Of Olafur Gudmundsson
Sent: Thursday, July 30, 2015 12:16 AM
To: ietf; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [Netconf] Sec-Dir Review: draft-mm-netconf-time-capability-05.tx

Olafur