Subject: [secdir] SecDir Review of draft-ietf-ace-usecases

From: Adam Montville <[email-masked]>
Date: Mon, 12 Oct 2015 09:02:01 -0500

Hi.

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

Draft is Ready with nits and one possible issue.

This draft seems to provide a good set of use cases collectively representing the lifecycle of constrained devices up to and including decommissioning.  

While the draft does mention “configuration”, the context is more about ensuring flexibility of expressing access permissions.  I’m not sure if this draft requires something like the following, but it would be beneficial for downstream operational processes to explicitly support endpoint posture assessment.  This could be done by providing an explicit posture-related interface.  Such a requirement could be alluded to in the Security Considerations section.  On the other hand, this may be something addressed by CoAP and other drafts.

Nits (against -09):

Second paragraph of 3.1: You might consider adding a sentence indicating whether developers are expected to do anything after becoming familiar with RFC7258.

Third paragraph of 3.1: Formatting issue after first sentence - second sentence is on a new line, or the second sentence was intended to start a new paragraph.

Third paragraph of 3.1: s/attacks/attack/

Fifth paragraph of 3.1: Formatting issue after second sentence - third sentence is on a new line, or the third sentence was intended to start a new paragraph.

Kind regards,

Adam

---

From: Stefanie Gerdes <[email-masked]>
Date: Fri, 23 Oct 2015 11:43:36 +0200

Hi Adam,

Thank you for your comments.

> While the draft does mention “configuration”, the context is more about ensuring flexibility of expressing access permissions.  I’m not sure if this draft requires something like the following, but…

The draft focuses on listing use cases and resulting authorization
problems. Therefore, all items listed in the sections 3.2, 3.3 and 3.4
derive from the problems summary sections. We tried very hard to steer
clear of listing solutions for these problems while still providing
useful guidance for solution developers. Thus, the draft does not
provide details on where configuration data might be coming from.
Therefore, we would rather not include this comment.

We will fix the Nits that you pointed out.

Thanks
Steffi