Subject: [secdir] secdir review of draft-ietf-nfsv4-minorversion2-39

From: "Scott G. Kelly" <[email-masked]>
Date: Sun, 29 Nov 2015 07:10:48 -0800 (PST)

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This doc describes minor version 2 updates to NFSv4. There are 6 new operations/features supported: Server Side Copy, Application I/O Advise, Space Reservations, Sparse Files, Application Data Blocks, and Labeled NFS.

Consistent with other NFS docs, security considerations specific to an operation are described in the section for that operation. Server Side Copy and Labeled NFS each contain their own sub-sections.

The main security considerations section states that this revision has all the security considerations of NFS version 4.1 (referencing RFC5661), and also refers to the feature-specific discussions in previous sections.
 
I didn't find any issues not already addressed by the security considerations in this and referenced docs. 

--Scott

---

From: Tom Haynes <[email-masked]>
Date: Sun, 29 Nov 2015 10:57:47 -0500

> On Nov 29, 2015, at 10:10 AM, Scott G. Kelly <[email-masked]> wrote:
> 

Thanks for the review Scott.