Subject: [secdir] secdir review of draft-ietf-ippm-active-passive-05

From: Carl Wallace <[email-masked]>
Date: Sun, 17 Jan 2016 13:44:49 -0500

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments
just like any other last call comments.

This draft aims to provide clear definitions for Active and Passive
performance assessment as well as defining Hybrid methods and establishing
means of evaluating new methods as they emerge. The document relies
heavily on textual references to other specifications, which can at times
be a bit tedious for the reader but I have no particular suggestions
regarding this point and it's probably fine for a document that is aiming
to corral various earlier concepts. The referenced security and privacy
considerations were very good (if nearly as long as this spec itself). One
minor point, section 4.2 might be better placed before the current section
4.1 to better set-up the ASCII art in section 4.1.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 20 Jan 2016 10:44:00 -0600

Hi, Carl,

> 4.1 to better set-up the ASCII art in section 4.1.

Thanks for the review!

Could the authors let me know if the 4.1/4.2 section switch should happen?
No need to submit a revision about that until after the telechat tomorrow,
if the answer is "yes".

Spencer

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 20 Jan 2016 12:03:24 -0500

Hi Carl, thanks for your review.

Carl and Spencer,

I think the issue is that “PDM” appears in the
(ASCII Art) Figure in section 4.1,
without explaining what PDM is (that happens in 4.2).
The alternative is to expand a bit on PDM in the explanation
of the Figure in 4.1.  This way we can leave all the
methods together following the 4.1 Graphical Representation
section (with the ASCII art).

   4<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4>.  Discussion  . . . . . . . . . . . . . . . . . . . . . . . . .   8<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-8>
     4.1<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.1>.  Graphical Representation  . . . . . . . . . . . . . . . .   8<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-8>
     4.2<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.2>.  Discussion of PDM . . . . . . . . . . . . . . . . . . . .  10<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-10>
     4.3<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.3>.  Discussion of "Coloring" Method . . . . . . . . . . . . .  11<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-11>
     4.4<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.4>.  Brief Discussion of OAM Methods . . . . . . . . . . . . .  11<https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-11>

Ok?
Al

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Wednesday, January 20, 2016 11:44 AM
To: Carl Wallace
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: secdir review of draft-ietf-ippm-active-passive-05

Hi, Carl,

On Sun, Jan 17, 2016 at 12:44 PM, Carl Wallace <[email-masked]<mailto:[email-masked]>> wrote:

Thanks for the review!

Could the authors let me know if the 4.1/4.2 section switch should happen? No need to submit a revision about that until after the telechat tomorrow, if the answer is "yes".

Spencer

---

From: Carl Wallace <[email-masked]>
Date: Wed, 20 Jan 2016 12:10:25 -0500

Works for me.

From:  "MORTON, ALFRED C (AL)" <[email-masked]>
Date:  Wednesday, January 20, 2016 at 12:03 PM
To:  Spencer Dawkins at IETF <[email-masked]>, Carl Wallace
<[email-masked]>
Cc:  "[email-masked]"
<[email-masked]>, "[email-masked]"
<[email-masked]>, "[email-masked]" <[email-masked]>
Subject:  RE: secdir review of draft-ietf-ippm-active-passive-05

>    4 <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4>
> .  Discussion  . . . . . . . . . . . . . . . . . . . . . . . . .   8
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-8>
>      4.1 
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.1> .
> Graphical Representation  . . . . . . . . . . . . . . . .   8
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-8>
>      4.2 
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.2> .
> Discussion of PDM . . . . . . . . . . . . . . . . . . . .  10
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-10>
>      4.3 
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.3> .
> Discussion of "Coloring" Method . . . . . . . . . . . . .  11
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-11>
>      4.4 
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#section-4.4> .
> Brief Discussion of OAM Methods . . . . . . . . . . . . .  11
> <https://tools.ietf.org/html/draft-ietf-ippm-active-passive-05#page-11>
>  
> Ok?
> Al
>  
>  
> 
> Could the authors let me know if the 4.1/4.2 section switch should happen? No
> need to submit a revision about that until after the telechat tomorrow, if the
> answer is "yes".
> 
>  
> 
> Spencer