Subject: [secdir] Review of draft-ietf-tcpm-undeployed-03

From: Shawn M Emery <[email-masked]>
Date: Fri, 08 Jan 2016 20:49:39 -0700

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security
area directors. Document editors and WG chairs should treat these
comments just like any other last call comments.

This draft designates a number of TCP related RFCs to Historic or Informational
status.  The corresponding RFCs have either been superseded, not widely adopted,
or no longer recommended.

The security considerations section does exist and states that this RFC
does not introduce any new considerations.  The section goes on to say that
any security aspects of the RFC are applicable to the RFCs in question.  I
agree with these assertions.

General comments:

None.

Editorial comments:

s/which which describes/which describes/

Shawn.
--

---

From: Dacheng <[email-masked]>
Date: Mon, 11 Jan 2016 20:14:16 +0800

I have reviewed this document as part of the security directorate’s ongoing effort to review all IETF documents being processed by the IESG.

These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

This document defines a media type for a YANG-based editing mechanism that can be used with the HTTP PATCH method.

I agree that this mechanism does not introduce any new security issues, beyond what is described in [I-D.ietf-netconf-restconf]. So, this draft is almost ready for publication. 

A question:

In Section 2.6  you mentioned 'The server will save the running datastore to non-volatile storage' . Do you assume the severs supporting your mechanism always have non-volatile storage?

An editorial comment:
page 15:
The 'value' node will contain one instance of foo:-> The 'value' node contains one instance of foo:

Cheers

Dacheng