Subject: [secdir] SecDir review of draft-ietf-taps-transports-usage

From: "Paul Hoffman" <[email-masked]>
Date: Mon, 05 Sep 2016 16:28:26 -0700

Greetings. draft-ietf-taps-transports-usage, "On the Usage of Transport 
Service Features Provided by IETF Transport Protocols" is an 
informational overview of how TCP, MCTCP, and SCTP interact with 
applications. It is strictly descriptive and doesn't define anything 
new.

Because this is just describes existing protocols, there are no new 
security considerations. However, the current Security Considerations 
section says:
    Security will be considered in future versions of this document.
It is not clear if the authors meant to have this be a null section, or 
whether they really intend to create a Security Considerations section 
that repeats or points to the security considerations for the three 
transports. I think the latter is better, given the lack of anything new 
in this document. Regardless, they need to fill this in before the 
SecDir review can be complete.

--Paul Hoffman

---

From: Michael Welzl <[email-masked]>
Date: Tue, 6 Sep 2016 09:53:10 +0200

Hi,

Thank you very much for this review; as an author, I’ll just say “ack”. I agree with what you say. We’ll do our best to do this ASAP.

Cheers,
Michael

> On 6. sep. 2016, at 01.28, Paul Hoffman <[email-masked]> wrote:
> 
> Greetings. draft-ietf-taps-transports-usage, "On the Usage of Transport Service Features Provided by IETF Transport Protocols" is an informational overview of how TCP, MCTCP, and SCTP interact with applications. It is strictly descriptive and doesn't define anything new.
> 
> Because this is just describes existing protocols, there are no new security considerations. However, the current Security Considerations section says:
> It is not clear if the authors meant to have this be a null section, or whether they really intend to create a Security Considerations section that repeats or points to the security considerations for the three transports. I think the latter is better, given the lack of anything new in this document. Regardless, they need to fill this in before the SecDir review can be complete.
> 
> --Paul Hoffman