Subject: [secdir] CodeStand

From: Christian O'Flaherty <[email-masked]>
Date: Thu, 13 Oct 2016 20:47:00 +0000

Hi all,

In Berlin at the SecDir Meeting we presented a web site aimed to document coding projects based on IETF documents. Unfortunately, the name we used was taken and we had to turn it off after the meeting.

The new name for the project is CodeStand and the new site is: https://codestand.ietf.org

We’re now looking for volunteers willing to create “Code Requests” for their documents. Students will create “Projects" referencing your “Code Request”. A project can also be created to document existing code without having a code request and it can be either open source or proprietary code.

The site will be announced to students next week at the Grace Hopper Celebration so we would like to have as many code requests as possible available in CodeStand.

You can Sign In using your current Datatracker credentials.

Please provide feedback to [email-masked]<mailto:[email-masked]>

The CodeStand team

---

From: Paul Wouters <[email-masked]>
Date: Thu, 13 Oct 2016 17:55:24 -0400 (EDT)

On Thu, 13 Oct 2016, Christian O'Flaherty wrote:

> In Berlin at the SecDir Meeting we presented a web site aimed to document coding projects based on IETF documents. Unfortunately,
> the name we used was taken and we had to turn it off after the meeting. 
> 
> We’re now looking for volunteers willing to create “Code Requests” for their documents. Students will create “Projects" referencing
> your “Code Request”. A project can also be created to document existing code without having a code request and it can be either open
> source or proprietary code.
> 
> Please provide feedback to [email-masked] 
> 
> The CodeStand team

I added two projects for testing. I found the distinction between
"protocol", "project" and "implementation" very confusing. For
example, the RFC's you can "add" to it, apply to the "project"
and not the "implementation". But implementations differ.

Also, adding all the RFCs/drafts for libreswan was very painful.

It was not always clear that you needed to push the "add" button to me
either, and lost a few inputs when doing "update".

Paul