Subject: [secdir] Secdir review of draft-ietf-i2rs-protocol-security-requirements

From: Radia Perlman <[email-masked]>
Date: Sat, 1 Oct 2016 21:12:10 -0700

On Thu, Sep 15, 2016 at 6:43 AM, Radia Perlman <[email-masked]>
wrote:
I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area
directors.
Document editors and WG chairs should treat these comments just like any
other last call comments.

I previously reviewed version 6 and 10, and all my comments are addressed
in this version (17). The secdir assignment was for version 14, but the
latest version seems to be 17, so that is the one that I reviewed.

Nothing substantive, certainly no security issues, and it's ready for
publication.

I do have a few super-minor typos in this version (17)  Apologies for the
weird formatting of my comments below. Perhaps it's gmail, that when I
cut-and-paste from the document, makes weird boxes, so please ignore the
boxes.  If gmail is just putting boxes in while I type in my comments, just
to annoy me, and they don't appear in the sent email, then ignore the
non-boxes I'm complaining about.  Anyway, here are my comments:

There seems to be a cut-and-paste error here:

"The optional insecure transport can only be used restricted set of
publically data available (events or information)"

Perhaps it should be "The optional insecure transport can only be used when
accessing publically available data (events or information)".

Not exactly sure what you'd like it to be...but there does seem to be at
least a missing word in the text from the document.

-----
And as long as I'm noticing extremely minor editorial things during reread:

"The first application is a weekly configuration application
   that uses the I2RS protocol to change configurations.  The second
   application is an application that allows operators to makes
   emergency changes to routers in the network"

In the first sentence I'd probably say "periodic" instead of "weekly".

The second sentence should be "to make" instead of "to makes"

-----------

Another super-minor typo "A variety of forms of managemen"  is missing
the letter "t" in "management"

Radia

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 4 Oct 2016 09:50:46 -0400

Radia: 

Thank you for the additional review.  I will update this in the next version of the draft (which is in the RFC editor’s queue).

Sue 

From: Radia Perlman [mailto:[email-masked]] 
Sent: Sunday, October 2, 2016 12:12 AM
To: [email-masked]; The IESG; [email-masked]
Subject: Secdir review of draft-ietf-i2rs-protocol-security-requirements

On Thu, Sep 15, 2016 at 6:43 AM, Radia Perlman <[email-masked]> wrote:
I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area directors.
Document editors and WG chairs should treat these comments just like any other last call comments.

I previously reviewed version 6 and 10, and all my comments are addressed in this version (17). The secdir assignment was for version 14, but the latest version seems to be 17, so that is the one that I reviewed.

Nothing substantive, certainly no security issues, and it's ready for publication.

I do have a few super-minor typos in this version (17)  Apologies for the weird formatting of my comments below. Perhaps it's gmail, that when I cut-and-paste from the document, makes weird boxes, so please ignore the boxes.  If gmail is just putting boxes in while I type in my comments, just to annoy me, and they don't appear in the sent email, then ignore the non-boxes I'm complaining about.  Anyway, here are my comments:

"The optional insecure transport can only be used restricted set of publically data available (events or information)"

Perhaps it should be "The optional insecure transport can only be used when accessing publically available data (events or information)".  

Not exactly sure what you'd like it to be...but there does seem to be at least a missing word in the text from the document.

-----