Subject: [secdir] SecDir review of draft-bbf-bbf-urn-02

From: Yaron Sheffer <[email-masked]>
Date: Fri, 14 Oct 2016 14:10:16 +0300

I have reviewed this document as part of the security directorate's 
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security
area directors.  Document editors and WG chairs should treat these
comments just like any other last call comments.

Summary

This is just a URN registration, with no relevant security considerations.

Details

To prevent "URN squatting", I would recommend to include an explanation 
why a name that's not trivially associated with "Broadband Forum" is 
claimed here, namely "dslforum-org". Although 2 minutes of research 
suffice to find the answer.

Thanks,
	Yaron

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 24 Oct 2016 19:25:48 +0000

> why a name that's not trivially associated with "Broadband Forum" is claimed
> here, namely "dslforum-org". Although 2 minutes of research suffice to find
> the answer.

Thanks for the comment. And sorry for the delayed response. To address this comment. I propose adding the following test at the end of the introduction:
"BBF has used these latter two NIDs for many years without formally registering them and has published widely-implemented specifications that use these NIDs. Use of the 'dslforum-org' NID started prior the organization's 2008 name change from DSL Forum to Broadband Forum. "

From:
   The 'bbf' NID is for new work efforts related to data models for
   protocols other than its CPE WAN Management Protocol (CWMP) [TR-069].
   The 'broadband-forum-org' and 'dslforum-org' NIDs are used for all
   data models related to CWMP [TR-069].

To:
   The 'bbf' NID is for new work efforts related to data models for
   protocols other than its CPE WAN Management Protocol (CWMP) [TR-069].
   The 'broadband-forum-org' and 'dslforum-org' NIDs are used for all
   data models related to CWMP [TR-069]. BBF has used these latter two NIDs 
   for many years without formally registering them and has published widely-
   implemented specifications that use these NIDs. Use of the 'dslforum-org' 
   NID started prior the organization's 2008 name change from DSL Forum to 
   Broadband Forum.  

And additional mention under Namespace Considerations to address Joel's comments. At end of Namespace Considerations, I propose adding:

   Three NIDs are defined. The "broadband-forum-org" and "dslforum-org" 
   (Broadband Forum changed its name from DSL Forum in 2008) NIDs have 
   been used for many years by BBF without formal registration. As they are 
   referenced by multiple BBF specifications currently in common use, BBF thought 
   it best to formalize them. The new "bbf" NID will be used for new work efforts.

Barbara