Subject: [secdir] Review of draft-ietf-tsvwg-ecn-experimentation-05

From: "Hilarie Orman" <[email-masked]>
Date: Wed, 13 Sep 2017 12:04:26 -0600

Security review of
         Explicit Congestion Notification (ECN) Experimentation
                draft-ietf-tsvwg-ecn-experimentation-05

Do not be alarmed.  I have reviewed this document as part of the
security directorate's ongoing effort to review all IETF documents
being processed by the IESG.  These comments were written primarily
for the benefit of the security area directors.  Document editors and
WG chairs should treat these comments just like any other last call
comments.

This document liberalizes the ways in which experiments can be
conducted on explicit congestion notification with TCP, RTP, and DCCP.

Other than the alarming statement:

   "... this memo places the
   responsibility for not breaking Internet congestion control on the
   experiments and the experimenters who propose them, as specified in
   Section 4.4."

there are no security considerations that occur to me.

I realize that people experiment with TCP modifications all the time,
and the ECN experiments can provide valuable engineering information.
Nonetheless, it seems that some higher standard of safety could be
in order for today's Internet.  But that is outside the scope of this
document.

Hilarie

---

From: "Black, David" <[email-masked]>
Date: Wed, 13 Sep 2017 18:27:55 +0000

Hilarie,

Thank you for the review. 

> in order for today's Internet.  But that is outside the scope of this

Well, there is a higher standard of safety and it is outside the scope of this document.

Experiments that take advantage of the liberation (I like that word!) in this document are required to first be documented in an Experimental RFC.   That requirement should provide both the Transport Area and the IESG with the ability to ensure that such experiments do not pose unacceptable risks to the continued operation of the Internet - a statement to that effect could be added if you or the Security ADs think it would be helpful.

Thanks, --David

> -----Original Message-----
> From: Hilarie Orman [mailto:[email-masked]]
> Sent: Wednesday, September 13, 2017 2:04 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Review of draft-ietf-tsvwg-ecn-experimentation-05
> 
>                      Security review of

---

From: Hilarie Orman <[email-masked]>
Date: Wed, 13 Sep 2017 17:11:45 -0600 (MDT)

Yes, I think it would be suitable to include such a statement.
People read these things, they wonder, does anyone try to prevent
Internet from turning into ice-9?

Hilarie

----- Original Message -----
From: "Black, David" <[email-masked]>
To: "Hilarie Orman" <[email-masked]>, "The IESG" <[email-masked]>, "secdir" <[email-masked]>
Cc: "draft-ietf-tsvwg-ecn-experimentation all" <[email-masked]>, "Black, David" <[email-masked]>
Sent: Wednesday, September 13, 2017 12:27:55 PM
Subject: RE: Review of draft-ietf-tsvwg-ecn-experimentation-05

Hilarie,

Thanks, --David

---

From: "Black, David" <[email-masked]>
Date: Fri, 15 Sep 2017 17:14:48 +0000

I've added a sentence to that effect to the security considerations section of what will become the -06 version of this draft:

However, effective congestion control is crucial to the continued operation of the Internet, and hence this memo places the responsibility for not breaking Internet congestion control on the experiments and the experimenters who propose them, as specified in Section 4.4. This responsibility is embodied in the requirement to discuss congestion control implications in the Experimental RFC for each experiment, as review of that discussion by the IETF community and the IESG prior to publication approval of that RFC should ensure that the experiment does not break Internet congestion control.

Thanks, --David

> Sent: Wednesday, September 13, 2017 7:12 PM
> To: Black, David <[email-masked]>
> Cc: The IESG <[email-masked]>; secdir <[email-masked]>; draft-ietf-tsvwg-ecn-
> experimentation all <[email-masked]>
> Subject: Re: Review of draft-ietf-tsvwg-ecn-experimentation-05
> 
> To: "Hilarie Orman" <[email-masked]>, "The IESG"
> <[email-masked]>, "secdir" <[email-masked]>
> Cc: "draft-ietf-tsvwg-ecn-experimentation all" <draft-ietf-tsvwg-ecn-
> [email-masked]>, "Black, David" <[email-masked]>
> Experiments that take advantage of the liberation (I like that word!) in this
> document are required to first be documented in an Experimental RFC.   That
> requirement should provide both the Transport Area and the IESG with the
> ability to ensure that such experiments do not pose unacceptable risks to the
> continued operation of the Internet - a statement to that effect could be
> added if you or the Security ADs think it would be helpful.
> 
> Thanks, --David
> 
>