Subject: [secdir] Secdir last call review of draft-ietf-teas-rsvp-ingress-protection-13

From: Joseph Salowey <[email-masked]>
Date: Tue, 27 Feb 2018 22:57:43 -0800

Reviewer: Joseph Salowey
Review result: Ready

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG. These comments
were written primarily for the benefit of the security area directors. Document
editors and WG chairs should treat these comments just like any other last call
comments.

In general I felt that the document was a bit difficult to read and the issues
raised in the Genart and RTG reviews should be addressed.

>From a security point of view I believe the document is ready, but I have a
comment below that might improve the document.

I find the security considerations as reference to other documents a bit
unsettling, however, based on my somewhat limited understanding of RSVP it
think it is accurate in this case.  The problem I have with the security
considerations as reference is that most implementors are probably are not
going to follow the links to the other documents to find out what security
wisdom lies therein.   If the document pointed to specific considerations in
other documents that were particularly relevant to this document that would be
an improvement.  I couldn't work my way back through the chain of references to
something specific, but someone with a bit more RSVP domain knowledge may be
able to make some specific recommendations.

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 1 Mar 2018 02:37:09 +0000

Hi Joseph,

    Thank you very much for your time and comments.
    The specific relevant documents have been added. 

Best Regards,
Huaimo
-----Original Message-----
From: Joseph Salowey [mailto:[email-masked]] 
Sent: Wednesday, February 28, 2018 1:58 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-teas-rsvp-ingress-protection-13

Reviewer: Joseph Salowey
Review result: Ready

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

In general I felt that the document was a bit difficult to read and the issues raised in the Genart and RTG reviews should be addressed.

I find the security considerations as reference to other documents a bit unsettling, however, based on my somewhat limited understanding of RSVP it think it is accurate in this case.  The problem I have with the security considerations as reference is that most implementors are probably are not going to follow the links to the other documents to find out what security
wisdom lies therein.   If the document pointed to specific considerations in
other documents that were particularly relevant to this document that would be an improvement.  I couldn't work my way back through the chain of references to something specific, but someone with a bit more RSVP domain knowledge may be able to make some specific recommendations.