Subject: [secdir] secdir review of draft-ietf-bess-fat-pw-bgp-03

From: "Scott G. Kelly" <[email-masked]>
Date: Fri, 16 Feb 2018 06:06:26 -0800 (PST)

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

The summary of the review is Ready with issues.

From the last line of the abstract, this draft updates RFC 4761 by defining new flags in the Control Flags field of the Layer2 Info Extended Community.

I'm not expert in routing protocols, so I can't say for sure that the one minor issue I'm calling out is the only one. The security considerations section is very brief, saying only

   This extension to BGP does not change the underlying security issues
   inherent in the existing [RFC4271].

RFC4271 is the BGP4 RFC. I agree that those security considerations apply, but as noted in the abstract, this draft updates RFC4761, and since that document calls out additional security considerations, don't those also apply here? Shouldn't this document's security considerations also reference RFC4761?

--Scott

---

From: "Scott G. Kelly" <[email-masked]>
Date: Fri, 16 Feb 2018 06:08:37 -0800 (PST)

Resending due to bounce from [email-masked]

On Friday, February 16, 2018 6:06am, "Scott G. Kelly" <[email-masked]> said:

> I have reviewed this document as part of the security directorate's ongoing effort
> to review all IETF documents being processed by the IESG. These comments were
> written primarily for the benefit of the security area directors.  Document
> editors and WG chairs should treat these comments just like any other last call
> comments.
> 
> From the last line of the abstract, this draft updates RFC 4761 by defining new
> flags in the Control Flags field of the Layer2 Info Extended Community.
> 
> I'm not expert in routing protocols, so I can't say for sure that the one minor
> issue I'm calling out is the only one. The security considerations section is very
> brief, saying only
> 
> RFC4271 is the BGP4 RFC. I agree that those security considerations apply, but as
> noted in the abstract, this draft updates RFC4761, and since that document calls
> out additional security considerations, don't those also apply here? Shouldn't
> this document's security considerations also reference RFC4761?
> 
> --Scott
> 
> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview
>

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 16 Feb 2018 06:43:01 -0800

Scott:

Hi!  Thanks for the review!

The correct address is [email-masked]. (.all, not
-all).  I’m including it in this reply.

BTW, yes the security considerations should also reference rfc4761.  That
comment had come up in another review and the authors should have it queued
up for the next version.

Alvaro.

On February 16, 2018 at 9:08:47 AM, Scott G. Kelly ([email-masked])
wrote: