Subject: [secdir] secdir review of draft-ietf-dime-rfc4006bis-07

From: David Mandelberg <[email-masked]>
Date: Wed, 11 Apr 2018 00:16:08 -0400

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

The summary of the review is Ready with nits.

(nit) The term AVP is used extensively, and I don't see a definition. 
Would its definition be obvious to anybody implementing this spec? I'm 
assuming it means attribute-value pair.

(nit, section 5.1.1) "For time based services, the quota is continuously 
consumed at the regular rate of 60 seconds per minute." Are leap seconds 
a problem?

-- 
Freelance cyber security consultant, software developer, and more
https://david.mandelberg.org/

---

From: Yuval Lifshitz <[email-masked]>
Date: Wed, 11 Apr 2018 05:29:24 +0000 (UTC)

Hi David,
* The term AVP is well known for anyone implementing a Diameter spec. It is also defined in the base spec (https://tools.ietf.org/html/rfc6733#section-1.2).* IMO, one second of inaccuracy is not considered overcharge or revenue leakage in time based service

Yuval
    On Wednesday, April 11, 2018, 7:16:15 a.m. GMT+3, David Mandelberg <[email-masked]> wrote:

---

From: Ben Campbell <[email-masked]>
Date: Wed, 11 Apr 2018 09:45:53 -0500

Hi,

The term “AVP” is on the IETF’s “well known” abbreviation list. (Both for Attribute Value Pair and Audio Visual Profile)

Thanks!

Ben.

> On Apr 11, 2018, at 12:29 AM, Yuval Lifshitz <[email-masked]> wrote:
> 
> Hi David,
> 
> * The term AVP is well known for anyone implementing a Diameter spec. It is also defined in the base spec (https://tools.ietf.org/html/rfc6733#section-1.2).
> * IMO, one second of inaccuracy is not considered overcharge or revenue leakage in time based service
> 
> Yuval
>