Subject: [secdir] Secdir last call review of draft-ietf-stir-passport-shaken-04

From: Takeshi Takahashi <[email-masked]>
Date: Fri, 02 Nov 2018 19:48:09 -0700

Reviewer: Takeshi Takahashi
Review result: Ready

I do not have any particular concerns on the Security Considerations section.
As mentioned in the section, the proposed extension will not pose any
particular threats to the base specification.

Having said that, I have minor comments and clarification questions as an
individual who has read this document without prior knowledge of this topic.

1. In the abstract,

The sentence "from ATIS .... Joint Task Force" will not be neceaary.
For those who are familiar with SHAKEN specification, this sentence is obvious.
For those who are not familiar with SHAKEN, this sentence will not provide any
information that may facilitate the understanding of the overview of the draft.
In either cases, the sentence will not be necessary.

"to include information defined as part of ..." had better be refined further.
I believe the readers wish to know the details (incl., types) of the
information instead of where the specification was once defined.

2. In the abstract and/or introduction,

STIR should be spelled out. I guess it is Secure Telephony Identity Revisited.

3. Terminology

I feel that you use the terms "claims" and "indicators" for pointing to the
same objects. If that's the case, I hope you could choose to use only one of
them.

Example of the use of two terminologies.
1. In the introduction, you have the sentence "This document specifies these
indicators...". 2. In the introduction, you have the sentence "there are two
additional claims..." 3. The title of section 4 is "Passport attest claim". and
so on.

4. In section 5 "PASSporT origid claim",

There is a sentence "There will likely be best practices documents that more
precisely guide it's usage in real deployments". If you have such a document
(including work-in-progress drafts), having a reference to this sentence will
be appreciated. If there is no reference, I do not think we need this sentence
here.

5. orig and origid claims
If I understood correctly, both orig and origid represent identifies the same
objects (including service provider-initiated calls, customers, classes of
devices, etc.) In this case, if the object identified by orig and the one
identified by origid is not the same, how should the receiver interpret these
claims?

6. section 7
I am a bit confused. If the use of "attest" and "origid" is already defined
elsewhere, what does this document define? Is the document define the use of
those claims for some other protols (other than SIP)?

7. security consideration.

As mentioned in this section, the values of the new "attest" and "origid"
claims added by this extension are not used in the current validation step.
Then, do you think we should encourage people to have another step that
validates those claims added by this extension?

I would appreciate your answers on these issues.

---

From: Chris Wendt <[email-masked]>
Date: Sun, 4 Nov 2018 08:41:02 -0500

Hi Takeshi,

Thanks for the review, comments inline.

> On Nov 2, 2018, at 10:48 PM, Takeshi Takahashi <[email-masked]> wrote:
> 

removed

> information instead of where the specification was once defined.

Changed the abstract to this:
This document extends PASSporT, which is a token object that conveys cryptographically-signed information about the participants involved in  communications.  The extension is defined, corresponding to the SHAKEN specification, to provide both a specific set of levels-of-confidence to the correctness of the originating identity for a SIP based Communication Service Provider (CSP) telephone network originated call as well as an identifier that allows the CSP to uniquely identify the origination of the call within its network.

> STIR should be spelled out. I guess it is Secure Telephony Identity Revisited.

removed based on last comments but in either case i received this comment from Adam as well.

> additional claims..." 3. The title of section 4 is "Passport attest claim". and

Claim is a specific term used to identify a key value in a JWT payload defined in RFC7519, indicator is used in a more generic way

That said, i changed that sentence to the following:
This document specifies these values as claims to extend the base set of PASSporT claims.

replacing “indicators" to “values as claims..."

> be appreciated. If there is no reference, I do not think we need this sentence

removed

> identified by origid is not the same, how should the receiver interpret these

orig and origid are not really related at all (although based on the name i suppose that might be a natural conclusion)

orig is the telephone or URI identity, origid is a unique id that represents to a service provider where the call was originated in it’s network.

I added some of this detail to the abstract, and i believe it exists in the document, but to fully appreciate the difference you probably do need to be familiar with both PASSporT and SHAKEN documents.

I feel like if i explained this difference again in any new text, it would get repetitive.

> elsewhere, what does this document define?

I started this document originally mostly referring to SHAKEN by reference, but received WG comments that i needed to provide more details in this document for the context and security considerations to be appreciated, so to remove that would conflict with that WG opinion.

> Is the document define the use of

No, SHAKEN will only be used in the context of telephone numbers and SIP.

> validates those claims added by this extension?

SHAKEN does define how these values should be interpreted, i think in the security considerations, we are only trying to say that the addition of these claims does not impact or change the security properties that are already discussed in the PASSporT document.