Subject: [secdir] Secdir review of draft-ietf-jmap-mail-14

From: Magnus Nyström <[email-masked]>
Date: Mon, 18 Feb 2019 18:30:07 -0800

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

This document defines a data model for mail over JMAP. JMAP is a JSON-based
protocol for synchronization of data between clients and servers.

   -

   Section 9, the Security Considerations section, generally refers to
draft-ietf-jmap-core for security considerations. I would agree with
this. I wonder for a
   new protocol like this though, if TLS 1.3 should be required?

   -

   Also, for draft-ietf-jmap-core, it would be nice if Basic Auth
could be disallowed for a new protocol like this - trying to move away
from passwords

   - The rest of the Security Considerations section seems fine to me.
   -

   Editorial; Section 9.3: "Milter protocol" - I understand this is
short-hand for "mail filter protocol," but perhaps this should be
written out, maybe with some
   reference? I also could not find the term defined in draft-ietf-jmap-core.

   - Also in 9.3, should "the Milter protocol" be "a Milter protocol"? Not
   sure.

Thanks.
-- Magnus

---

From: "Neil Jenkins" <[email-masked]>
Date: Tue, 19 Feb 2019 01:50:47 -0500

On Tue, 19 Feb 2019, at 13:30, Magnus Nyström wrote:
>  * Section 9, the Security Considerations section, generally refers to draft-ietf-jmap-core for security considerations. I would agree with this. I wonder for a new protocol like this though, if TLS 1.3 should be required?

In response to Eric Rescorla's review, the draft has been updated to require a minimum of TLS 1.2 and recommend at least TLS 1.3 – I think this is reasonable given the current situation.

>  * Also, for draft-ietf-jmap-core, it would be nice if Basic Auth could be disallowed for a new protocol like this - trying to move away from passwords

Nice in theory, but in practice it's really up to the vendors, and will be used regardless of what you say in the spec.

>  * Editorial; Section 9.3: "Milter protocol" - I understand this is short-hand for "mail filter protocol," but perhaps this should be written out, maybe with some reference?

I've added an informative reference to http://www.postfix.org/MILTER_README.html.

>  *  I also could not find the term defined in draft-ietf-jmap-core.

This is a mail-specific thing, so not relevant to core.

>  * Also in 9.3, should "the Milter protocol" be "a Milter protocol"? Not sure.

No, it's referring to a specific de-facto protocol; I think this is more clear with the added reference.

Cheers,
Neil.