Subject: [secdir] SECDIR review of draft-ietf-6tisch-msf-16

From: Donald Eastlake <[email-masked]>
Date: Sun, 5 Jul 2020 17:48:24 -0400

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  Document
editors and WG chairs should treat these comments just like any other
comments. Sorry this review is so late.

The summary of the review is Ready with a minor issue.

Security:

I have no objection to anything in the Security Considerations section.
However, I find it odd that this section does not mention confidentiality
or authentication at all. I think it needs a few words added. Perhaps, in
the first paragraph of the Security Considerations section, the following
change, assuming it is correct:
"The security considrations of the specifications continue to apply in the
MSF scope." -> "Confidentiality and authentication of MSF control and data
traffic is provided by these specifications whose security considerations
continue to apply to MSF."

Nits:

Section 2, top of page 5: garble. ",wh ile" -> ", while".

Section 3, page 6:

   - "the AutoTxCell and AutoRxCell are collided" -> "the AutoTxCell and
   AutoRxCell collide"
   - "In case in a backs-off period" -> "When in a back-off period"
   - "autonomous cells take precedence over negotiated cell" -> "autonomous
   cells take precedence over negotiated cells"
   - "possible for negotiated cell" -> "possible for a negotiated cell"

Section 5, page 9: "Without specific declaring, all cells" -> "Without
specific declaration, all cells" or just "All cells"

Section 5.1, page 9: ", most cases" -> ", in most cases"

Section 5.2, top of page 11:

   - "For burst traffic type" -> "For bursty traffic"
   - "It is recommended to set MAX_NUM_CELLS value at least 4x of the
   maximum number of used cells in a slot frame in recent history." ->
   "Setting MAC_NUM_CELLS to a value at least 4x the recent maximum number of
   cells used in a slot frame is RECOMMENDED."

There are references to outdated drafts. I usually just omit the version
number in my drafts that reference other drafts eliminating this.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: Tengfei Chang <[email-masked]>
Date: Mon, 6 Jul 2020 13:52:00 +0200 (CEST)

Hi Donald, 

Thanks for your review on the MSF! It's never late. 
I have resolved your comments according to the suggestion and created a new version on my local. 

One question, should I publish the new version right away or I should wait for more comments? 
Thanks! 

Tengfei 

Stay Healthy! Stay Optimistic! 

Dr. Tengfei Chang 
Post-doctoral Researcher 
Wireless Networking for Evolving & Adaptive Applications (EVA) 
National Inst. for Research in Comp. Sci. and Automation ( Inria ) 
(+33)1 80 49 41 43 
[email-masked] 
www.tchang.org 
____________________ 

> From: "Donald Eastlake" <[email-masked]>
> To: "iesg" <[email-masked]>, "secdir" <[email-masked]>, "draft-ietf-6tisch-msf
> all" <[email-masked]>
> Sent: Sunday, July 5, 2020 11:48:24 PM
> Subject: SECDIR review of draft-ietf-6tisch-msf-16

> editors and WG chairs should treat these comments just like any other comments.
> Sorry this review is so late.

> I have no objection to anything in the Security Considerations section. However,
> I find it odd that this section does not mention confidentiality or
> authentication at all. I think it needs a few words added. Perhaps, in the
> first paragraph of the Security Considerations section, the following change,
> assuming it is correct:
> " The security considrations of the specifications continue to apply in the MSF
> scope." -> "Confidentiality and authentication of MSF control and data traffic
> is provided by these specifications whose security considerations continue to
> apply to MSF."

>    * "the AutoTxCell and AutoRxCell are collided" -> "the AutoTxCell and AutoRxCell
>     collide"
>     * "In case in a backs-off period" -> "When in a back-off period"
>    * "autonomous cells take precedence over negotiated cell" -> "autonomous cells
>     take precedence over negotiated cells"
>     * "possible for negotiated cell" -> "possible for a negotiated cell"

> Section 5, page 9: "Without specific declaring, all cells" -> "Without specific
> declaration, all cells" or just "All cells"

>     * "For burst traffic type" -> "For bursty traffic"
>    * " It is recommended to set MAX_NUM_CELLS value at least 4x of the maximum
>    number of used cells in a slot frame in recent history." - > "Setting
>    MAC_NUM_CELLS to a value at least 4x the recent maximum number of cells used in
>     a slot frame is RECOMMENDED."
> There are references to outdated drafts. I usually just omit the version number
> in my drafts that reference other drafts eliminating this.

> [ mailto:[email-masked] | [email-masked] ]