Subject: [secdir] Secdir last call review of draft-ietf-tls-oldversions-deprecate-09

From: Adam Montville via Datatracker <[email-masked]>
Date: Mon, 23 Nov 2020 07:25:43 -0800

Reviewer: Adam Montville
Review result: Ready

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

The summary of the review is READY.

It's a short, but comprehensive document deprecating use of TLS v1.1 and v1.2,
and DTLS v1.0. This deprecation avoids reliance upon weak
ciphersuites/cryptographic primitives, and should help focus implementations on
a reduced number of requirements (i.e. no fall-back to weak protocols), which
ideally results in fewer implementation errors.

---

From: tom petch <[email-masked]>
Date: Mon, 23 Nov 2020 16:40:06 +0000

> and DTLS v1.0. This deprecation avoids reliance upon weak

Curious.

I am sure that the version that I reviewed deprecated TLS v1.0 and not 
TLS v1.2

Tom Petch

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 23 Nov 2020 17:22:59 +0000

> I am sure that the version that I reviewed deprecated TLS v1.0 and not 

Correct. We're not doing 1.2 yet:-) I guess that was just
a typo for 1.1

S.