Subject: Re: [Secdispatch] MTU Size

From: Göran Selander <[email-masked]>
Date: Wed, 6 Mar 2019 17:07:55 +0000

Hi Hannes,

From: Secdispatch <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Wednesday, 6 March 2019 at 13:54
To: "[email-masked]" <[email-masked]>
Subject: [Secdispatch] MTU Size

Hi all,

During the meeting, almost randomly, the design goal of being able to put key exchange messages into the MTU size was brought up.

There is nothing random about MTU sizes in this discussion. You and I already discussed the importance of MTU size in a recent mail exchange:
https://mailarchive.ietf.org/arch/msg/secdispatch/iIfoZnVOlySQsA-8_YvQV0pJ4Is

Unfortunately, it was unclear what the MTU size for the key exchange protocol for the different radio technologies is. There was some discussion on the Webex chat but it might be worthwhile to repeat it on the list.

So, what are the size constraints a key exchange protocol has to work with for

·         6tisch

·         LoRAWAN

·         SMS (who cares?)

·         NB IOT

I think you already got a response for 6tisch and LoRaWAN. Note that fragmentation is not built in, so unless upper layers provide that it is not possible to send a message larger than the frame size. This is particularily relevant for the case of using a key exchange to re-key LoRaWAN itself, in which case there is no need for any application.

For NB_IoT, fragmentation is built in, and the frame size is less critical. As discussed in the meeting, in this case the fact that it is licensed spectrum allows a much higher uplink transmit power which leads to high energy consumption in unfavorable coverage settings. As a consequence, the per-byte component of power consumption is high, and for each reduced byte of message overhead there is an energy saving.

Göran

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 17:11:20 +0000

Goeran,

Can you provide the MTU values for NB-IOT?

Ciao
Hannes

From: Göran Selander <[email-masked]>
Sent: Mittwoch, 6. März 2019 18:08
To: Hannes Tschofenig <[email-masked]>; [email-masked]
Subject: Re: [Secdispatch] MTU Size

Hi Hannes,

From: Secdispatch <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 6 March 2019 at 13:54
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Secdispatch] MTU Size

Hi all,

·       6tisch

·       LoRAWAN

·       SMS (who cares?)

·       NB IOT

Göran

Ciao
Hannes

---

From: Göran Selander <[email-masked]>
Date: Wed, 6 Mar 2019 17:39:31 +0000

Hi Hannes,

As I mentioned below, for NB-IoT the MTU size is less relevant for power consumption since it efficiently handles fragmentation so the power consumption is strictly increasing instead of being a step function.  I can ask Claes if this is important to you.

Göran

From: Hannes Tschofenig <[email-masked]>
Date: Wednesday, 6 March 2019 at 18:11
To: Göran Selander <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Secdispatch] MTU Size

Goeran,

Ciao
Hannes

Hi Hannes,

Hi all,

·         6tisch

·         LoRAWAN

·         SMS (who cares?)

·         NB IOT

Göran

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 17:56:32 +0000

During the meeting we found out that the MTU size is important and hence I wanted to collect the MTU size that limits how long the key exchange packets have to be.
I believe it would be good to know what MTU size we should take into account with NB IOT as well.

From: Göran Selander <[email-masked]>
Sent: Mittwoch, 6. März 2019 18:40
To: Hannes Tschofenig <[email-masked]>; [email-masked]
Subject: Re: [Secdispatch] MTU Size

Hi Hannes,

From: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 6 March 2019 at 18:11
To: Göran Selander <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Secdispatch] MTU Size

Goeran,

Ciao
Hannes

From: Göran Selander <[email-masked]<mailto:[email-masked]>>
Sent: Mittwoch, 6. März 2019 18:08
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Secdispatch] MTU Size

Hi Hannes,

Hi all,

·       6tisch

·       LoRAWAN

·       SMS (who cares?)

·       NB IOT

Göran

Ciao
Hannes