Subject: Re: [Secdispatch] Power measurements

From: Göran Selander <[email-masked]>
Date: Wed, 6 Mar 2019 16:30:00 +0000

Hi Hannes,

The benchmarks for 3GPP (NB-IoT) and LoRaWAN presented in the Interim yesterday were based on the message size comparisons:

Message size comparison
---
Slide 31 contains the assumptions
Slide 32 contains the comparison showing a factor 3 – 4 between EDHOC and DTLS 1.3 message sizes

NB-IoT Energy Consumption
---
Slide 34 contains the assumptions
Slide 35 contains the estimates showing a factor 2.2 – 3.3 in power consumption between EDHOC and DTLS 1.3 message sizes
The model for estimating energy consumption is a standard model used in 3GPP and based on actual measurements. The calculations are here:
https://github.com/EricssonResearch/EDHOC/blob/master/docs/NB%20IoT%20power%20consumption.xlsx

LoRaWAN
---
Slide 38 describes the model for estimating the backoff times
Slide 39 contains the ToA and the backoff time estimates

For LoRaWAN two quantities were compared. The Time-On-Air which is related to power consumption and as input to the second quantity, the backoff time. Spread sheets for ToA are available various sources e.g. here https://www.thethingsnetwork.org/forum/t/spreadsheet-for-lora-airtime-calculation/1190  The actual calculations were made using this spread sheet:
https://github.com/EricssonResearch/EDHOC/blob/master/docs/LoRaWAN_ToA.xlsx

The estimates for backoff time was made using this spread sheet.
https://github.com/EricssonResearch/EDHOC/blob/master/docs/LoRaWAN-Backoff-Time-Lower-Bound.xls

Let me know if you have further questions about the comparisons.

Göran

From: Secdispatch <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Wednesday, 6 March 2019 at 13:21
To: "[email-masked]" <[email-masked]>
Subject: [Secdispatch] Power measurements

Hi all,

Yesterday a few measurements of 3GPP & LoRAWAN power measurements were presented. I asked whether the provided data are estimates based on some model or whether they are the results of some measurements.

During the call the answer to that question could not be provided. It would be interesting to double-check this.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 17:07:39 +0000

Hi Goeran,

Has someone done measurement using real hardware? I can see the Excel sheet and it appears that these are approximations.

Ciao
Hannes

From: Göran Selander <[email-masked]>
Sent: Mittwoch, 6. März 2019 17:30
To: Hannes Tschofenig <[email-masked]>; [email-masked]
Subject: Re: [Secdispatch] Power measurements

Hi Hannes,

Message size comparison
---

LoRaWAN
---

Göran

From: Secdispatch <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 6 March 2019 at 13:21
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Secdispatch] Power measurements

Hi all,

Ciao
Hannes

---

From: Jesús Sánchez-Gómez <[email-masked]>
Date: Wed, 6 Mar 2019 18:19:08 +0100

Hello Hannes,

Allow me to answer,

The excel only shows the Time-on-Air calculations based on the Semtech 
design. That is only
one of the input parameters.

During my research I've worked specifically with the Microchip RN2483 
(the defacto standard
certified LoraWAN Class A module) and the current measurements made with 
multimeters
were as specified in the datasheet (picture in my previous email).

As for the Time-on-Air, we haven't measured the RN2483 ToA because at 
the time we didn't have
the right gear for that, but in theory all LoRaWAN certified modules 
(i.e. RN2483) must obey those times
in order to sell the product. Otherwise it is impossible for the device 
to achieve LoRa Alliance
certification.

I did not conduct measurements with other LoRaWAN certified radio modems.

Best Regards,

On 06/03/2019 18.07, Hannes Tschofenig wrote:
>
> Hi Goeran,
>
> Has someone done measurement using real hardware? I can see the Excel 
> sheet and it appears that these are approximations.
>
> Ciao
>
> Hannes
>
> *From:*Göran Selander <[email-masked]>
> *Sent:* Mittwoch, 6. März 2019 17:30
> *To:* Hannes Tschofenig <[email-masked]>; [email-masked]
> *Subject:* Re: [Secdispatch] Power measurements
>
> Hi Hannes,
>
> The benchmarks for 3GPP (NB-IoT) and LoRaWAN presented in the Interim 
> yesterday were based on the message size comparisons:
>
> Message size comparison
>
> ---
>
> Slide 35 contains the estimates showing a factor 2.2 – 3.3 in power 
> consumption between EDHOC and DTLS 1.3 message sizes
>
> The model for estimating energy consumption is a standard model used 
> in 3GPP and based on actual measurements. The calculations are here:
>
> For LoRaWAN two quantities were compared. The Time-On-Air which is 
> related to power consumption and as input to the second quantity, the 
> backoff time. Spread sheets for ToA are available various sources e.g. 
> here 
> https://www.thethingsnetwork.org/forum/t/spreadsheet-for-lora-airtime-calculation/1190 
>  The actual calculations were made using this spread sheet:
>
> *From: *Secdispatch <[email-masked] 
> <mailto:[email-masked]>> on behalf of Hannes Tschofenig 
> <[email-masked] <mailto:[email-masked]>>
> *Date: *Wednesday, 6 March 2019 at 13:21
> *To: *"[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>
> *Subject: *[Secdispatch] Power measurements
>
> Hi all,
>
> Yesterday a few measurements of 3GPP & LoRAWAN power measurements were 
> presented. I asked whether the provided data are estimates based on 
> some model or whether they are the results of some measurements.
>
> During the call the answer to that question could not be provided. It 
> would be interesting to double-check this.
>
> Ciao
>
> Hannes
>
> IMPORTANT NOTICE: The contents of this email and any attachments are 
> confidential and may also be privileged. If you are not the intended 
> recipient, please notify the sender immediately and do not disclose 
> the contents to any other person, use it for any purpose, or store or 
> copy the information in any medium. Thank you.
>
> IMPORTANT NOTICE: The contents of this email and any attachments are 
> confidential and may also be privileged. If you are not the intended 
> recipient, please notify the sender immediately and do not disclose 
> the contents to any other person, use it for any purpose, or store or 
> copy the information in any medium. Thank you.
>
> _______________________________________________
> Secdispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdispatch

-- 
Jesús Sánchez Gómez
+34 868 88 78 53
+34 635 33 26 09
[email-masked]
Department of Information and Communication Engineering
Faculty of Computer Science
University of Murcia
30100 Murcia, Spain

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 17:25:12 +0000

Hi Jesus,

I wondering how the system design impacts the power consumption, particularly since many IoT devices are not even single MCU designs.
Just measuring the radio will give an artificial view. Did you explore this aspect in your measurements?

Ciao
Hannes

From: Jesús Sánchez-Gómez <[email-masked]>
Sent: Mittwoch, 6. März 2019 18:19
To: Hannes Tschofenig <[email-masked]>; [email-masked]
Subject: Re: [Secdispatch] Power measurements

Hello Hannes,

Allow me to answer,

The excel only shows the Time-on-Air calculations based on the Semtech design. That is only
one of the input parameters.

During my research I've worked specifically with the Microchip RN2483 (the defacto standard
certified LoraWAN Class A module) and the current measurements made with multimeters
were as specified in the datasheet (picture in my previous email).

As for the Time-on-Air, we haven't measured the RN2483 ToA because at the time we didn't have
the right gear for that, but in theory all LoRaWAN certified modules (i.e. RN2483) must obey those times
in order to sell the product. Otherwise it is impossible for the device to achieve LoRa Alliance
certification.

Best Regards,

Ciao
Hannes

From: Göran Selander <[email-masked]><mailto:[email-masked]>
Sent: Mittwoch, 6. März 2019 17:30
To: Hannes Tschofenig <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Secdispatch] Power measurements

Hi Hannes,

Message size comparison
---

LoRaWAN
---

Göran

Hi all,

Ciao
Hannes

Secdispatch mailing list

[email-masked]<mailto:[email-masked]>

--

Jesús Sánchez Gómez

+34 868 88 78 53

+34 635 33 26 09

[email-masked]<mailto:[email-masked]>

University of Murcia

30100 Murcia, Spain

---

From: Göran Selander <[email-masked]>
Date: Wed, 6 Mar 2019 17:29:31 +0000

Hi Hannes,

As Claes mentioned in the meeting, these are the calculations used in the industry. Indeed these are approximations, as you can see from that assumptions, but to the best of our knowledge we believe they are relevant. I will ask Claes if he knows of any measurements tomorrow.

Göran

From: Hannes Tschofenig <[email-masked]>
Date: Wednesday, 6 March 2019 at 18:07
To: Göran Selander <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Secdispatch] Power measurements

Hi Goeran,

Ciao
Hannes

Hi Hannes,

Message size comparison
---

LoRaWAN
---

Göran

Hi all,

Ciao
Hannes

---

From: Jesús Sánchez-Gómez <[email-masked]>
Date: Wed, 6 Mar 2019 18:39:40 +0100

Hello Hannes,

On 06/03/2019 18.25, Hannes Tschofenig wrote:
>
> Hi Jesus,
>
> I wondering how the system design impacts the power consumption, 
> particularly since many IoT devices are not even single MCU designs.
>

We considered the RN2483 (LoRaWAN radio module) and the main MCU as 
different
entities during our measurements.

Our measurements at the time were very simple, focusing only on the RN2483.
In the particular case of the measurements of current, we placed a 
multimeter at the GND pin.

Just to clarify if I understood your question correctly, depending on 
the particular MCU
(e.g. ARM, MSP430, PIC32, etc) the power to communicate with the RN2483 
could be different:
whatever current the main MCU needs to talk with an USART and 
computation time of the instructions
dealing with the LoRaWAN commands and that is very hard to generalize.

I hope this was helpful.

Best Regards,

> Ciao
>
> Hannes
>
> *From:*Jesús Sánchez-Gómez <[email-masked]>
> *Sent:* Mittwoch, 6. März 2019 18:19
>     Has someone done measurement using real hardware? I can see the
>     Excel sheet and it appears that these are approximations.
>
>     Ciao
>
>     Hannes
>
>     <mailto:[email-masked]>
>     *To:* Hannes Tschofenig <[email-masked]>
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>     The benchmarks for 3GPP (NB-IoT) and LoRaWAN presented in the
>     Interim yesterday were based on the message size comparisons:
>
>     Message size comparison
>
>     ---
>
>     Slide 35 contains the estimates showing a factor 2.2 – 3.3 in
>     power consumption between EDHOC and DTLS 1.3 message sizes
>
>     The model for estimating energy consumption is a standard model
>     used in 3GPP and based on actual measurements. The calculations
>     are here:
>
>     related to power consumption and as input to the second quantity,
>     the backoff time. Spread sheets for ToA are available various
>     sources e.g. here
>     <mailto:[email-masked]>> on behalf of Hannes
>     Tschofenig <[email-masked]
>     <mailto:[email-masked]>>
>     Yesterday a few measurements of 3GPP & LoRAWAN power measurements
>     were presented. I asked whether the provided data are estimates
>     based on some model or whether they are the results of some
>     measurements.
>
>     During the call the answer to that question could not be provided.
>     It would be interesting to double-check this.
>
>     Ciao
>
>     Hannes
>
>     IMPORTANT NOTICE: The contents of this email and any attachments
>     are confidential and may also be privileged. If you are not the
>     intended recipient, please notify the sender immediately and do
>     not disclose the contents to any other person, use it for any
>     purpose, or store or copy the information in any medium. Thank you.
>
>     IMPORTANT NOTICE: The contents of this email and any attachments
>     are confidential and may also be privileged. If you are not the
>     intended recipient, please notify the sender immediately and do
>     not disclose the contents to any other person, use it for any
>     purpose, or store or copy the information in any medium. Thank you.
>
>     [email-masked]  <mailto:[email-masked]>
>
> [email-masked]  <mailto:[email-masked]>

---

From: Göran Selander <[email-masked]>
Date: Wed, 6 Mar 2019 17:44:26 +0000

Hi Hannes,

Just a comment here: The benchmarks provided different limiting properties of constrained devices. The impact on message overhead in power consumption is demonstrated in several of the motivating use cases. For LoRaWAN, the duty cycle and backoff times is perhaps the most dramatic effect of message overhead.

Göran

From: Secdispatch <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Wednesday, 6 March 2019 at 18:26
To: Jesús Sánchez-Gómez <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Secdispatch] Power measurements

Hi Jesus,

Ciao
Hannes

Hello Hannes,

Allow me to answer,

Best Regards,

Ciao
Hannes

Hi Hannes,

Message size comparison
---

LoRaWAN
---

Göran

Hi all,

Ciao
Hannes

Secdispatch mailing list

--

Jesús Sánchez Gómez

+34 868 88 78 53

+34 635 33 26 09

University of Murcia

30100 Murcia, Spain

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 17:59:45 +0000

Thanks, this is good to know.

I am asking these questions since models may not necessarily reflect reality.

For example, I recall this paper submitted to the IOTSU workshop where Martin Orehek and Alf Zugenmaier look at the 3GPP’s Cellular IoT traffic model and point out there assumptions being made regarding battery lifetime are not necessarily accurate:
https://down.dsg.cs.tcd.ie/iotsu/subs/IoTSU_2016_paper_21.pdf

From: Jesús Sánchez-Gómez <[email-masked]>
Sent: Mittwoch, 6. März 2019 18:40
To: Hannes Tschofenig <[email-masked]>; [email-masked]
Subject: Re: [Secdispatch] Power measurements

Hello Hannes,

We considered the RN2483 (LoRaWAN radio module) and the main MCU as different
entities during our measurements.

Our measurements at the time were very simple, focusing only on the RN2483.
In the particular case of the measurements of current, we placed a multimeter at the GND pin.

Just to clarify if I understood your question correctly, depending on the particular MCU
(e.g. ARM, MSP430, PIC32, etc) the power to communicate with the RN2483 could be different:
whatever current the main MCU needs to talk with an USART and computation time of the instructions
dealing with the LoRaWAN commands and that is very hard to generalize.

I hope this was helpful.

Best Regards,

Ciao
Hannes

From: Jesús Sánchez-Gómez <[email-masked]><mailto:[email-masked]>
Sent: Mittwoch, 6. März 2019 18:19
To: Hannes Tschofenig <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Secdispatch] Power measurements

Hello Hannes,

Allow me to answer,

Best Regards,

Ciao
Hannes

Hi Hannes,

Message size comparison
---

LoRaWAN
---

Göran

Hi all,

Ciao
Hannes

Secdispatch mailing list

--

Jesús Sánchez Gómez

+34 868 88 78 53

+34 635 33 26 09

University of Murcia

30100 Murcia, Spain

Secdispatch mailing list

--

Jesús Sánchez Gómez

+34 868 88 78 53

+34 635 33 26 09

University of Murcia

30100 Murcia, Spain

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 18:01:47 +0000

I understand. The MTU-aspect does, however, appear to be something specific to work with in terms of engineering work. That’s why it looks like a promising route.

From: Göran Selander <[email-masked]>
Sent: Mittwoch, 6. März 2019 18:44
To: Hannes Tschofenig <[email-masked]>; Jesús Sánchez-Gómez <[email-masked]>; [email-masked]
Subject: Re: [Secdispatch] Power measurements

Hi Hannes,

Göran

From: Secdispatch <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 6 March 2019 at 18:26
To: Jesús Sánchez-Gómez <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Secdispatch] Power measurements

Hi Jesus,

Ciao
Hannes

From: Jesús Sánchez-Gómez <[email-masked]<mailto:[email-masked]>>
Sent: Mittwoch, 6. März 2019 18:19
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Secdispatch] Power measurements

Hello Hannes,

Allow me to answer,

Best Regards,

Ciao
Hannes

Hi Hannes,

Message size comparison
---

LoRaWAN
---

Göran

Hi all,

Ciao
Hannes

Secdispatch mailing list

--

Jesús Sánchez Gómez

+34 868 88 78 53

+34 635 33 26 09

University of Murcia

30100 Murcia, Spain