Subject: Re: [Secdispatch] Materials for Virtual Interim Meeting on March-05-2019

From: "Martin Thomson" <[email-masked]>
Date: Mon, 04 Mar 2019 17:59:29 -0500

Hi Roman, Richard,

In reviewing the agenda for this, I realized that this might not be the ideal structure for this particular topic.

This structure is a fairly typical BoF structure for a topic that has a clear path forward, with a reasonably well-understood problem, what appears to be general agreement about how to approach the solution, and one clear candidate for a solution.  We go through that sort of process because it gives us the best chance of ending the meeting with a decision to form a working group around the proposed solution.  It effectively skips a bunch of the wrangling, which I'm sure we would all appreciate.

Going back to the usual set of questions:

1. What is the problem we are faced with?
2. Is the problem understood and narrowly scoped?
3. Do we believe it is possible to engineer a solution?
4. (stretch objective) Is this particular proposal a good basis for working on?

I don't see a whole lot of agreement about even the first question here.  The overwhelming impression you get from mail on the subject is that the primary concern here is the size of messages.  Recent mail from Hannes suggests that there might be a computation cost dimension as well.

The structure of the agenda is such that I don't feel like we'll get very far.  A lot of the time is spent in presentation (something I'm sure will keep me from falling asleep at 3am) of topics that don't directly bear on this particular problem.  In particular, the discussion of formal analysis of EDHOC is not going to help us reach any sort of consensus on the earlier questions as it relates directly to the third question.

Now, I'm sure that at least some of Goran's time will be spent addressing these important topics, I would like to see more time devoted to discussion of the hard questions and less on the "how do we get a working group chartered" end.  It seems like the agenda is specifically structured to presume an outcome on those foundational topics, and it is clear that no such presumption is safe.

Recent discussion leads me to conclude also that the final question might be contentious also, but that's probably a moot point.  I don't think that a mere 1.5 hour call will allow us to get into discussing solutions.

--Martin

On Fri, Mar 1, 2019, at 02:58, Roman Danyliw wrote:
> Hello!
> 
> As a reminder, SECDISPATCH will be meeting for a virtual interim 
> meeting on Tuesday, March 5, 2019.
> 
> ==[ Agenda ]==
> https://datatracker.ietf.org/meeting/interim-2019-secdispatch-01/materials/agenda-interim-2019-secdispatch-01-secdispatch-01.txt
> 
> ==[ Materials ]==
> https://datatracker.ietf.org/meeting/interim-2019-secdispatch-01/session/secdispatch
> 
> ==[ Dial-in Information ]==
> Meeting Link: 
> https://ietf.webex.com/ietf/j.php?MTID=m9c46ced5a864cc7a44ca4960e4fd6f0a
> 
> Meeting Number: 640 410 560
> Meeting Password: NMESeM7y 
> 
> Audio connection:
> ** 1-650-479-3208 Call-in toll number (US/Canada)
> ** Access code: 640 410 560
> 
> Regards,
> Roman and Richard
> 
> _______________________________________________
> Secdispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdispatch
>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 4 Mar 2019 23:41:20 -0500

Hi Martin,

Thanks for the feedback on the agenda.  Your points go to the question of
what we expect to accomplish in this meeting.  Given the level of
contention, I agree with your assessment that we will be unlikely to get to
a concrete decision here, but I'm hopeful we can get some specificity as to
the parameters of the problem(s) and the solution approaches that are on
the table.  In the hope that that could set the stage for some more
decision-oriented discussion at the Prague meeting.

Given that, I would propose we refactor the agenda to focus on introducing
and discussing those topics:

- 5min chairs' intros
- 15min Problem Statement overview (Göran Selander)
- 15min Discussion of problem statement
- 15min Overview of the EDHOC approach (Göran selander)
- 15min Overview of the TLS-based approach (Jim Schaad)
- 20min Discussion of solution approaches
- 5min Wrap-up

Presenters, it would be even better if you could keep your intros to 10min
to allow for more discussion, and stick to the actionable points:

- Problem statement: What are the concrete problems being addressed, and
what are the quantitative bounds that a proposed solution would have to
meet?
- Solution approaches: What are the key differences from the current state
of the art?  What are you preserving; what are you changing?

Thanks,
--Richard

On Mon, Mar 4, 2019 at 5:59 PM Martin Thomson <[email-masked]> wrote:

> Hi Roman, Richard,
>
> In reviewing the agenda for this, I realized that this might not be the
> ideal structure for this particular topic.
>
> This structure is a fairly typical BoF structure for a topic that has a
> clear path forward, with a reasonably well-understood problem, what appears
> to be general agreement about how to approach the solution, and one clear
> candidate for a solution.  We go through that sort of process because it
> gives us the best chance of ending the meeting with a decision to form a
> working group around the proposed solution.  It effectively skips a bunch
> of the wrangling, which I'm sure we would all appreciate.
>
> I don't see a whole lot of agreement about even the first question here.
> The overwhelming impression you get from mail on the subject is that the
> primary concern here is the size of messages.  Recent mail from Hannes
> suggests that there might be a computation cost dimension as well.
>
> The structure of the agenda is such that I don't feel like we'll get very
> far.  A lot of the time is spent in presentation (something I'm sure will
> keep me from falling asleep at 3am) of topics that don't directly bear on
> this particular problem.  In particular, the discussion of formal analysis
> of EDHOC is not going to help us reach any sort of consensus on the earlier
> questions as it relates directly to the third question.
>
> Now, I'm sure that at least some of Goran's time will be spent addressing
> these important topics, I would like to see more time devoted to discussion
> of the hard questions and less on the "how do we get a working group
> chartered" end.  It seems like the agenda is specifically structured to
> presume an outcome on those foundational topics, and it is clear that no
> such presumption is safe.
>
> Recent discussion leads me to conclude also that the final question might
> be contentious also, but that's probably a moot point.  I don't think that
> a mere 1.5 hour call will allow us to get into discussing solutions.
>
> --Martin
>
>

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 5 Mar 2019 07:24:04 +0000

Hi all!

On Mar 5, 2019, at 12:41 PM, Richard Barnes <[email-masked]<mailto:[email-masked]>> wrote:

Hi Martin,

Thanks for the feedback on the agenda.  Your points go to the question of what we expect to accomplish in this meeting.  Given the level of contention, I agree with your assessment that we will be unlikely to get to a concrete decision here, but I'm hopeful we can get some specificity as to the parameters of the problem(s) and the solution approaches that are on the table.  In the hope that that could set the stage for some more decision-oriented discussion at the Prague meeting.

I’m not sure I know what this means as such a multi-stage process doesn’t align with our dispatch process.

Roman

Given that, I would propose we refactor the agenda to focus on introducing and discussing those topics:

- 5min chairs' intros

Presenters, it would be even better if you could keep your intros to 10min to allow for more discussion, and stick to the actionable points:

- Problem statement: What are the concrete problems being addressed, and what are the quantitative bounds that a proposed solution would have to meet?
- Solution approaches: What are the key differences from the current state of the art?  What are you preserving; what are you changing?

Thanks,
--Richard

On Mon, Mar 4, 2019 at 5:59 PM Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:
Hi Roman, Richard,

I don't see a whole lot of agreement about even the first question here..  The overwhelming impression you get from mail on the subject is that the primary concern here is the size of messages.  Recent mail from Hannes suggests that there might be a computation cost dimension as well.

--Martin

On Fri, Mar 1, 2019, at 02:58, Roman Danyliw wrote:
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Secdispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/secdispatch
_______________________________________________
Secdispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/secdispatch

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 05 Mar 2019 04:56:41 -0500

> doesn’t align with our dispatch process.

I was only suggesting that we might benefit from greater clarity on the early steps here.  The decision to dispatch can come at any point, though we need to get further through if we believe that dispatching is one of the more advanced responses (like formation of a working group).  If that means that there is no positive outcome from this meeting in the sense that a decision is made about dispatching, as Richard says, at least we might make progress on the foundational bits.

(The more I think about this, the more that I think a BoF is the right format for this, but let's make the most of the time we have.)

---

From: Richard Barnes <[email-masked]>
Date: Tue, 5 Mar 2019 03:49:28 -0800

My co-chair has (correctly) pointed out to me that it is a bit late for
such a significant agenda change.   So consider my proposed agenda
withdrawn.

Sorry for the thrash.  I was trying to be productive on a trans-pacific
flight.  Next time, I’ll watch another movie instead!

—Richard