Subject: [Secdispatch] Power measurements

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 12:21:08 +0000

Hi all,

Yesterday a few measurements of 3GPP & LoRAWAN power measurements were presented. I asked whether the provided data are estimates based on some model or whether they are the results of some measurements.

During the call the answer to that question could not be provided. It would be interesting to double-check this.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 Mar 2019 14:17:50 +0100

> Yesterday a few measurements of 3GPP & LoRAWAN power measurements were presented. I asked whether the provided data are estimates based on some model or whether they are the results of some measure…

Imagine the estimates were made on the back of an envelope, informed by some measurements but not by measuring exactly what was postulated.
I understand we are all curious (I certainly am), but for the purposes of secdispatch:
How would it help to know the detailed technique that was employed?

The design technique that led to EDHOC could be termed ALARA (as low as reasonably achievable): If there is an opportunity to reduce the cost, we are happy if that can be used.
Of course, we need to clarify what is “reasonable” (e.g., losing some security was “reasonable” for TLS 1.3 0RTT because it was believed that property can be explained).
Data from the various deployment environments can help us decide whether we are there yet.
But that decision is a bit like the influence of patents: Every one of us has to make it; there won’t be consensus about the criteria, and trying to generate a consensus document about that would be so ludricous that it would be obvious why people want that.

It is good that work on making (D)TLS more compact continues.  It started with DTLS 1.3, and once that is done, we will immediately be able to take advantage of that for CoAP.  There is also the ATLAS work.  Work on what I’ll call cutlass (“cTLS”) is just starting, and I’m looking forward to an even more concise version of (D)TLS.  But it is not a given that what is “reasonable” for EDHOC will turn out “reasonable” for the TLS brand, so I’m not holding by breath.  And I don’t have to, because EDHOC is there.  

Grüße, Carsten

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 6 Mar 2019 13:25:49 +0000

If I see a presentation where performance values are presented then I want to know how those were created. Maybe there is something interesting that can be learned from it.

-----Original Message-----
From: Carsten Bormann <[email-masked]>
Sent: Mittwoch, 6. März 2019 14:18
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked]
Subject: Re: [Secdispatch] Power measurements

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 Mar 2019 14:43:23 +0100

> If I see a presentation where performance values are presented then I want to know how those were created. Maybe there is something interesting that can be learned from it.

Certainly (and acknowledged in my previous message), but you sent this message to the secdispatch mailing list.
My comments were more of a reaction to yesterday’s interim, sorry for mixing this up.

Grüße, Carsten

---

From: Jesús Sánchez-Gómez <[email-masked]>
Date: Wed, 6 Mar 2019 17:16:18 +0100

Hello everyone,

In the particular case of LoRaWAN, the power consumption is calculated 
by Time-on-Air (ToA) of the message
times the power consumption of the module during transmission.

Short answer:

We calculated the exchange for the most adverse conditions possible: 
fixing LoRaWAN DataRate to a value of 0 (roughly 293 bps).
Add all the packet transmission times and multiply by the power 
consumption of your particular LoRaWAN device.

The details of the exchange shown during the dispatch are disclosed in 
detail here:

https://github.com/EricssonResearch/EDHOC/blob/master/docs/LoRaWAN-Backoff-Time-Lower-Bound.xls

More in depth answer: (Apologies for the lengthy email)

Every region regulation specifies a maximum radiated power, e.g. in 
Europe ETSI 300 220
defines a maximum radiated power in 868 MHz Radio band of 25 mW 
(~14dBm). LoRaWAN
end-devices follow that regulation and thus transmit at 14 dBm maximum.

Even if the ETSI regulation specifies a maximum radiated power of 25mW 
(14dBm), each
certified LoRaWAN radio module will employ different currents because 
different implementations
are more or less efficient with power. This is Dependant on every device 
and specified in the datasheet.

On the other hand, the Time-on-Air is independent of the device. It will 
be the same for every LoRaWAN device.

*How to calculate power consumption in LoRaWAN*

You multiply the ToA times the power consumption during transmission.

To get the ToA:

ToA depends on two input factors: (i) size of the packet, and (ii) 
datarate configuration.

Officially, Semtech provides the /SemtechSX12X Calculator tool/ that can 
help you with these calculations.
Alternative tools to attain the same results are:

https://www.thethingsnetwork.org/forum/t/spreadsheet-for-lora-airtime-calculation/1190
https://www.loratools.nl/#/airtime

The formal math is defined in /Lora Modem Design Guide SX1272/3/6/7/8: 
LoRa Modem Designer’s Guide AN1200.13/

To get the current:

- Use a multimeter on any LoRaWAN module you have around. Make the 
LoRaWAN module send any packet with a long ToA, e.g. a couple of 
seconds. Write down the current showed in the multimeter.
- If you don't have a device around to measure, In the datasheet of each 
module should come specified de mA needed during transmissions.
- Then you're set, just multiply the current times the voltage times the 
ToA and you'll get the mWh needed for a specific transmission.

Just to clarify, the power consumption of the module is NOT the same as 
the irradiated power of the antenna.
E.g. if the datasheet of a module says that the output power is 14 dBm, 
that equals 25 mW, those 25mW are not the
same thing as the power that the module is actually draining from the 
battery, hence I strongly suggest the multimeter
option.

As an example here is the hardware datasheet of the Microchip RN2483 Module:

Two things:

- In sleep mode some modules use a few µA of current, but you can 
alternatively save the data with a command and just turn it off (cut 
power entirely).
   This totally depends on the application and scenario in question.
- In Rx mode, the module also needs power, but it's maybe 1/3 or 1/4 of 
the TX power, not depreciable though, you need to take it also into account.

These values depend on the module you're dealing with, it's best to get 
an expert in electric design and make him read the hardware datasheets
before making any conclusions. Some manufactures try to get as much 
power efficiency as possible while other manufacturers
sell their modules for a cheaper price. It's a tradeoff.

Best Regards,

On 06/03/2019 14.43, Carsten Bormann wrote:
> _______________________________________________
> Secdispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdispatch

-- 
Jesús Sánchez Gómez
+34 868 88 78 53
+34 635 33 26 09
[email-masked]
Department of Information and Communication Engineering
Faculty of Computer Science
University of Murcia
30100 Murcia, Spain