Subject: [Secdispatch] Some Experiments: TLS, PQ and Key Exchanges

From: "Dr. Pala" <[email-masked]>
Date: Tue, 19 Nov 2019 11:55:36 +0800

Hi SecDispatch,

I just wanted to share with you some interesting results for "large" 
keys vs. computational intense algos and TLS that was recently published 
in two different blog posts - one from Amazon and one from Cloudflare:

  * https://aws.amazon.com/blogs/security/post-quantum-tls-now-supported-in-aws-kms/
  * https://blog.cloudflare.com/the-tls-post-quantum-experiment/

definitely worth reading :D Maybe the situation for TLS and large keys 
in certificates might not be as bad of an issue as initially thought... 
:) ... ???

Does anybody has any comment ?

Cheers,
Max

-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Tue, 19 Nov 2019 04:37:42 +0000

A little closer to what you are referring to Max, in Section 4 of https://eprint.iacr.org/2019/1276.pdf we share our preliminary experimental results with PQ signature certs in TLS 1.3. We found that two NIST signature candidates seem the best. All others introduced extra round-trips because of the chain size not fitting in the TCP congestion window and would not be satisfactory for latency-sensitive applications.

There is more detailed work that we have not published yet, which includes much more detail than the above paper and proposes some more solutions. Will share it in due time.

Rgs,
Panos

From: Secdispatch <[email-masked]> On Behalf Of Dr. Pala
Sent: Monday, November 18, 2019 10:56 PM
To: [email-masked]
Subject: [Secdispatch] Some Experiments: TLS, PQ and Key Exchanges

Hi SecDispatch,

I just wanted to share with you some interesting results for "large" keys vs. computational intense algos and TLS that was recently published in two different blog posts - one from Amazon and one from Cloudflare:

  *   https://aws.amazon.com/blogs/security/post-quantum-tls-now-supported-in-aws-kms/
  *   https://blog.cloudflare.com/the-tls-post-quantum-experiment/
definitely worth reading :D Maybe the situation for TLS and large keys in certificates might not be as bad of an issue as initially thought... :) ... ???

Cheers,
Max

--
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
[OpenCA Logo]