Subject: [Secdispatch] FW: New Version Notification for draft-faibish-iot-ddos-usecases-01.txt

From: <[email-masked]>
Date: Wed, 22 Jan 2020 21:03:32 +0000

Dear secdispatch chairs,

For the last year I worked on this draft defining usecases of IoT devices exploited for DDoS attacks in the TEEP WG. The purpose of the draft is to present the problem and if approved to write a second draft with prevention protocol. Last meeting TEEP decided not to pursue this draft as part of the TEEP WG as out of scope. As a result I want to make the case so this protocol proposal to become a secdispatch draft. During the work on this draft I also started to build a tool that will allow checking IoT devices vulnerability to be used to check potential opportunity to use the specific IoT devices as means for DDoS attacks. I tested the first version at the Hackathon at IETF 105 in Montreal within the TEEP WG but there were no IoT devices prototypes at hackathon so, I was only able to self test. 

I want to ask a 15 minutes time slot in the secdispatch meeting during the IETF 107 in Vancouver as well as presenting the python tool to be used by other interested parties to test their own IoT devices. I will again attend the Hackathon in Vancouver and check the IoT devices that will be brought by any WG. I will still attend the TEEP meetings as well. 

The tool is scanning any network protocol and open ports to check vulnerability to be used by bad actors to start reflection DDoS attacks from the device. The compliance tool runs Python code, to scan an IoT device (local or external) for open ports, based on the most common 42 ports (TCP and UDP) used by IoTs. These port scan results are then compared with the MUD file that is provided by the user for the specific IoT, since every MUD file is tailored to that specific manufacturer’s IoT model. The source-ports (TCP and UDP) mentioned in the MUD are extracted by the Python program and then compared against the 42 ports scanned earlier. There is also a MUD visualizer, that takes in a MUD file and shows the incoming and outgoing traffic based on the JSON MUD file. You may also make a MUD file.

Thank you very much for your support

./Sorin

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, December 25, 2019 4:09 PM
To: faibish, sorin
Subject: New Version Notification for draft-faibish-iot-ddos-usecases-01.txt

[EXTERNAL EMAIL] 

A new version of I-D, draft-faibish-iot-ddos-usecases-01.txt
has been successfully submitted by Sorin Faibish and posted to the IETF repository.

Name:		draft-faibish-iot-ddos-usecases
Revision:	01
Title:		Usecases definition for IoT DDoS attacks prevention
Document date:	2019-12-25
Group:		Individual Submission
Pages:		9
URL:            https://www.ietf.org/internet-drafts/draft-faibish-iot-ddos-usecases-01.txt
Status:         https://datatracker.ietf.org/doc/draft-faibish-iot-ddos-usecases/
Htmlized:       https://tools.ietf.org/html/draft-faibish-iot-ddos-usecases-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-faibish-iot-ddos-usecases
Diff:           https://www.ietf.org/rfcdiff?url2=draft-faibish-iot-ddos-usecases-01

Abstract:
   This document specifies several usecases related to the different
   ways IoT devices are exploited by malicious adversaries to
   instantiate Distributed Denial of Services (DDoS) attacks. The
   attacks are generted from IoT devices that have no proper protection
   against generating unsolicited communication messages targeting a
   certain network and creating large amounts of network traffic. The
   attackers take advantage of breaches in the configuration data in
   unprotected IoT devices exploited for DDoS attacks. The attackers
   take advantage of the IoT devices that can send network packets
   that were generated by malicious code that interacts with an OS
   implementation that runs on the IoT devices. The prupose of this
   draft is to present possible IoT DDoS usecases that need to be
   prevented by TEE. The major enabler of such attacks is related to
   IoT devices that have no OS or unprotected EE OS and run
   code that is downloaded to them from the TA and modified by
   man-in-the-middle that inserts malicious code in the OS.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Michael Richardson <[email-masked]>
Date: Wed, 22 Jan 2020 17:05:13 -0500

I took a quick look through your document.

<[email-masked]> wrote:
    > with prevention protocol. Last meeting TEEP decided not to pursue this
    > draft as part of the TEEP WG as out of scope. As a result I want to

It certainly does seem out of scope for TEEP.  SUIT maybe, but even there
that work has been done. Perhaps it belongs with the MUD work as motivational
evidence, but I don't see anything particularly new.

Or with the IoT Lifecycle Security work that I've suggested, but it would
still be motivational document, maybe some kind of BCP once other specs reach
RFC and we have some experience with them.

    > I want to ask a 15 minutes time slot in the secdispatch meeting during
    > the IETF 107 in Vancouver as well as presenting the python tool to be
    > used by other interested parties to test their own IoT devices. I will

I'm sure that the tool is very interesting, but I don't see why secdispatch
should care.  
I suggest that you might want to do a Happy Hackdemo presentation, or a screencast.

    > The tool is scanning any network protocol and open ports to check
    > vulnerability to be used by bad actors to start reflection DDoS attacks
    > from the device. The compliance tool runs Python code, to scan an IoT
    > device (local or external) for open ports, based on the most common 42
    > ports (TCP and UDP) used by IoTs. These port scan results are then

So, we've had tools like this for decades with mixed history of open source
and GPL and formerly this license and then another, and sometimes huge VC
behind them, and sometimes not.
The IETF doesn't standardized them, fund them, promote them, etc.

So unless the tool requires IANA actions, I don't see why it belongs here.
That's not to see it I'm un-interested, but it has no IETF-interest.
This feels like something that you write write a Usenet paper, NDSS,
PythonConf, ... paper for.  Or maybe just a really cool Screencast that you
upload to youtube.

    > compared with the MUD file that is provided by the user for the
    > specific IoT, since every MUD file is tailored to that specific
    > manufacturer’s IoT model. The source-ports (TCP and UDP) mentioned in
    > the MUD are extracted by the Python program and then compared against
    > the 42 ports scanned earlier. There is also a MUD visualizer, that
    > takes in a MUD file and shows the incoming and outgoing traffic based
    > on the JSON MUD file. You may also make a MUD file.

    > Name: draft-faibish-iot-ddos-usecases Revision: 01 Title: Usecases
    > definition for IoT DDoS attacks prevention Document date: 2019-12-25
    > Group: Individual Submission Pages: 9 URL:
    > https://www.ietf.org/internet-drafts/draft-faibish-iot-ddos-usecases-01.txt
    > Status:
    > https://datatracker.ietf.org/doc/draft-faibish-iot-ddos-usecases/
    > Htmlized:
    > https://tools.ietf.org/html/draft-faibish-iot-ddos-usecases-01
    > Htmlized:
    > https://datatracker.ietf.org/doc/html/draft-faibish-iot-ddos-usecases
    > Diff:
    > https://www.ietf.org/rfcdiff?url2=draft-faibish-iot-ddos-usecases-01

    > Abstract: This document specifies several usecases related to the
    > different ways IoT devices are exploited by malicious adversaries to
    > instantiate Distributed Denial of Services (DDoS) attacks. The attacks
    > are generted from IoT devices that have no proper protection against
    > generating unsolicited communication messages targeting a certain
    > network and creating large amounts of network traffic. The attackers
    > take advantage of breaches in the configuration data in unprotected IoT
    > devices exploited for DDoS attacks. The attackers take advantage of the
    > IoT devices that can send network packets that were generated by
    > malicious code that interacts with an OS implementation that runs on
    > the IoT devices. The prupose of this draft is to present possible IoT
    > DDoS usecases that need to be prevented by TEE. The major enabler of
    > such attacks is related to IoT devices that have no OS or unprotected
    > EE OS and run code that is downloaded to them from the TA and modified
    > by man-in-the-middle that inserts malicious code in the OS.

    > Please note that it may take a couple of minutes from the time of
    > submission until the htmlized version and diff are available at
    > tools.ietf.org.

    > _______________________________________________ Secdispatch mailing
    > list [email-masked]
    > https://www.ietf.org/mailman/listinfo/secdispatch