Subject: Re: [Secdispatch] Request for agenda item at IETF 109 sec dispatch

From: Stefan Santesson <[email-masked]>
Date: Wed, 21 Oct 2020 23:17:03 +0200

As an update on this request, we just submitted an I-D on the main specification:

https://datatracker.ietf.org/doc/draft-santesson-svt/

Stefan Santesson 

From: Secdispatch <[email-masked]> on behalf of Stefan Santesson <[email-masked]>
Date: Tuesday, 6 October 2020 at 18:29
To: IETF SecDispatch <[email-masked]>
Cc: Russ Housley <[email-masked]>, Francesca Palombini <francesca.palombini=[email-masked]>
Subject: [Secdispatch] Request for agenda item at IETF 109 sec dispatch

Hi,

At IETF 107 I made a presentation on SVT (Signature Validation Token) at sec dispatch.

At that time the work on SVT was in its early stages and the conclusion of the dispatch was to start a mailing list to discuss progress and direction.

This was never done eventually, but since IETF 107, this work has matured considerably and resulted in implementation and a successful Proof of Concept with running code.

The function of the SVT and the motivation of the SVT has also evolved.

In short:

SVT is a token that provides external evidence in support of long term validation of electronic signatures.

This is fully comparable with all types of long term validation strategies, who all need support of external evidence to conclude validity of the signer certificate as well as the signature itself.

The major contribution of the SVT is that it is reduces the number of external signed evidences that needs to be relied upon in order to perform successful validation, and thereby greatly reduces complexity of long term validation.

Another important contribution of SVT is that it, because of its compactness and simplicity, allows provision of multiple tokens of various strength or algorithms so that if one algorithm fails, the other may still be secure.

A first draft (00) will be authored by me and Russ Housley and will be submitted to the IETF, well in time for IETF 109.

I and Russ would like to request a timeslot at next sec dispatch to discuss progression of this draft as IETF standard.

Stefan Santesson 

_______________________________________________ Secdispatch mailing list [email-masked] https://www.ietf.org/mailman/listinfo/secdispatch

---

From: Stefan Santesson <[email-masked]>
Date: Thu, 29 Oct 2020 17:04:30 +0100

Yet one more update on this requested agenda item for next IETF meeting is that we have now submitted 2 more drafts, the XML and PDF profiles of the main specification.

We have also created a Github repo where all information about the current draft development is available: https://github.com/swedenconnect/IETF-SVT

This page also includes information about available open source as well as reference implementation.

Stefan Santesson 

From: Secdispatch <[email-masked]> on behalf of Stefan Santesson <[email-masked]>
Date: Wednesday, 21 October 2020 at 23:17
To: IETF SecDispatch <[email-masked]>
Cc: Russ Housley <[email-masked]>, Francesca Palombini <francesca.palombini=[email-masked]>
Subject: Re: [Secdispatch] Request for agenda item at IETF 109 sec dispatch

 

Stefan Santesson 

Hi,

In short:

 

Stefan Santesson