Subject: RE: CGA draft and paper

From: "Tuomas Aura" <[email-masked]>
Date: Tue, 18 Mar 2003 11:32:27 -0800

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: 16 March 2003 06:27
> To: Tuomas Aura
> Cc: SEND WG
> 
> Tuomas Aura wrote:
> 
> > http://www.ietf.org/internet-drafts/draft-aura-cga-00.txt
> 
> I like this draft a lot. In particular, I like the two-step
> construction of the addresses in order to make care-of address
> construction efficient.
> 
> A few minor comments:
> 
> * Introduction: is there a reference to someone using CGAs for
>    opportunistic IPsec?

No. I just think it is the right thing to do. I should probably 
remove references to uses beyond SEND and just say that there
are several.

> * Why MD5 and not SHA1?

Because an MD5 hash is 128 bits long --> easier to write the formula
for bitwise AND and OR with an IPv6 address. Really, there is no other
reason. My first goal has been to make the spec readable and
unambiguous.

> 
> * Section 6, "(These DoS attacks can be prevented if the IPv6
>    ND messages are authenticated with CGA addresses.)" It might
>    make sense to clarify that legitimate collisions can still
>    occur.

Ok.

> Jari

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: gabriel montenegro <[email-masked]>
Date: Wed, 19 Mar 2003 01:23:54 +0100

> remove references to uses beyond SEND and just say that there

Specifically for Opportunistic Encryption:

  Opportunistic Encryption for IPv6
     * Inria Technical Report (October 2002)
           o http://www.inria.fr/rrrt/rr-4568.html

and

ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-laganier-ike-ipv6-cga-00.txt

> reason. My first goal has been to make the spec readable and

The question, which I can't really answer, is if the weaknesses
in MD5 are more applicable here than they are, for example,
in hmac-sha-1.

-gabriel