Subject: Re: comments on send-ipsec-00

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Thu, 27 Mar 2003 10:54:09 +1100

On Wed, Mar 12, 2003 at 07:56:31PM -0800, Alper Yegin wrote:
> 
> - "If (DAD) clashes are detected
>    after three tries, the node is probably under attack, so it should
>    shut down and report the situation to an administrator."
> 
> Isn't DAD mechanism protected by CGAs as well? How can the attacker produce
> the right cryptographic information to claim 3 different IP addresses in a
> row?

This is a real interesting one.  I referred to a Dave Barry quote
a couple of times at IETF:

	"I want a laptop so small and light that sometimes I
	accidentally suck it up one of my nostrils. I also would
	like to have a cell phone that enabled me to
	jam the cell phones of people around me." -- Dave Barry

I'm not sure we can help with the first bit right now, but I think
the second will be pretty easy for people to manage, simply by
sending bogus NAs.

I've started looking at this based on a CGA/SENDlike approach,
but it is kind of tricky.  

-----N
-- 
Nick 'Sharkey' Moore			<[email-masked]>
Research Fellow, CTIE			Tel: +61 3 9905 3707
Monash University,  Australia		Fax: +61 3 9905 5358
--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: Jari Arkko <[email-masked]>
Date: Thu, 27 Mar 2003 07:25:34 +0200

> but it is kind of tricky.  

The situation is a bit unclear in the current document,
mainly because of the lack of protection for NSs (discussed
separately). However, theoretically the situation is as follows:

* DAD probes (NS) can be protected with CGAs exactly in the
   same manner as regular Neighbor Advertisements.

* This will enable the receiver to check whether the sender
   truly owns the addresses, or is just claiming to be.
   So we can prevent the attack.

* Still, even if the sender owns the address it is possible
   that we have an accidental clash. Thus we can't avoid DAD
   with CGA, with still have to do it and still have to give
   up some tried addresses. And its best to construct the
   protocol so that it gives up after three tries, because
   it may be up against the NSA "SEND Breake" machine ;-)
   But note that this is very different from simply
   listening in on any unsupported claim that the addresss
   is in use.

Jari