Subject: psreq issue#1: Should draft-psreq discuss solutions at all?

From: Pekka Nikander <[email-masked]>
Date: Fri, 07 Mar 2003 16:53:08 +0200

Many of the issues raised during the WG LC were
somehow concerned with solutions.  In fact, quite
a few  seemed to be concerned that the draft
discusses solutions at all; some people expressed
the strong opinion that it should not.

In the draft, we currently state the following about
solutions:

>   This document occasionally discusses solution proposals, such as CGA
>   [9]  and ABK [8].  However, the discussion is solely for illustrative
>   purposes.  It is meant to give the readers a more concrete idea of
>   some possible solutions.  It does NOT indicate any preference on
>   solutions on the behalf of the authors or the working group.

One reason for including any text about solutions
is to make the draft more readable.  Reading problem
descriptions without any ideas on how to *possibly*
solve them is very frustrating, at least to me personally.

Another reason for including the text is to give the
WG some idea of what is probably doable in a reasonable
amount of time, and what are more likely to be research
problems, requiring very long time to solve, if solvable
at all with current technology.

It is certainly easy to remove all text concerning
solutions, but I am afraid that the readability of the
draft would suffer.  On the other hand, if text is
added about the pros/cons of all solutions, the draft
may become excessive long (see issues #3, #6, #7, #9,
#18, #19, #21, #22).

Now, on the light of this, I am solicitating well grounded
opinions on whether the next version of the draft should
include any text about solutions?

If no, should the existing text be just removed or should
something else to be done to it.

If yes, is the existing level of illustrative talk about
solutions appropriate, or should there be more/less
text?

Additionally, if yes, should there be more informative
references to the possible solution approaches, or is the
current practice of mentioning or briefly describing the
solution approaches appropriate?

--Pekka Nikander

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Fri, 7 Mar 2003 09:11:35 -0800

<wg chair hat off>

I think the draft would read better without the solutions discussion in it.
While I think it makes sense to talk about solutions when formulating a problem
statement (because some people typically have an easier time precisely
specifying the problem that way), I think the problem statement itself should
not include solutions.

<wg chair hat on>

            jak

---

From: Jari Arkko <[email-masked]>
Date: Fri, 07 Mar 2003 22:18:16 +0200

>>   solutions on the behalf of the authors or the working group.

I'm fine with this text actually. Maybe you could add to the last
sentence something about the two solutions not being an exhaustive list
just to underline your point.

Jari

---

From: Pekka Savola <[email-masked]>
Date: Sat, 8 Mar 2003 15:55:59 +0200 (EET)

> just to underline your point.

I'm also fine with including some rough hand-waving towards some 
solutions.  For those who already are aware of the solutions, this makes 
it much easier to connect the PSreq cases and requirements.

Perhaps a reasonable compromise could be found by editing the text
describing the solutions slightly.  But IIRC, the draft was already in a
reasonably good condition.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Pekka Nikander <[email-masked]>
Date: Mon, 10 Mar 2003 08:57:16 +0200

I seem to be getting a very mixed signal on including
any solutions text to the draft.  Some people clearly
oppose, some people think it is fine.

To resolve this for now, I'll do the following, unless
someone strongly opposes.

  1. I'll leave the solution text to the draft, and
     try to add some clarifications as requested in
     a number of other issues.

  2. At the same time, I will enclose all solution
     text in [[double brackets]], making it easy to
     recognize it and remove it later, if wanted.

--Pekka Nikander

---

From: "James Kempf" <[email-masked]>
Date: Mon, 10 Mar 2003 09:47:11 -0800

Pekka,

I'm fine with leaving it in if there is concensus. Let's revisit in SFO.

            jak