Subject: issue 6: millisecond timestamp granularity

From: Jari Arkko <[email-masked]>
Date: Fri, 22 Aug 2003 00:20:26 +0300

Issue 6 is about the granularity of timestamps in the SEND
protocol. This is relevant for unsolicited advertisements,
as I think we'll be using nonces for the others.

If the granularity is coarse, the sender might have to
delay sending the advertisement until real time advances
into a new value within the given granularity. This
is not a practical problem right now. OTOH it would
be good to design the protocol so that we won't hit a hard
limit, should something change in the future.

Michael Richardsson made a suggestion in Vienna that
we move to fixed point binary scheme, perhaps allocating
16 bits for the fractions of the second. This would be
about 20 microseconds granularity. (Clearly, if you
clocks don't have this granularity, you can advance them
in bigger steps.)

I like Michael's suggestion. It seems simple to
implement. Lets do it. Any objections?

--Jari

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Thu, 21 Aug 2003 15:02:59 -0700

Sounds fine to me.

            jak