Subject: Issue 11: Timestamp processing issues, nonce vs. timestamp

From: Pekka Nikander <[email-masked]>
Date: Wed, 01 Oct 2003 12:43:52 +0300

[Resending to the list, apparently the list failed on
  me again.  Sorry if you see this multiple times.]

Since we decided to move to the ND options based approach,
issue 11 seems to boil down to the following:

1. Always process nonces from solicitated messages first,
    and if the nonce and signatures are verified OK, do create
    a cache entry even if the clock difference is larger
    than delta.

2. If timestamp checking is enabled for all inbound NSs, nodes
    with bad clocks can't get our address.  So, a sensible rule
    might be that "in case of invalid timestamp in a received NS,
    still respond to the message, but don't create a neighbor
    cache entry".

Both of these look doable with the new Issue 22 new method
of handling separately Delta and clock drift.

Hence, should we adopt the approach above?

--Pekka Nikander

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Wed, 1 Oct 2003 08:21:44 -0700

Agree.

            jak
\

---

From: Jari Arkko <[email-masked]>
Date: Mon, 06 Oct 2003 15:01:28 +0300

> Hence, should we adopt the approach above?

Yes.

--Jari