Subject: Re: question on ecc for draft-ietf-send-cga

From: <[email-masked]>
Date: Thu, 13 Nov 2003 4:00:45 +0200

Gabriel,

Its a good question to ask.

But I really think RSA is a better choice in terms of being
clearly unencumbered. ECC, on the other hand, is widely
known to have IPR issues. I do not think the appearance
of an algorithm in a public domain software is
a proof that there are no IPR issues, say, if a large vendor
started using the algorithm.

So, I'm strongly in favor of keeping RSA. That doesn't
mean that we couldn't revisit this decision and bring
another algorithm in to SEND in a Draft Standard phase,
for instance, or even later when the IPRs expire like they
did for RSA couple of years ago.

Secondly, James asked why we can't make this negotiable.
It certainly is negotiable in, say, IKE. However, there
the situation is different. First of all, its a unicast,
negotiated security setup. What we have is in some cases
multicast (e.g. DAD) and its hard to see how we could
get it to work with negotiation. Also, in IKE the algorithm
affects what keys you have, and what the protocols do.
In our case it would also affect the addresses that we use
for communication.

--Jari

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 13 Nov 2003 05:46:07 +0100

Quoting [email-masked]:

> get it to work with negotiation. 

For the DAD case, the network (or the router) could actually specify 
to the hosts which algorithm to use for their CGAs...
the algorithm does not have to be negociated between users, it just have
to be specified by the network...does this make sense?

Claude.