Subject: RE: issue 62 - rdlast

From: "Tuomas Aura" <[email-masked]>
Date: Sat, 14 Feb 2004 05:05:15 -0800

Jari Arkko wrote:
> Agreed. But this is complicated. Lets see if I got this
> right. Here's the new text for the combined last two bullets:
> 
>     o  When a message is received from a known peer, i.e., one that
>        already has an entry in the cache, the time stamp is checked
>        against the previously received SEND message:
> 
>          TSnew + fuzz > TSlast + (RDnew - RDlast) x (1 - drift) - fuzz
> 
>        If this does not hold, the message SHOULD be silently
discarded.
> 
>        If it does hold, the message is processed.  However, if TSnew <
>        TSlast, which is possible if packets arrive rapidly and out of
>        order, TSlast MUST NOT be updated, i.e., the stored TSlast for
a
>        given node MUST NOT ever decrease.  Otherwise TSlast and RDlast
>        SHOULD be updated.

This fixes the main issue. However, it is still not specified 
whether the receiver should update RDlast if both formulas 
hold. It is probably better not to update RDlast because
the packet that arrives first gives the most accurate 
measurement of the difference of the clocks. (Note that 
attackers cannot exploit this because they usually cannot 
speed up the delivery of packets.)

Could we rewrite the 2 last paragraphs above a follows:

        If this inequality does not hold, the receiver SHOULD 
        silently discard the message. On the other hand, if the 
        inequality holds, the receiver SHOULD process the message.

        Moreover, if the above inequality holds and 
        TSnew > TSlast, the receiver SHOULD update RDlast 
        and TSlast. Otherwise, the receiver MUST NOT update
        update RDlast or TSlast. 

I would leave out the sentence about TSlast never decreasing
because the reader might understand this as a general a rule.
It is, or course, not a general rule because TSlast can decrease 
in response to solicited advertisements.

Tuomas

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: Jari Arkko <[email-masked]>
Date: Sat, 14 Feb 2004 18:33:53 +0200

> in response to solicited advertisements.

Your text looks good. Thanks.

--Jari