Subject: RE: issue 70 -- upgrade path for algorithms

From: "Tuomas Aura" <[email-masked]>
Date: Tue, 6 Apr 2004 05:20:07 -0700

There is one inconsistency in NDOPT created by the latest
round of changes, and another paragraph that could be improved. 
Otherwise, the changes made by Jari look ok to me.

In NDOPT Section 5.2: 
    The SHA-1 hash is taken over the presentation used
    in the Key Information field of the CGA option. 

This should be something like:
    The SHA-1 hash is taken over the presentation used
    in the Public Key field of the CGA Parameters data 
    structure that is carried in the CGA option.   

In NDOPT Section 7.1:
   Nodes that use stateless address autoconfiguration SHOULD generate a
   new CGA as specified in Section 4 of [13] each time they run the
   autoconfiguration procedure.  The nodes MAY continue to use the same
   public key and modifier, and start the process from Step 4 of the
   generation algorithm.

This could be changed to:
   Nodes that use stateless address autoconfiguration SHOULD generate a
   new CGA and a CGA Parameters data structure as specified in Section 4

   of [13] each time they run the autoconfiguration procedure.  
(I think the last sentence is now unnecessary in NDOPT and 
can be deleted.)

Tuomas

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 01 April 2004 13:41
> To: Tuomas Aura
> Cc: [email-masked]
> Subject: issue 70 -- upgrade path for algorithms
> 
> 
> I have now made a tentative edit for the ndopt
> draft in order to make the CGA Parameters block
> opaque.
> 
> The diff and text is available here:
>   http://www.arkko.com/publications/send/issues/issue70diff.html
>   http://www.arkko.com/publications/send/drafts/draft-send-ndopt.txt
> 
> One potential question mark surfaced during the
> editing. Remember the other issue we had about
> pad length fields vs. implicit padding. Given your
> definition in the preliminary CGA draft 06,
> the last field, Extension Fields, is of variable
> size and there's no defined ASN.1 for it. As a
> result, I've put a Pad Length field to the CGA Option
> in order to know when your field ends and the padding
> starts. If people are unhappy with this approach, we
> can also make the CGA draft have some kind of length
> determination, and then we can skip the Pad Length
> field.
> 
> Comments? Other issues?
> 
> --Jari
> 

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: Jari Arkko <[email-masked]>
Date: Tue, 06 Apr 2004 20:39:35 +0300

>     structure that is carried in the CGA option.   

Yes.

> (I think the last sentence is now unnecessary in NDOPT and 

Ok.

I have updated the draft according to this, and the
diffs are available from the issue page:

   http://www.arkko.com/publications/send/issues/

--Jari