Subject: issue 70 -- upgrade path for algorithms

From: <[email-masked]>
Date: Thu, 1 Apr 2004 14:41:16 +0300

I have now made a tentative edit for the ndopt
draft in order to make the CGA Parameters block
opaque.

The diff and text is available here:
  http://www.arkko.com/publications/send/issues/issue70diff.html
  http://www.arkko.com/publications/send/drafts/draft-send-ndopt.txt

One potential question mark surfaced during the
editing. Remember the other issue we had about
pad length fields vs. implicit padding. Given your
definition in the preliminary CGA draft 06,
the last field, Extension Fields, is of variable
size and there's no defined ASN.1 for it. As a
result, I've put a Pad Length field to the CGA Option
in order to know when your field ends and the padding
starts. If people are unhappy with this approach, we
can also make the CGA draft have some kind of length
determination, and then we can skip the Pad Length
field.

Comments? Other issues?

--Jari

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: "James Kempf" <[email-masked]>
Date: Thu, 1 Apr 2004 08:21:40 -0800

This sounds fine, and consistent with the use of padding for the trust root
field.

            jak