Subject: Re: RE : Problem of interaction between SEND(CGA) and the IPv6 mobility

From: Greg Daley <[email-masked]>
Date: Sun, 11 Jul 2004 21:57:59 +1000

Hi Mohan, 

> > 
> Which deployment scenario requires secured Proxy ND ? If MIPv6
> is deployed by the operators, there would not be a real home link
> AFAIK. If MIPv6 is deployed in an enterprise, the trust is sufficient
> enough to not require proxy ND i guess. So, i am missing something
> on where proxy-ND would be required in practice.

Actually there's a possibility that 
Enterprises will be some of the earlier adopters
of Mobile IPv6, as opposed to carriers 
(well not opposed, but as an adjunct).

In this case, or in the case that a device
is actually on a home network, it may make sense
to turn off MIPv6 processing when at home 
(better MTUs, no per-packet IPSec processing load
etc).

For real (not dummy/loopback) home networks, 
there is a need for proxy ND, since we may have 
neighbours on the home network who wish to 
talk to us.

In fact, there was discussion during Mobile IPv6
development aimed at getting rid of home networks
in the specification (rather than just in
implementations by using dummy homes).  This was
rejected at the time (I was in the party for
removing them, and simplifying the spec).

Greg

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Sun, 11 Jul 2004 14:02:27 -0700

> neighbours on the home network who wish to 
My question was a bit confusing. I did not intend to question the
need for proxy ND. Only the security for it in the context of MIPv6,
which you answered  in your next mail.

-mohan