Subject: Re: Problem of interaction between SEND(CGA) and the IPv6 mobility

From: Greg Daley <[email-masked]>
Date: Sun, 11 Jul 2004 22:26:43 +1000

Hi James and Mohan, 

It's not the NAR which needs to do proxying, 
it's the PAR.

The PAR is on the network where the MN has
existing NCE's with other hosts and routers.
The PAR has to override these NCE's with its
own link-layer address to begin forwarding 
packets received on-link for the MN.

This is required for Both the predictive
and non-predictive scenarios.

----- Original Message -----
From: Mohan Parthasarathy <[email-masked]>
Date: Sunday, July 11, 2004 8:32 am
Subject: Re: Problem of interaction between SEND(CGA) and the IPv6 mobility

> James,
> 
> <snip>
> > 
> > jak>> Depending on whether the wireless link technology supports 
> predictive> or reactive handover, there may be an issue with 
> proxying. For a predictive
> > technology, the NAR may be required to proxy since the PAR 
> informs it of the
> > new CoA prior to the actual link handover. However, this is entirely
> > theoretical at the moment, because there is no widely available 
> wireless> link technology that supports predictive handover and, 
> simultaneously, would
> > be in a position to use FMIPv6. The cellular technologies all do 
> local link
> > handover optimization their own way ("stretchy PPP" for 3GPP2, 
> GPRS for PP).
> > 802.16 may support predictive handover, but the WG doing mobility 
> is about 2
> > years from completing the basic link design (I think it's .16e) 
> if I
> > understand correctly. With a reactive wireless link technology, 
> there's no
> > need for proxying because the mobile doesn't actually claim the 
> CoA until it
> > is on the link. 802.11 is a reactive technology, as is 802.15.2 
> (Bluetooth),
> I don't understand this part. Why do you think in 802.11, that the 
> NAR cannot defend
> the new CoA when the MN is on the old link ? When the node is on 
> the old link, why can't it 
> do the standard FMIPv6 like on any other link ? 
> 
> thanks
> mohan
> 
> > and so they don't need proxying. Given the focus in SEND on meeting
> > immediate technology needs quickly rather than doing the full 
> solution too
> > late, the WG decided to forgo working on secure proxying for now, 
> though the
> > design team did discuss some approaches. If SEND turns out to be 
> popular, we
> > can have a BOF and restart the WG to work on the remaining issues.

That sounds OK with me (although FMIPv6 and MIPv6
do require proxying if they share a 'home' or 'old'
link with other devices).

Greg

--------------------------------------------------------------------
To unsubscribe from this list, send email with "UNSUBSCRIBE" in the
body to <[email-masked]>.
Archive: http://standards.ericsson.net/lists/ietf-send/maillist.html
--------------------------------------------------------------------

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Sun, 11 Jul 2004 15:11:55 -0700

> It's not the NAR which needs to do proxying, 
It is required on the NAR also so that it can defend the address till the
MN attaches to the new link.

-mohan

---

From: Greg Daley <[email-masked]>
Date: Mon, 12 Jul 2004 09:13:30 +1000

Hi Mohan,

> MN attaches to the new link.

That is correct if you believe that DAD defense of an
predicted address is necessary to FMIPv6 :)

Greg

---

From: "James Kempf" <[email-masked]>
Date: Mon, 12 Jul 2004 09:23:01 -0700

Yes, that's right. PAR must proxy for both reactive and predictive handover,
NAR must proxy for predictive handover.

            jak

----- Original Message ----- 
From: "Greg Daley" <[email-masked]>
To: "Mohan Parthasarathy" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; "Jean-Michel COMBES"
<[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Sunday, July 11, 2004 5:26 AM
Subject: Re: Problem of interaction between SEND(CGA) and the IPv6 mobility