Subject: [sfc] Note on GI deployment scenario draft-liu-sfc-use-cases-00

From: Nicolas BOUTHORS <[email-masked]>
Date: Mon, 27 Jan 2014 09:22:31 +0000

Hello,

On Gi deployments the GGSN connects to a Radius Function at PDP Context Setup Time. In most case
this is used to perform and MSISDN to IP address mapping, which is then used by the Gi service infrastructure
to decide how to handle the IP flows for that particular subscriber.

This information cannot be derived by the DPI located after the GGSN. (It could if the DPI were to be located on the other side of the GGSN, the Gn interface).

It is clear that we should update the diagram to show the Radius traffic go through the DPI so that the DPI can extract the information and add it to the metadata which will be collected later as the subscriber traffic goes through.

Something like:

Chain 0: GGSN send Radius traffic to Radius server via the DPI so that the DPI can establish the IP/MSISDN correlation

Nicolas

---

From: Guanxiaoran <[email-masked]>
Date: Tue, 28 Jan 2014 07:23:27 +0000

Hi Nicolas,

Do you mean that DPI must support RADIUS proxy in this case?

Ran

发件人: sfc [mailto:[email-masked]] 代表 Nicolas BOUTHORS
发送时间: 2014年1月27日 17:23
收件人: [email-masked]
主题: [sfc] Note on GI deployment scenario draft-liu-sfc-use-cases-00

Hello,

Something like:

Nicolas

---

From: Nicolas BOUTHORS <[email-masked]>
Date: Tue, 28 Jan 2014 08:02:15 +0000

DPI does not have to be a Radius proxy. It can observe the Radius traffic via a Tap or get a copy
of the Radius traffic using OpenFlow tables if the traffic runs through a (virtual) switch that it can control.

Acting as a proxy is more complex as it can have an effect on performance and HA: the radius calls are on the critical path of PDP context establishment.

It is usefull only if we want to insure that the IP/MSISDN correlation is performed before any end user traffic is allowed to go through.

Watching over the Radius traffic also allows to capture other parameters such as the APN. The Radius server could also include extensions such as an indication of which policies should be applied to a particular subscriber traffic.
This last point combined to the metadata it collects could allow the DP to select the appropriate service chain to apply to outgoing packets

Nicolas

________________________________
From: Guanxiaoran [[email-masked]]
Sent: Tuesday, January 28, 2014 8:23 AM
To: Nicolas BOUTHORS; [email-masked]
Subject: 答复: Note on GI deployment scenario draft-liu-sfc-use-cases-00

Hi Nicolas,

Ran

Hello,

Something like:

Nicolas

---

From: Guanxiaoran <[email-masked]>
Date: Tue, 28 Jan 2014 09:46:27 +0000

Hi Nicolas,

The Radius server could also include extensions such as an indication of which policies should be applied to a particular subscriber traffic.
Ran> Does the RADIUS server send these information to the DPI or DPI capture them when the traffic goes through ?

Thanks,
Ran

发件人: sfc [mailto:[email-masked]] 代表 Nicolas BOUTHORS
发送时间: 2014年1月28日 16:02
收件人: Guanxiaoran
抄送: [email-masked]
主题: Re: [sfc] Note on GI deployment scenario draft-liu-sfc-use-cases-00

Nicolas

To: Nicolas BOUTHORS; [email-masked]<mailto:[email-masked]>

Ran

发件人: sfc [mailto:[email-masked]] 代表 Nicolas BOUTHORS
发送时间: 2014年1月27日 17:23
收件人: [email-masked]<mailto:[email-masked]>
主题: [sfc] Note on GI deployment scenario draft-liu-sfc-use-cases-00

Hello,

Something like:

Nicolas

---

From: Nicolas BOUTHORS <[email-masked]>
Date: Tue, 28 Jan 2014 10:13:51 +0000

The goal here is to get all the information in the Radius message, as the traffic goes through. It is however not part of the standards,
and relies on the ability of Radius to transport additional parameters.

It is interesting to note that sfc is not that far from what takes place in the EPC, or the Gn side of the GGSN, traffic is encapsulated
and tunneled through to get to the Internet. PDP establishment procedure is similar to what a Classifier has to do when
it establishes a service path. One important step is a identify the subscriber and retrieve the global policy identifiers that should apply
at that point in time.

To give and example, I can say  that closing a PDP context in a Gi environment, should be detected to prevent return traffic
such as video streams to be charged for, or have lagging parental control policies effect due to rapid IP reallocation.

________________________________
From: Guanxiaoran [[email-masked]]
Sent: Tuesday, January 28, 2014 10:46 AM
To: Nicolas BOUTHORS
Cc: [email-masked]
Subject: [sfc] 答复: Note on GI deployment scenario draft-liu-sfc-use-cases-00

Hi Nicolas,

Thanks,
Ran

Nicolas

Ran

Hello,

Something like:

Nicolas