Subject: Re: [sfc] SFC using VLANs

From: Sumandra Majee <[email-masked]>
Date: Tue, 28 Jan 2014 21:49:25 +0000

Yes it would be interesting. There are other solution which also build a dynamic chain based of service characteristic.  VLAN tag is the most obvious choice but is it not possible to use other encapsulation technology like GRE perhaps?

From: Dave Dolson <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 28, 2014 at 10:35 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] SFC using VLANs

Greetings,

At Sandvine we have been deploying a form of Service Function Chaining (albeit under different nomenclature) for about 5 years now.
Our Policy Traffic Switch (PTS) platform can initiate and terminate chains, steering traffic to different chains based on a variety of traffic and subscriber conditions.

The encapsulation is VLAN tagging, and the requirement on the SF node is to transparently bridge an Ethernet trunk, forwarding or injecting traffic using the same Ethernet addresses and VLAN tag.
We have addressed issues of chain symmetry, health checking, failure, load balancing and sending different chains through the same node.
A benefit of this approach is that explicit chain configuration is not required in the SF node itself.
An obvious con is the limited number of VLAN tags (no more than 4095), and the complexity of the switch configuration may lower that further.

If this group is interested, I could elaborate, including the details and pros/cons, either on this mailing list or in a draft. Any interest?

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 28 Jan 2014 17:27:37 -0500

There are a number of ways to do this without SFC.  You could create your chain using DSCP markings and use OF in the underlay to forward traffic with markings set (defaulting to standard IP networking if not set).  Many router vendors support a form of Policy Based Routing (aka filter based forwarding) that can be used code in the chains per flow.  You could even run an overlay like VXLAN or Contrail or Nuage that support a chaining-like feature.  And, yes, you could build a GRE encapsulation overlay as well.  

My hope is for SFC to provide a standard, simplified method of doing this.

I'm definitely interested to hear more about David's specific implementation, problems worked around, and features still not possible to implement with the current configuration.

From: [email-masked]<[email-masked]>
To: Dave Dolson<[email-masked]>,[email-masked]<[email-masked]>
Sent: Tuesday, January 28, 2014
Subject: Re: [sfc] SFC using VLANs

From: Dave Dolson <[email-masked]>

To: "[email-masked]" <[email-masked]>

Greetings,

 

David Dolson

---

From: "Songhaibin (A)" <[email-masked]>
Date: Wed, 29 Jan 2014 03:44:32 +0000

Would like to hear more about David’s implementation too.

Best Regards!
-Haibin

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, January 29, 2014 6:28 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [sfc] SFC using VLANs

________________________________
From: [email-masked]<[email-masked]<mailto:[email-masked][email-masked]>>
To: Dave Dolson<[email-masked]<mailto:[email-masked]>>,[email-masked]<[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, January 28, 2014
Subject: Re: [sfc] SFC using VLANs
Yes it would be interesting. There are other solution which also build a dynamic chain based of service characteristic. VLAN tag is the most obvious choice but is it not possible to use other encapsulation technology like GRE perhaps?

Greetings,