Subject: [sfc] SFC using VLANs

From: Dave Dolson <[email-masked]>
Date: Tue, 28 Jan 2014 18:35:05 +0000

Greetings,

At Sandvine we have been deploying a form of Service Function Chaining (albeit under different nomenclature) for about 5 years now.
Our Policy Traffic Switch (PTS) platform can initiate and terminate chains, steering traffic to different chains based on a variety of traffic and subscriber conditions.

The encapsulation is VLAN tagging, and the requirement on the SF node is to transparently bridge an Ethernet trunk, forwarding or injecting traffic using the same Ethernet addresses and VLAN tag.
We have addressed issues of chain symmetry, health checking, failure, load balancing and sending different chains through the same node.
A benefit of this approach is that explicit chain configuration is not required in the SF node itself.
An obvious con is the limited number of VLAN tags (no more than 4095), and the complexity of the switch configuration may lower that further.

If this group is interested, I could elaborate, including the details and pros/cons, either on this mailing list or in a draft. Any interest?

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: Ron Parker <[email-masked]>
Date: Tue, 28 Jan 2014 18:58:01 +0000

Hi, Dave.

I think the group could benefit greatly from your experiences.   In particular, the chain symmetry and load balancing aspects would be very interesting to me.

   Ron

From: sfc [mailto:[email-masked]] On Behalf Of Dave Dolson
Sent: Tuesday, January 28, 2014 1:35 PM
To: [email-masked]
Subject: [sfc] SFC using VLANs

Greetings,

David Dolson