Subject: [sfc] IPR check for draft-quinn-sfc-problem-statement

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 21 Jan 2014 19:05:13 +0000

This email serves as a poll for knowledge of any IPR that applies to draft [1], to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and major contributor.

If you are on the SFC WG mailing list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Thank you,

Jim & Thomas
SFC chairs

[1] http://tools.ietf.org/id/draft-quinn-sfc-problem-statement-02.txt

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 21 Jan 2014 14:54:58 -0500

None from my end.

On Jan 21, 2014:2:05 PM, at 2:05 PM, Jim Guichard (jguichar) <[email-masked]> wrote:

> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Tue, 21 Jan 2014 20:18:34 +0000

Ditto

From: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 21, 2014 2:54 PM
To: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Cc: Thomas Narten <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

None from my end.

On Jan 21, 2014:2:05 PM, at 2:05 PM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Thank you,

Jim & Thomas
SFC chairs

[1] http://tools.ietf.org/id/draft-quinn-sfc-problem-statement-02.txt
_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Tue, 21 Jan 2014 22:54:16 +0000

+1

Surendra.

From: "Ken Gray (kegray)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 21, 2014 12:18 PM
To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>, "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Cc: Thomas Narten <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: Rajeev Manur <[email-masked]>
Date: Tue, 21 Jan 2014 23:08:34 +0000

+1

Thanks!
--Rajeev

From: sfc [mailto:[email-masked]] On Behalf Of Surendra Kumar (smkumar)
Sent: Tuesday, January 21, 2014 2:54 PM
To: Jim Guichard (jguichar)
Cc: Thomas Narten; [email-masked]
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: Brad McConnell <[email-masked]>
Date: Tue, 21 Jan 2014 23:11:24 +0000

I'm not aware of any.

Thank you,

Brad McConnell

________________________________
From: sfc [[email-masked]] on behalf of Rajeev Manur [[email-masked]]
Sent: Tuesday, January 21, 2014 5:08 PM
To: Jim Guichard (jguichar)
Cc: Thomas Narten; [email-masked]
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

+1

Thanks!
--Rajeev

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Wed, 22 Jan 2014 01:00:54 +0000

Me neither.

Paul

On Jan 21, 2014, at 6:11 PM, Brad McConnell <[email-masked]<mailto:[email-masked]>> wrote:

I'm not aware of any.

Thank you,

Brad McConnell

________________________________
From: sfc [[email-masked]<mailto:[email-masked]>] on behalf of Rajeev Manur [[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, January 21, 2014 5:08 PM
To: Jim Guichard (jguichar)
Cc: Thomas Narten; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

+1

Thanks!
--Rajeev

From: sfc [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Surendra Kumar (smkumar)
Sent: Tuesday, January 21, 2014 2:54 PM
To: Jim Guichard (jguichar)
Cc: Thomas Narten; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: Navindra Yadav <[email-masked]>
Date: Tue, 21 Jan 2014 17:51:51 -0800

ditto.
cheers
Navindra

On Tue, Jan 21, 2014 at 5:00 PM, Paul Quinn (paulq) <[email-masked]> wrote:

>  Me neither.
>
>  Paul
>
>
>  On Jan 21, 2014, at 6:11 PM, Brad McConnell <[email-masked]>
> wrote:
>
>  I'm not aware of any.
>
> Thank you,
>
> Brad McConnell
>
>  ------------------------------
> *From:* sfc [[email-masked]] on behalf of Rajeev Manur [
> [email-masked]]
> *Sent:* Tuesday, January 21, 2014 5:08 PM
> *To:* Jim Guichard (jguichar)
> *Cc:* Thomas Narten; [email-masked]
> *Subject:* Re: [sfc] IPR check for draft-quinn-sfc-problem-statement
>
>
>  +1
>
>
>  Thanks!
>  --Rajeev
>
>
>   *From:* sfc [mailto:[email-masked]] *On Behalf Of *Surendra Kumar
> (smkumar)
> *Sent:* Tuesday, January 21, 2014 2:54 PM
> *To:* Jim Guichard (jguichar)
> *Cc:* Thomas Narten; [email-masked]
> *Subject:* Re: [sfc] IPR check for draft-quinn-sfc-problem-statement
>
>
>  +1
>
>
>   Surendra.
>
>
>   *From: *"Ken Gray (kegray)" <[email-masked]>
> *Date: *Tuesday, January 21, 2014 12:18 PM
> *To: *Thomas Nadeau <[email-masked]>, "Jim Guichard (jguichar)" <
> [email-masked]>
> *Cc: *Thomas Narten <[email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: [sfc] IPR check for draft-quinn-sfc-problem-statement
>
>
>   Ditto
>
>
>   *From: *Thomas Nadeau <[email-masked]>
> *Date: *Tuesday, January 21, 2014 2:54 PM
> *To: *"Jim Guichard (jguichar)" <[email-masked]>
> *Cc: *Thomas Narten <[email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: [sfc] IPR check for draft-quinn-sfc-problem-statement
>
>
>
>
>  None from my end.
>
>
>   This email serves as a poll for knowledge of any IPR that applies to
> draft [1], to ensure that IPR has been disclosed in compliance with IETF
> IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
>
>   If you are listed as a document author or contributor please respond to
> this email whether or not you are aware of any relevant IPR. The draft will
> not be adopted until a response has been received from each author and
> major contributor.
>
>
>   If you are on the SFC WG mailing list but are not listed as an author
> or contributor, then please explicitly respond only if you are aware of any
> IPR that has not yet been disclosed in conformance with IETF rules.
>
>
>   Thank you,
>
>
>   Jim & Thomas
>   SFC chairs
>
>

---

From: "Michael Smith (michsmit)" <[email-masked]>
Date: Wed, 22 Jan 2014 01:10:05 +0000

I'm not aware of any either.
Michael

From: "Paul Quinn (paulq)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 21, 2014 5:00 PM
To: Brad McConnell <[email-masked]<mailto:[email-masked]>>
Cc: Thomas Narten <[email-masked]<mailto:[email-masked]>>, "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

Me neither.

Paul

I'm not aware of any.

Thank you,

Brad McConnell

+1

Thanks!
--Rajeev

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: Chris Frederick <[email-masked]>
Date: Wed, 22 Jan 2014 16:07:27 +0000

Hello,
Sandvine has intellectual property related to the granular steering of traffic flows, specifically where the session has been established. This technique enables steering on the basis of application, content, etc, vs. just the port that would be seen in the initial SYN packet.
This is outlined here: http://www.google.com/patents/WO2004086714A1?cl=en
This is not related to SFC specifically but I bring it to your attention as this technique can be used to select flows that would then be redirected through a service function chain or path; Sandvine uses this mechanism in our own SFC implementation for example. Best regards,

Chris Frederick
Director, Technology Partnerships
[email-masked]

<mailto:[email-masked]>
From: sfc [mailto:[email-masked]] On Behalf Of Michael Smith (michsmit)
Sent: Tuesday, January 21, 2014 8:10 PM
To: Paul Quinn (paulq); Brad McConnell
Cc: Thomas Narten; Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

Me neither.

Paul

I'm not aware of any.

Thank you,

Brad McConnell

+1

Thanks!
--Rajeev

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: "Hongyu Li (Julio)" <[email-masked]>
Date: Thu, 23 Jan 2014 02:24:22 +0000

+1

From: sfc [mailto:[email-masked]] On Behalf Of Thomas Nadeau
Sent: Wednesday, January 22, 2014 3:55 AM
To: Guichard Jim
Cc: Thomas Narten; [email-masked]
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

       None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: Puneet Agarwal <[email-masked]>
Date: Thu, 23 Jan 2014 07:05:43 +0000

I am not aware of any.

Thx

Puneet

On Jan 21, 2014, at 11:05 AM, "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>> wrote:

Thank you,

Jim & Thomas
SFC chairs

---

From: <[email-masked]>
Date: Fri, 24 Jan 2014 15:24:31 +0100

Dear all,

I'm not aware of any IPR that applies to the problem statement draft.

Cheers,

Christian.

From: Jim Guichard <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 21, 2014 at 2:05 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Thomas Narten <[email-masked]<mailto:[email-masked]>>
Subject: IPR check for draft-quinn-sfc-problem-statement

Thank you,

Jim & Thomas
SFC chairs

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sun, 26 Jan 2014 14:58:20 +0000

Chairs,

I am not aware of relevant IPR applicable to draft-quinn-sfc-problem-statement-02.txt.

Thanks,

-- Carlos.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sun, 26 Jan 2014 15:00:28 +0000

Chris,

Just to be clear -- when you say "This is not related to SFC specifically", are you acknowledging that you know of no IPR with subject matter related to draft-quinn-sfc-problem-statement-02.txt?

Also, if there is any IPR to be disclosed, the actual disclosure should be done at http://www.ietf.org/ipr/file-disclosure.html and not on the WG mailing list.

Thanks,

-- Carlos.

On Jan 22, 2014, at 11:07 AM, Chris Frederick <[email-masked]> wrote:

> From: "Paul Quinn (paulq)" <[email-masked]>
> To: Brad McConnell <[email-masked]>
> Cc: Thomas Narten <[email-masked]>, "Jim Guichard (jguichar)" <[email-masked]>, "[email-masked]" <[email-masked]>
> On Jan 21, 2014, at 6:11 PM, Brad McConnell <[email-masked]> wrote:
> 
> 
> I'm not aware of any.
> 
> Thank you,
> 
> Brad McConnell
> 
> From: "Ken Gray (kegray)" <[email-masked]>
> To: Thomas Nadeau <[email-masked]>, "Jim Guichard (jguichar)" <[email-masked]>
> Cc: Thomas Narten <[email-masked]>, "[email-masked]" <[email-masked]>
> From: Thomas Nadeau <[email-masked]>
> To: "Jim Guichard (jguichar)" <[email-masked]>
> Cc: Thomas Narten <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: Chris Frederick <[email-masked]>
Date: Mon, 27 Jan 2014 14:27:46 +0000

Hi Carlos,
I was trying to draw a distinction between IPR related to the 'process of actual chaining' (which it's not) and IPR related to the granular selection of 'what gets chained' (which it is).
Thx for the pointer to the proper form, I'm new here + still  getting my bearings. Best,
/c

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Sunday, January 26, 2014 10:00 AM
To: Chris Frederick
Cc: Michael Smith (michsmit); Paul Quinn (paulq); Brad McConnell; Thomas Narten; Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

Chris,

Thanks,

-- Carlos.

On Jan 22, 2014, at 11:07 AM, Chris Frederick <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Chris Frederick

Cc: Thomas Narten; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>

Me neither.

Paul

I'm not aware of any.

Thank you,

Brad McConnell

+1

Thanks!
--Rajeev

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs

---

From: Chris Frederick <[email-masked]>
Date: Mon, 27 Jan 2014 14:36:28 +0000

Sorry, that's still not quite accurate; it's not just 'what gets chained', there's an element of 'how' as well...I felt it was worth flagging because the IPR covers an ability to steer (including into service function chains) based on protocol/application, content, and so on (i.e. information not available on the first packet), yet the technique enables redirection from the first packet.
Again, apologies for using the wrong forum; I'll check the link you provided. Thx,
/c

From: sfc [mailto:[email-masked]] On Behalf Of Chris Frederick
Sent: Monday, January 27, 2014 9:28 AM
To: Carlos Pignataro (cpignata)
Cc: Thomas Narten; [email-masked]; Jim Guichard (jguichar); Michael Smith (michsmit); Brad McConnell; Paul Quinn (paulq)
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

Hi Carlos,

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Sunday, January 26, 2014 10:00 AM
To: Chris Frederick
Cc: Michael Smith (michsmit); Paul Quinn (paulq); Brad McConnell; Thomas Narten; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] IPR check for draft-quinn-sfc-problem-statement

Chris,

Thanks,

-- Carlos.

Hello,

Chris Frederick

Me neither.

Paul

I'm not aware of any.

Thank you,

Brad McConnell

+1

Thanks!
--Rajeev

+1

Surendra.

Ditto

None from my end.

Thank you,

Jim & Thomas
SFC chairs