Subject: Re: [sfc] Progression of use case documents in the SFC WG

From: <[email-masked]>
Date: Tue, 1 Apr 2014 08:59:55 +0200

Tom,

As far as I know determining the consensus does not mean ignore the feedback of the list to a formal poll initiated by the chairs, nor misinterpret the discussion that are minuted and available online.

Cheers,
Med

>-----Message d'origine-----
>De : sfc [mailto:[email-masked]] De la part de Thomas Nadeau
>Envoyé : lundi 31 mars 2014 21:26
>À : Zhen Cao
>Cc : Guichard Jim; Hongyu Li (Julio); [email-masked]
>Objet : Re: [sfc] Progression of use case documents in the SFC WG
>
>
>On Mar 30, 2014:4:20 AM, at 4:20 AM, Zhen Cao <[email-masked]> wrote:
>
>> Hello Jim,
>>
>> On Sat, Mar 29, 2014 at 8:32 PM, Jim Guichard (jguichar)
>> <[email-masked]> wrote:
>>> You will note that this is not an outright rejection of
>>> draft-liu-sfc-use-cases but rather specific questions on the validity of
>>> adopting the document given that our preference (and the majority of
>>> responses from the WG support this view) is to produce standalone
>documents
>>
>> I do not think we can conclude if it is majority now. At least, I did
>> not see respect the previous email discussion and London meeting
>> minutes...
>
>	I think you misunderstand the job of the WG Chairs. It is their job
>to determine consensus, nor yours.
>
>	--Tom
>
>
>> for mobility and data center, and liaise with BBF for broadband.
>Therefore,
>>> what content is left in the more general document to justify adopting as
>a
>>> separate document? Further if adopted how as a WG can we avoid
>duplication
>>> of content across multiple documents?
>>
>> I think Hongyu already justified below. Besides, it also has a cloud
>> CPE use case which has not been covered elsewhere.
>>
>>> 3.      It provides an abstraction of common features of all use case,
>see
>>> section 4 in latest revision draft-liu-sfc-use-cases. This is a good
>>> guidance for requirements and architecture derivation.
>>
>> _______________________________________________
>> sfc mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sfc
>>

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 1 Apr 2014 07:08:10 +0000

What SDO does draft-kumar-sfc-dc-use-cases intend to target?
I see the introduction in the document:" Data centers -- enterprise, cloud or service provider -- deploy
   service nodes at various points in the network topology" which will overlap with many SDOs in scopes.

Thanks,
Yuanlong

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Saturday, March 29, 2014 1:25 AM
To: Joel M. Halpern; Zhen Cao
Cc: [email-masked]
Subject: Re: [sfc] Progression of use case documents in the SFC WG

Thank you Joel. Yes, this is the approach we plan to take and I see a lot
of support for that on the list.

On 3/28/14, 11:03 AM, "Joel M. Halpern" <[email-masked]> wrote:

>One aspect in the chairs proposal that struck me has particularly useful
>was keeping the use case document for specific partners separate.  That
>way, it is MUCH easier to liaise with 3GPP or the BBF on the aspects of
>the use cases that are important to them.
>
>Yours,
>Joel
>
>On 3/28/14, 4:34 AM, Zhen Cao wrote:
>> Dear Chairs,
>>
>> I do not know how we come to this conclusion given the below facts
>> 1) Email discussion on January,
>> http://www.ietf.org/mail-archive/web/sfc/current/msg00966.html, with
>> many supports of moving forward the  document draft-liu-sfc-use-cases.
>>
>> 2) London discussion as per
>> http://www.ietf.org/proceedings/89/minutes/minutes-89-sfc , where
>> several people voice out that we need one document
>>
>> As for draft-liu-sfc-use-cases, I'd say it is not a simple 'general'
>> use cases write-up, actually it has already merged with one mobility
>> use case from Med, and it also describe the use cases from the
>> abstract point of view, i.e. two angles that try to summarize the
>> existing activities.
>>
>> Technically, one use cases document is much better for people both
>> inside and outside to understand the sfc activities better. The
>> draft-liu-sfc-use-cases serves this target very well. And many use
>> cases are basically the same according the chaining logic, why we need
>> so many...
>>
>> So based on previous discussion both on the list and f2f meeting,  I
>> am suggesting that we move forward the general document and consider
>> other documents in meanwhile as they turn out to be significant.
>>
>> Many thanks,
>> zhen cao
>> china mobile
>>
>>> That leaves: http://datatracker.ietf.org/doc/draft-liu-sfc-use-cases/,
>>>a
>>> more general document. But that document includes text on three topics
>>>that
>>> would be covered in more detail elsewhere (broadband, mobile, and DC).
>>>While
>>> this document could contain pointers to the other documents, that
>>>leaves the
>>> document with very little standalone content -- raising the question
>>>of what
>>> should be done with it, or what content it could incorporate in order
>>>to be
>>> worthwhile as a standalone document.
>>>
>>> Thus, the chairs recommendation at this time is:
>>>
>>> 1) Call for WG adoption of draft-haeffner-sfc-use-case-mobility-00.txt
>>>and
>>> draft-kumar-sfc-dc-use-cases-00.txt as WG documents (target:
>>>informational).
>>>
>>> 2) Defer action on draft-liu-service-chaining-use-cases  and
>>> draft-meng-sfc-broadband-usecases per the above discussion.
>>>
>>> Does this make sense?
>>>
>>> Jim & Thomas
>>>

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 1 Apr 2014 11:42:29 +0000

Med, Zhen,

Let me first say that the chairs are not ignoring yours or anyone else's
feedback. No final decisions have been made and I can assure you that the
chairs are considering all inputs. There is no attempt to Œbias' or
Œmisinterpret' anything and I would ask that you stop throwing accusations
such as that around as it is not helping move the discussion forward; we
simply want to do what is in the best interests of the WG and enable a
process that will aid in moving work forward in a timely manner.

On 4/1/14, 2:59 AM, "[email-masked]"
<[email-masked]> wrote:

>Tom,
>
>As far as I know determining the consensus does not mean ignore the
>feedback of the list to a formal poll initiated by the chairs, nor
>misinterpret the discussion that are minuted and available online.
>
>Cheers,
>Med
>

---

From: <[email-masked]>
Date: Tue, 1 Apr 2014 13:54:23 +0200

Re-,

There were no accusations from my side; only a reminder of the process and what is minuted and available publically. 

Cheers,
Med

>De : Jim Guichard (jguichar) [mailto:[email-masked]]
>Envoyé : mardi 1 avril 2014 13:42
>À : BOUCADAIR Mohamed IMT/OLN; Thomas Nadeau; Zhen Cao
>Cc : Hongyu Li (Julio); [email-masked]

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 1 Apr 2014 11:59:21 +0000

Thank you.

On 4/1/14, 7:54 AM, "[email-masked]"
<[email-masked]> wrote:

>Re-,
>
>There were no accusations from my side; only a reminder of the process
>and what is minuted and available publically.
>
>Cheers,
>Med
>
>>>>>> draft-liu-sfc-use-cases but rather specific questions on the
>>>>>>validity
>>>>>>of
>>>>>> what content is left in the more general document to justify
>>>>>>adopting
>>>>>>as
>>>>a

---

From: Zhen Cao <[email-masked]>
Date: Tue, 1 Apr 2014 22:25:25 +0800

There were no accusations from my side either, just trying to make things
better.

Regards,
Zhen

Jim Guichard (jguichar) <[email-masked]>于2014年4月1日星期二写道：

> On 4/1/14, 2:59 AM, "[email-masked] <javascript:;>"
> <[email-masked] <javascript:;>> wrote:
>
> >Tom,
> >
> >>De : sfc [mailto:[email-masked] <javascript:;>] De la part de
> Thomas Nadeau
> >>Cc : Guichard Jim; Hongyu Li (Julio); [email-masked] <javascript:;>
> >>On Mar 30, 2014:4:20 AM, at 4:20 AM, Zhen Cao <[email-masked]<javascript:;>>
> wrote:
> >>
> >>> Hello Jim,
> >>>
> >>> <[email-masked] <javascript:;>> wrote:
> >>> [email-masked] <javascript:;>

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 1 Apr 2014 13:40:36 -0400

I hardly think you need to remind the co-chairs (or document editors) of the process.  We've all been doing this for quite some time and know the drill.

	--Tom

---

From: <[email-masked]>
Date: Wed, 2 Apr 2014 08:00:38 +0200

Tom,

Should we focus on the core discussion topic of this thread rather than diverting? 

There are precise objections in this thread and an alternate proposal to produce "ONE" single use case document to meet the working group charter and to help collecting data that would be used as an input to the requirements.

Cheers,
Med

>De : Thomas Nadeau [mailto:[email-masked]]
>Envoyé : mardi 1 avril 2014 19:41
>À : BOUCADAIR Mohamed IMT/OLN
>Cc : [email-masked]
>	I hardly think you need to remind the co-chairs (or document editors)
>of the process.  We've all been doing this for quite some time and know the
>drill.
>
>	--Tom
>
>