Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 18 Apr 2014 22:31:48 +0000

Dear WG:

This message begins a two week call for WG adoption of the document http://www.ietf.org/id/draft-kumar-sfc-dc-use-cases-01.txt ending 2nd May 2014.

Please respond to the SFC mailing list with any statements of approval or disapproval.

Please note:

  1.  This is not WG Last Call. The document is not final, and the WG is expected to modify the document’s content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
  2.  If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
  3.  If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 18 Apr 2014 19:25:20 -0400

I support adoption of this document by the working group.  It is a good 
starting point for addressing the material it covers, and the working 
group should cover that material.

Yours,
Joel

On 4/18/14, 6:31 PM, Jim Guichard (jguichar) wrote:
> Dear WG:
>
> This message begins a two week call for WG adoption of the document
> http://www.ietf.org/id/draft-kumar-sfc-dc-use-cases-01.txt ending 2nd
> May 2014.
>
>  1. This is not WG Last Call. The document is not final, and the WG is
>     expected to modify the document’s content until there is WG
>     consensus that the content is solid. Therefore, please don’t oppose
>     adoption just because you want to see changes to its content.
>  2. If you have objections to adoption of the document, please state
>     your reasons why, and explain what it would take to address your
>     concerns.
>  3. If you have issues with the content, by all means raise those issues
>     and we can begin a dialog about how best to address them.
>
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 19 Apr 2014 17:12:26 +0000

I support as well

On 19 Apr 2014, at 01:25 , Joel M. Halpern <[email-masked]> wrote:

> I support adoption of this document by the working group.  It is a good starting point for addressing the material it covers, and the working group should cover that material.
>
> Yours,
> Joel
>

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Rajeev Manur <[email-masked]>
Date: Sun, 20 Apr 2014 23:14:30 +0000

Support

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, April 18, 2014 3:32 PM
To: [email-masked]
Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

Please note:

  1.  This is not WG Last Call. The document is not final, and the WG is expected to modify the document's content until there is WG consensus that the content is solid. Therefore, please don't oppose adoption just because you want to see changes to its content.
  2.  If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
  3.  If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

---

From: ramki Krishnan <[email-masked]>
Date: Sun, 20 Apr 2014 16:19:12 -0700

Support.

Thanks,
Ramki

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: Saturday, April 19, 2014 10:12 AM
To: Joel M. Halpern
Cc: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

I support as well

On 19 Apr 2014, at 01:25 , Joel M. Halpern <[email-masked]> wrote:

>>    expected to modify the document's content until there is WG
>>    consensus that the content is solid. Therefore, please don't oppose

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Mon, 21 Apr 2014 15:37:47 +0000

I support this draft, it covers an important deployment where SFC is very relevant.

Paul

On Apr 18, 2014, at 3:31 PM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Dear WG:

Please note:

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Ron Parker <[email-masked]>
Date: Mon, 21 Apr 2014 17:31:29 +0000

Support.

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, April 18, 2014 6:32 PM
To: [email-masked]
Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

Please note:

---

From: Nicolas BOUTHORS <[email-masked]>
Date: Tue, 22 Apr 2014 07:30:37 +0000

I support the adoption of  http://www.ietf.org/id/draft-kumar-sfc-dc-use-cases-01.txt

Nicolas Bouthors
________________________________
From: Jim Guichard (jguichar) [[email-masked]]
Sent: Saturday, April 19, 2014 12:31 AM
To: [email-masked]
Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

Please note:

---

From: <[email-masked]>
Date: Thu, 24 Apr 2014 07:41:38 +0200

Dear all,

I don't support the adoption of this draft for the reasons already listed in the list. I'm for one single use case document.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Jim Guichard (jguichar)
Envoyé : samedi 19 avril 2014 00:32
À : [email-masked]
Objet : [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

Please note:

---

From: Changcheng Huang <[email-masked]>
Date: Fri, 25 Apr 2014 07:55:50 +0900

I don't support the adoption of this document. I think it has not covered some key aspects of datacenter. It is well known that datacenter services can be provided in different levels which include IaaS, PaaS, and SaaS. This document has not addressed use cases under these different scenarios, nor has it discussed the possible business relationships that may have an impact on SFC. We have proposed recursive service in our contribution (draft-huang) which addresses these use cases and how they may be supported. 

Best regards,

Chang

------------
Changcheng Huang

> On Apr 19, 2014, at 7:31 AM, "Jim Guichard (jguichar)" <[email-masked]> wrote:
> 
> Dear WG:
> 
> This is not WG Last Call. The document is not final, and the WG is expected to modify the document’s content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
> If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
> If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 24 Apr 2014 23:22:00 +0000

Hi Chang,

Thanks for you inputs. Please note however that the document *if* adopted is not final and the WG is fully expected to modify its content until there is consensus that all of the major components have been addressed. Please continue to work with the authors to incorporate your suggestions if appropriate.

Sent from my iPhone

On Apr 24, 2014, at 6:56 PM, "Changcheng Huang" <[email-masked]<mailto:[email-masked]>> wrote:

Best regards,

Chang

------------
Changcheng Huang

On Apr 19, 2014, at 7:31 AM, "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>> wrote:

Dear WG:

Please note:

---

From: Sumandra Majee <[email-masked]>
Date: Fri, 25 Apr 2014 00:33:16 +0000

Are you referring to
 http://tools.ietf.org/html/draft-huang-sfc-service-forwarding-label-00

If so I have a few questions.

From: Changcheng Huang <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 24, 2014 at 3:55 PM
To: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Best regards,

Chang

------------
Changcheng Huang

Dear WG:

Please note:

---

From: Lucy yong <[email-masked]>
Date: Fri, 25 Apr 2014 14:21:09 +0000

Hi Jim,

There are several DC related use case drafts. What reason chairs choose draft-kumar as WG?

IMO: draft-kumar describes very generic SFC use case which can be captured as general use case regardless locations. What is the purpose to adopt this draft now?

I do not support this adoption.

Regards,
Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, April 24, 2014 6:22 PM
To: Changcheng Huang
Cc: [email-masked]
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Hi Chang,

Sent from my iPhone

Best regards,

Chang

------------
Changcheng Huang

Please note:

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 25 Apr 2014 20:15:13 +0000

I like the examples given by the draft, like the sequence of functions needed for North-South traffic and the sequence of functions needed for East-West traffic.

But my puzzle is  why all traffic terminated at the ADC? Isn't this very vendor specific?

For North-South traffic, it also very common to have frontend WebServers to terminate the external traffic. And there is Front-End FW and LB before the WebServers. Then traffic go to AppServer that again have its specific FW and LB. Then traffic go to DB servers that have their specific FW (a.k.a. backend FW) and LB.

There are many examples of Service Function Chain in DC environment. The SFC WG use cases should focus on the ones that can drive specific requirement.

I can't see how the examples listed in Section 3 drive the requirement listed in Section 5. The requirement listed in Section 5 are so general, that you don't need those examples listed in Section 3.

I think the key requirement driven by examples in Section 3 is to allow those Service Functions to be located  anywhere (i.e. not necessarily on the data path). Therefore, the key requirement is allow dynamic steering policies to Service Nodes, routers, and switches.

Therefore, I don't support this draft to be adopted to WG draft.

Linda Dunbar

From: sfc [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Friday, April 25, 2014 9:21 AM
To: Jim Guichard (jguichar); Changcheng Huang
Cc: [email-masked]
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Hi Jim,

Regards,
Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, April 24, 2014 6:22 PM
To: Changcheng Huang
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Hi Chang,

Sent from my iPhone

Best regards,

Chang

------------
Changcheng Huang

Please note:

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sun, 27 Apr 2014 22:58:57 +0000

SFC Chairs,

I support the adoption of draft-kumar-sfc-dc-use-cases-01 as an SFC WG document.

This document addresses a very important set of use cases of SFC on the DC. The scope is relevant, and the document itself is a very comprehensive, thorough, and clear starting point for the WG. As a starting point, I believe the document achieves a good balance in being general enough while describing specifics of the DC.

Thanks,

-- Carlos.

On Apr 18, 2014, at 6:31 PM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Dear WG:

Please note:

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Mon, 28 Apr 2014 21:55:56 +0000

Support, this document is a good starting place for the WG.

-Darrel
On Apr 18, 2014, at 3:31 PM, Jim Guichard (jguichar) <[email-masked]> wrote:

> 	• This is not WG Last Call. The document is not final, and the WG is expected to modify the document’s content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
> 	• If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
> 	• If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

---

From: Jiafeng Zhu <[email-masked]>
Date: Tue, 29 Apr 2014 00:08:58 +0000

Hi Jim,
I don't support this  adoption. Although it mentions the multiple tenants situation, in section 3 ... Further, enterprise data centers may be organized along businesses, with each business treated as a tenant, thereby supporting multi-tenancy...,  but this document doesn't clearly indicate that a tenant can also provide services for its tenant recursively.
                Regards,
                Jiafeng Zhu

Dear WG:

Please note:

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 29 Apr 2014 12:03:24 +0000

Hi Jiafeng,

Please note that the omission of content is normal process and the WG is expected to modify the document content until there is WG consensus that the content is solid and complete. If you believe there is content missing please have that discussion either directly with the authors or on the list so that your concerns may be properly discussed.

From: Jiafeng Zhu <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 28, 2014 at 8:08 PM
To: Jim Guichard <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Call for adoption of draft-kumar-sfc-dc-use-cases-01

Hi Jim,
I don’t support this  adoption. Although it mentions the multiple tenants situation, in section 3 … Further, enterprise data centers may be organized along businesses, with each business treated as a tenant, thereby supporting multi-tenancy…,  but this document doesn’t clearly indicate that a tenant can also provide services for its tenant recursively.
                Regards,
                Jiafeng Zhu

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, April 18, 2014 3:32 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

Please note:

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Tue, 29 Apr 2014 16:56:29 +0000

I also support this draft. Being on DC level this draft will complement the other use case drafts. Beside typical FW or DPI etc. there should be not that much overlap with the more carrier services oriented use case drafts.

Cheers, Walter

-----Ursprüngliche Nachricht-----
Von: sfc [mailto:[email-masked]] Im Auftrag von Joel M. Halpern
Gesendet: Samstag, 19. April 2014 01:25
An: Jim Guichard (jguichar); [email-masked]
Betreff: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Yours,
Joel

---

From: "Pham, Chuong D" <[email-masked]>
Date: Wed, 30 Apr 2014 09:35:07 +1000

Separate drafts for pockets of environments will most likely overlook the opportunities for identifying commonalities, synergies and reuse factors between similar use cases for different environments. This is the painful situation today where silos exist while at this point in time where Mobile, Fixed Broadband and Data Centre are seeing strong forces towards convergence with SDN, NFV and Cloud technologies.

An overall draft such as draft-liu or similar must exist as a common reference point for more detailed level drafts addressing use cases for specific/pockets of environments while allowing for future migration/convergence.

Unless draft-kumar co-exists with high level draft-liu, I see more harm in divergence rather than benefits therefore I disapprove.

Regards,
Chuong

-----Original Message-----
From: Haeffner, Walter, Vodafone DE [mailto:[email-masked]] 
Sent: Wednesday, 30 April 2014 2:56 AM
To: Joel M. Halpern; Jim Guichard (jguichar); [email-masked]
Cc: Jeffrey Napper (jenapper) ([email-masked])
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Cheers, Walter

-----Ursprüngliche Nachricht-----
Von: sfc [mailto:[email-masked]] Im Auftrag von Joel M. Halpern
Gesendet: Samstag, 19. April 2014 01:25
An: Jim Guichard (jguichar); [email-masked]
Betreff: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Yours,
Joel

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Wed, 30 Apr 2014 06:53:57 +0000

Hi all,

As I explained the reason replied in another thread "Re: [sfc] Progression of SFC use case documents", I don't support the adoption of this draft.

Regards,
Will (Shucheng LIU)

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Saturday, April 19, 2014 6:32 AM
To: [email-masked]
Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

Please note:

---

From: "Hongyu Li (Julio)" <[email-masked]>
Date: Wed, 30 Apr 2014 07:02:17 +0000

Can't agree more.

Hongyu

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Pham, Chuong D
Sent: Wednesday, April 30, 2014 7:35 AM
To: Haeffner, Walter, Vodafone DE; Joel M. Halpern; Jim Guichard (jguichar); [email-masked]
Cc: Jeffrey Napper (jenapper) ([email-masked])
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Regards,
Chuong

-----Original Message-----
From: Haeffner, Walter, Vodafone DE [mailto:[email-masked]]
Sent: Wednesday, 30 April 2014 2:56 AM
To: Joel M. Halpern; Jim Guichard (jguichar); [email-masked]
Cc: Jeffrey Napper (jenapper) ([email-masked])
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Cheers, Walter

-----Ursprüngliche Nachricht-----
Von: sfc [mailto:[email-masked]] Im Auftrag von Joel M. Halpern
Gesendet: Samstag, 19. April 2014 01:25
An: Jim Guichard (jguichar); [email-masked]
Betreff: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Yours,
Joel