Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

From: Sumandra Majee <[email-masked]>
Date: Thu, 24 Apr 2014 00:44:39 +0000

I support the adoption but I have following observations.

  1)  Datacenter encompasses a lot of application and varied vertical market. I would like to see this focus on the enterprise and perhaps the cloud DC use cases. Service providers use data center too, but the policies are often applied per subscriber and per resource (URL), per application. Enterprise datacenter policy may not involve per user policy (I think most will not but it does involve a group of users).

There are layers of ADC in the enterprise in the form of,
   L4 distribution  ———— ADC 1(with a unicast VIP1) [APP resource]  —————  ADC2 (VIP2 : APP resource 2). These can be viewed as same instance or sometimes NOT.

2) In the mobile DC when flows are threaded thru a series of VAS,  the 5 tuple remain unchanged. That is not the case in enterprise when there is a server to server communication on behalf of a client.  The east west traffic in cloud DC is quite unruly since the changes are made often and new services are created by DevOps  every so often. I think this is a significantly different from SP datacenter (where scale matters but number of unique applications are relatively small) and should be covered in detail.

I would rather see the focus on enterprise/cloud (call this draft-enterprise-….) and cover the uniqueness of that piece of land than a generic DC.

Regards.

Sumandra

From: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 18, 2014 at 3:31
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Dear WG:

This message begins a two week call for WG adoption of the document http://www.ietf.org/id/draft-kumar-sfc-dc-use-cases-01.txt ending 2nd May 2014.

Please respond to the SFC mailing list with any statements of approval or disapproval.

Please note:

  1.  This is not WG Last Call. The document is not final, and the WG is expected to modify the document’s content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
  2.  If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
  3.  If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

---

From: Barry Greene <[email-masked]>
Date: Thu, 24 Apr 2014 08:02:06 +0700

I echo Sumandra's observation. This needs another section to provide context, but the model in the use cases section would work with each context. 

Additionally, the "use cases" section does not read as "use cases." It is a very useful tool to use in SFC design in a DC, but not what you usually see as "use cases."

On Apr 24, 2014, at 7:44 AM, Sumandra Majee <[email-masked]> wrote:

> From: "Jim Guichard (jguichar)" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> 	• This is not WG Last Call. The document is not final, and the WG is expected to modify the document’s content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
> 	• If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
> 	• If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them. 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Fri, 25 Apr 2014 01:10:34 +0000

Thanks Sumandra!

As you seem to have noticed, the primary focus is indeed enterprise. However, there are a lot of commonalities with SP DCs and is the reason why it is extended to include SPs. I hear you on the policies. At the same time I've seen the swings from per-resource on one end to the per-user at the other end.  There are use cases involving per-user policy even in the enterprise – Fine grain firewalls (DC de-perimetrization) as one example, where policies can be enforced at the user and URL level.

Regarding 5-tuple in Mobile, five tuples do change. I can think of Mobile SPs using private addresses and NATing them towards the Internet.

Look forward to any specific comments and suggestions you may have and we will reflect them in the next revision.

Surendra.

From: Sumandra Majee <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 23, 2014 5:44 PM
To: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Regards.

Sumandra

Dear WG:

Please note:

---

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Fri, 25 Apr 2014 01:18:51 +0000

Barry,

Your observation is correct. We intentionally kept it to a higher level as
opposed to going into each of the specific examples in detail, primarily
to keep the focus on driving the SFC architecture requirements. If we
enumerate service function chains, we will not only have a quite a lengthy
draft but will also not demonstrate any new requirements.

Your comments well noted and thank you!

Surendra.

On 4/23/14 6:02 PM, "Barry Greene" <[email-masked]> wrote:

>
>I echo Sumandra's observation. This needs another section to provide
>context, but the model in the use cases section would work with each
>context. 
>
>Additionally, the "use cases" section does not read as "use cases." It is
>a very useful tool to use in SFC design in a DC, but not what you usually
>see as "use cases."
>
>
>>   1)  Datacenter encompasses a lot of application and varied vertical
>>market. I would like to see this focus on the enterprise and perhaps the
>>cloud DC use cases. Service providers use data center too, but the
>>policies are often applied per subscriber and per resource (URL), per
>>application. Enterprise datacenter policy may not involve per user
>>policy (I think most will not but it does involve a group of users).
>> 
>>    L4 distribution  ‹‹‹‹ ADC 1(with a unicast VIP1) [APP resource]
>>‹‹‹‹‹  ADC2 (VIP2 : APP resource 2). These can be viewed as same
>>instance or sometimes NOT.
>> 
>> 2) In the mobile DC when flows are threaded thru a series of VAS,  the
>>5 tuple remain unchanged. That is not the case in enterprise when there
>>is a server to server communication on behalf of a client.  The east
>>west traffic in cloud DC is quite unruly since the changes are made
>>often and new services are created by DevOps  every so often. I think
>>this is a significantly different from SP datacenter (where scale
>>matters but number of unique applications are relatively small) and
>>should be covered in detail.
>> 
>> I would rather see the focus on enterprise/cloud (call this
>>draft-enterprise-Š.) and cover the uniqueness of that piece of land than
>>a generic DC.
>> 
>> Regards.
>> 
>> Sumandra
>> 
>> This message begins a two week call for WG adoption of the document
>>http://www.ietf.org/id/draft-kumar-sfc-dc-use-cases-01.txt ending 2nd
>>May 2014. 
>> 
>> 	€ This is not WG Last Call. The document is not final, and the WG is
>>expected to modify the document¹s content until there is WG consensus
>>that the content is solid. Therefore, please don¹t oppose adoption just
>>because you want to see changes to its content.
>> 	€ If you have objections to adoption of the document, please state
>>your reasons why, and explain what it would take to address your
>>concerns.
>> 	€ If you have issues with the content, by all means raise those issues
>>and we can begin a dialog about how best to address them.

---

From: Lucy yong <[email-masked]>
Date: Fri, 25 Apr 2014 14:13:08 +0000

Hi Surendra,

The point you expressed below is the reason I do not support adopting draft-kumar. The draft describes a general SFC use case in data centers, which can be described in a general use case draft regardless locations and help driving the SFC architecture requirement. 

Regards,
Lucy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Surendra Kumar (smkumar)
Sent: Thursday, April 24, 2014 8:19 PM
To: Barry Greene; Sumandra Majee
Cc: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Barry,

Your observation is correct. We intentionally kept it to a higher level as opposed to going into each of the specific examples in detail, primarily to keep the focus on driving the SFC architecture requirements. If we enumerate service function chains, we will not only have a quite a lengthy draft but will also not demonstrate any new requirements.

Surendra.

On 4/23/14 6:02 PM, "Barry Greene" <[email-masked]> wrote:

>Additionally, the "use cases" section does not read as "use cases." It 
>is a very useful tool to use in SFC design in a DC, but not what you 
>usually see as "use cases."
>
>
>>market. I would like to see this focus on the enterprise and perhaps 
>>the cloud DC use cases. Service providers use data center too, but the 
>>5 tuple remain unchanged. That is not the case in enterprise when 
>>there is a server to server communication on behalf of a client.  The 
>>east west traffic in cloud DC is quite unruly since the changes are 
>>made often and new services are created by DevOps  every so often. I 
>>think this is a significantly different from SP datacenter (where 
>>scale matters but number of unique applications are relatively small) 
>>and should be covered in detail.
>> 
>>draft-enterprise-Š.) and cover the uniqueness of that piece of land 
>>than a generic DC.
>> 
>> Regards.
>> 
>> Sumandra
>> 
>>that the content is solid. Therefore, please don¹t oppose adoption 
>>just because you want to see changes to its content.
>> 	€ If you have issues with the content, by all means raise those 
>>issues and we can begin a dialog about how best to address them.

---

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Fri, 25 Apr 2014 14:22:01 +0000

Lucy,

That comment was specifically in the context of enterprise DCs. It still
has specific examples but does not enumerate them to death.

Rgds,
Surendra.

On 4/25/14 7:13 AM, "Lucy yong" <[email-masked]> wrote:

>Hi Surendra,
>
>The point you expressed below is the reason I do not support adopting
>draft-kumar. The draft describes a general SFC use case in data centers,
>which can be described in a general use case draft regardless locations
>and help driving the SFC architecture requirement.
>
>Regards,
>Lucy
>
>
>
>Your observation is correct. We intentionally kept it to a higher level
>as opposed to going into each of the specific examples in detail,
>primarily to keep the focus on driving the SFC architecture requirements.
>If we enumerate service function chains, we will not only have a quite a
>lengthy draft but will also not demonstrate any new requirements.
>

---

From: Lucy yong <[email-masked]>
Date: Fri, 25 Apr 2014 14:28:00 +0000

Hi Surendra,

Could you point out which examples in draft-kumar have a specific requirement that draft-haeffner and draft-liu do not cover?

Thanks,
Lucy

-----Original Message-----
From: Surendra Kumar (smkumar) [mailto:[email-masked]] 
Sent: Friday, April 25, 2014 9:22 AM
To: Lucy yong; Barry Greene; Sumandra Majee
Cc: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Lucy,

That comment was specifically in the context of enterprise DCs. It still has specific examples but does not enumerate them to death.

Rgds,
Surendra.

On 4/25/14 7:13 AM, "Lucy yong" <[email-masked]> wrote:

>draft-kumar. The draft describes a general SFC use case in data 
>centers, which can be described in a general use case draft regardless 
>locations and help driving the SFC architecture requirement.
>
>Regards,
>Lucy
>
>
>
>If we enumerate service function chains, we will not only have a quite 
>a lengthy draft but will also not demonstrate any new requirements.
>
>>>   1)  Datacenter encompasses a lot of application and varied 
>>>vertical market. I would like to see this focus on the enterprise and 
>>>perhaps the cloud DC use cases. Service providers use data center 
>>>too, but the policies are often applied per subscriber and per 
>>>resource (URL), per application. Enterprise datacenter policy may not 
>>>involve per user policy (I think most will not but it does involve a group of users).
>>> 
>>> 	€ This is not WG Last Call. The document is not final, and the WG 
>>>is expected to modify the document¹s content until there is WG 
>>>consensus that the content is solid. Therefore, please don¹t oppose 
>>>adoption just because you want to see changes to its content.