Subject: [sfc] Questions about draft-quinn-sfc-arch-05

From: Xuxiaohu <[email-masked]>
Date: Wed, 18 Jun 2014 10:07:58 +0000

Hi all,

I have two questions about draft-quinn-sfc-arch-05:

1. According to the following figure quoted from the above draft, it seems each SFF Table entry (I,e., SFP) only contains an ordered list of SF IDs. If so, for a given SFID in the list, how does the SFF know on which particular service node that SF should be performed (assume there are multiple service nodes which can provide the SF of that SF ID)?

                +------+----------------------------------+
                | SFP  |   Ordered Service Functions      |
                |------+----------------------------------+
                | ID   | order1 | order2 | order3 | ...   |
                +------+--------+--------+--------+-------+
                | SFP1 | SFID1  | SFID5  | SFID20 |       |
                +------+--------+--------+--------+-------+
                | SFP4 | SFID100| SFID3  | SFID4  | SFID9 |
                +------+--------+--------+--------+-------+
                | ...  |        |        |        |       |
                +------+--------+--------+--------+-------+

                            Figure 3: SFF Table

2. Does the Transport Derived SFF concept mean the SFP could also be represented by some information contained in the transport layer, instead of the service path id contained in the SFC encapsulation header? For instance, an ordered list of service node locators and service function instance identities (see http://tools.ietf.org/html/draft-xu-spring-sfc-use-case-01)?

Best regards,
Xiaohu

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 18 Jun 2014 14:00:44 +0000

When you create a Service Path you define the actual service functions (SFs + locator) that will provide service. When you create a service function chain you only define the type of the service function (dpi, firewall, nat).

thanks,

Reinaldo
________________________________________
From: sfc [[email-masked]] on behalf of Xuxiaohu [[email-masked]]
Sent: Wednesday, June 18, 2014 3:07 AM
To: [email-masked]
Subject: [sfc] Questions about draft-quinn-sfc-arch-05

Hi all,

                            Figure 3: SFF Table

Best regards,
Xiaohu

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 19 Jun 2014 01:27:21 +0000

> -----Original Message-----
> From: Reinaldo Penno (repenno) [mailto:[email-masked]]
> Sent: Wednesday, June 18, 2014 10:01 PM
> To: Xuxiaohu; [email-masked]
> Subject: RE: Questions about draft-quinn-sfc-arch-05
> 
> When you create a Service Path you define the actual service functions (SFs +
> locator) that will provide service. When you create a service function chain you
> only define the type of the service function (dpi, firewall, nat).

Sure. The SFP should be represented by an ordered list of SF IDs and SN locators. However, it seems that the SFF table entry (an ordered list of SF IDs) as described in draft-quinn-sfc-arch-05 is about an SFC, rather than an SFP.

Best regards,
Xiaohu
 
> 1. According to the following figure quoted from the above draft, it seems each
> SFF Table entry (I,e., SFP) only contains an ordered list of SF IDs. If so, for a given
> SFID in the list, how does the SFF know on which particular service node that SF
> should be performed (assume there are multiple service nodes which can
> provide the SF of that SF ID)?
> 
> 
> 2. Does the Transport Derived SFF concept mean the SFP could also be
> represented by some information contained in the transport layer, instead of the
> service path id contained in the SFC encapsulation header? For instance, an
> ordered list of service node locators and service function instance identities (see
> http://tools.ietf.org/html/draft-xu-spring-sfc-use-case-01)?
> 
> Best regards,
> Xiaohu
>