Subject: [sfc] 2nd WG Last Call on Problem Statement

From: Thomas Narten <[email-masked]>
Date: Wed, 25 Jun 2014 15:13:35 -0400

Hi.

We ran a WGLC on the problem statement draft
(draft-ietf-sfc-problem-statement-07.txt) back in May.
Although the draft received significant review and support prior to
the formal LC, the actual last call resulted largely in silence.

While it would be convenient to take silence as acceptance, that's not
good enough. To show the document is ready, we need WG members to
speak up and indicate they have read a recent version of the document
and think its ready to go.

Note that the document was just reissued. Section 3 has been edited to
remove some of the text was deemed to be encroaching on
architecture. You can see the changes at
http://tools.ietf.org/wg/sfc/draft-ietf-sfc-problem-statement/draft-ietf-sfc-problem-statement-07-from-06.diff.html

With that, we are restarting a 2-week WGLC on the document. We
specifically need to see sufficient indications from WG members that
the document is ready to advance, and that the document does not
contain significant deficiencies.

Thomas

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Thu, 26 Jun 2014 13:35:04 +0000

Thomas,

As an editor: I support moving this draft forward.

Paul

On Jun 25, 2014, at 3:13 PM, Thomas Narten <[email-masked]> wrote:

> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 26 Jun 2014 14:20:03 +0000

I suport it as well

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Thu, 26 Jun 2014 14:40:43 +0000

Hello,

I think the document needs editing and clarification before moving
forward. Many sub-sections seems redundant and intertwined.

Comment 1:

Section 2.1, 2.2, 2.4, 2.7 and 2.8 are  talking about the same root
problem: configuration complexity.

2.1, 2.4, 2.7 and 2.8 are consequences of 2.2 and not really a problem
statement in itself. At least that¹s how I see it. If you solve
configuration complexity, the others will consequently be solved.

I think it is worth to maintain the discussion but not as a separate
problem space, they should be under ³Configuration complexity² sub-section.

Some snippets to the point:

Section 2.1

"resulting in complex network changes and device configuration."

Section 2.4

"Service function chains today are most typically built through manual
   configuration processes.  These are slow and error prone."

Section 2.7

"rapid
   changes to the service deployment can be hard to realize due to the
   risk and complexity of such changes.
³

Section 2.8

"This
   results in operationally complex configurations and is still
   relatively inflexible."

These are all basically saying that today configuration is complex and
manual and automatic configuration would be a great idea.

Comment 2:

Section 2.6 seems a executive summary of parts of section 2.1 since the
tying service function to topology you are saying service function must
understand that transport.

"The coupling of service
   functions to topology requires service functions to support many
   transport encapsulations or for a transport gateway function to be
   present.²

Comment 3:

I have trouble parsing this sentence.

"Since traffic reaches many service functions based on network
   topology, alternate, or redundant service functions must be placed in
   the same topology as the primary service.²

On 6/26/14, 6:35 AM, "Paul Quinn (paulq)" <[email-masked]> wrote:

>>http://tools.ietf.org/wg/sfc/draft-ietf-sfc-problem-statement/draft-ietf-
>>sfc-problem-statement-07-from-06.diff.html
>>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 26 Jun 2014 10:59:25 -0400

Same here.

	--Tom

---

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Thu, 26 Jun 2014 15:09:51 +0000

As a co-author, I support advancing the draft.

Surendra.

---

From: ramki Krishnan <[email-masked]>
Date: Thu, 26 Jun 2014 08:26:39 -0700

Support.

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Wednesday, June 25, 2014 12:14 PM
To: [email-masked]
Subject: [sfc] 2nd WG Last Call on Problem Statement

Hi.

We ran a WGLC on the problem statement draft
(draft-ietf-sfc-problem-statement-07.txt) back in May.
Although the draft received significant review and support prior to the formal LC, the actual last call resulted largely in silence.

While it would be convenient to take silence as acceptance, that's not good enough. To show the document is ready, we need WG members to speak up and indicate they have read a recent version of the document and think its ready to go.

Note that the document was just reissued. Section 3 has been edited to remove some of the text was deemed to be encroaching on architecture. You can see the changes at http://tools.ietf.org/wg/sfc/draft-ietf-sfc-problem-statement/draft-ietf-sfc-problem-statement-07-from-06.diff.html

With that, we are restarting a 2-week WGLC on the document. We specifically need to see sufficient indications from WG members that the document is ready to advance, and that the document does not contain significant deficiencies.

Thomas

---

From: Kevin Glavin <[email-masked]>
Date: Thu, 26 Jun 2014 20:27:24 +0000

As a contributor to the draft, I support it advancing.

Kevin

On 6/25/14 12:13 PM, "Thomas Narten" <[email-masked]> wrote:

>http://tools.ietf.org/wg/sfc/draft-ietf-sfc-problem-statement/draft-ietf-s
>fc-problem-statement-07-from-06.diff.html
>

---

From: "Zarny, Myo" <[email-masked]>
Date: Thu, 26 Jun 2014 17:10:54 -0400

Support.

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: 25 June 2014 3:14 PM
To: [email-masked]
Subject: [sfc] 2nd WG Last Call on Problem Statement

Hi.

Thomas

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Fri, 27 Jun 2014 18:52:35 +0000

I have read this document, I think it is ready, and support its publication.

-Darrel

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Mon, 30 Jun 2014 12:25:03 +0000

+1

Sent from my iPhone

> On Jun 26, 2014, at 10:05 AM, "Paul Quinn (paulq)" <[email-masked]> wrote:
> 
> Thomas,
>

---

From: Dave Dolson <[email-masked]>
Date: Mon, 30 Jun 2014 13:02:53 +0000

Support.

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Wednesday, June 25, 2014 3:14 PM
To: [email-masked]
Subject: [sfc] 2nd WG Last Call on Problem Statement

Hi.

Thomas

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 30 Jun 2014 14:06:21 +0000

Yes/Support.

Thanks!

-Nobo

> Although the draft received significant review and support prior to the
> formal LC, the actual last call resulted largely in silence.
> 
> While it would be convenient to take silence as acceptance, that's not good
> enough. To show the document is ready, we need WG members to speak up
> and indicate they have read a recent version of the document and think its
> ready to go.
> 
> remove some of the text was deemed to be encroaching on architecture.
> You can see the changes at http://tools.ietf.org/wg/sfc/draft-ietf-sfc-
> problem-statement/draft-ietf-sfc-problem-statement-07-from-06.diff.html
> 
> specifically need to see sufficient indications from WG members that the
> document is ready to advance, and that the document does not contain
> significant deficiencies.
> 
> Thomas
>

---

From: <[email-masked]>
Date: Mon, 30 Jun 2014 17:54:53 +0200

Dear Reinaldo, all,
As non-contributor nor editor or author of the draft I think that it describes typical challenges of operational usage of networks, i.e. to configure and deliver a multitude of services. The networks are made up of different nodes which are connected by a structured topology and communicate via specific protocols. Moreover the current networks have been once deployed and afterwards extended within years and decades: Thus it is clear that many problems result from topology constraints - i.e. configuration complexity.
The different sections just describe different aspects of and impacts on service performance which are often related to each other.
That works for me.

Regarding your comment 3 on section 2.3 below, my understanding of the sentence is as follows:
In case of large-scale networks to achieve high performance same service functions may have to be implemented in multiple instances. All these instances have to be executed at the same hierarchical level of the network topology in order not to impact the service performance (e.g. as a function of end point location).
Is that correct?   

Beside some grammar nits in the text (e.g. p.1: The set of enabled service function chains reflect => The set of enabled service function chains reflects, p.3: The delivery of end-to-end services often require => The delivery of end-to-end services often requires etc.) I think that in ch. 5 it should read "three components" instead of "four components" reflecting the changes from -06 (ch. 3). Or did I misunderstand something?

After clarification of these minor issues I agree to support forwarding.

Best regards
Dirk
-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Reinaldo Penno (repenno)
Sent: Donnerstag, 26. Juni 2014 16:41
To: Paul Quinn (paulq); Thomas Narten
Cc: [email-masked]
Subject: Re: [sfc] 2nd WG Last Call on Problem Statement

Hello,

I think the document needs editing and clarification before moving forward. Many sub-sections seems redundant and intertwined.

Comment 1:

2.1, 2.4, 2.7 and 2.8 are consequences of 2.2 and not really a problem statement in itself. At least that¹s how I see it. If you solve configuration complexity, the others will consequently be solved.

I think it is worth to maintain the discussion but not as a separate problem space, they should be under ³Configuration complexity² sub-section.

Section 2.1

Section 2.4

Section 2.7

"rapid

Section 2.8

"This

These are all basically saying that today configuration is complex and manual and automatic configuration would be a great idea.

Comment 2:

Section 2.6 seems a executive summary of parts of section 2.1 since the tying service function to topology you are saying service function must understand that transport.

"The coupling of service

Comment 3:

On 6/26/14, 6:35 AM, "Paul Quinn (paulq)" <[email-masked]> wrote:

>> While it would be convenient to take silence as acceptance, that's 
>> not good enough. To show the document is ready, we need WG members to 
>> Note that the document was just reissued. Section 3 has been edited 
>> to remove some of the text was deemed to be encroaching on 
>>http://tools.ietf.org/wg/sfc/draft-ietf-sfc-problem-statement/draft-ie
>>tf- sfc-problem-statement-07-from-06.diff.html
>>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 30 Jun 2014 17:47:49 +0000

Thomas,

Having read a recent version of the problem statement document (rev -06, and checked the diffs below), I believe it is complete (modulo small comment below) and comprehensive yet not bloated, clear, idnits-free, and has incorporated all WG's feedback.

Consequently, I think it is ready to advance and support progressing this document to the IESG.

The small comment: I would like to see a small sentence added that the topological dependencies have not only an impact in creating/modifying service chains, but also to manage them, and it is part of the problem that there is no consistent OAM.

Thanks,

Carlos.

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 30 Jun 2014 22:03:38 +0000

Support. 

Linda 

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: 25 June 2014 3:14 PM
To: [email-masked]
Subject: [sfc] 2nd WG Last Call on Problem Statement

Hi.

Thomas