Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Wed, 25 Jun 2014 01:51:31 +0000

Linda,

Comments inline.

Surendra.

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 12, 2014 3:17 PM
To: "Ng, Tomy" <[email-masked]<mailto:[email-masked]>>, Qiong <[email-masked]<mailto:[email-masked]>>, "Pham, Chuong D" <[email-masked]<mailto:[email-masked]>>
Cc: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>, "Haeffner, Walter, Vodafone DE" <[email-masked]<mailto:[email-masked]>>, "Joel M. Halpern" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Jeffrey Napper (jenapper)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

I have given explicit comments to the draft, yet not receiving any reply from the authors.
Specifically:

-          The “ADC” in the draft is more like conventional Load Balance. Since this use case is about general Data Center use case, we should use the conventional terminology.

SK> WOC and ADC are consistent in terminology. In fact we updated load balancer to ADC based on the feedback we received.

-          I can’t see how the examples listed in Section 3 drive the requirement listed in Section 5. The requirement listed in Section 5 are so general, that you don’t need those examples listed in Section 3.

-          Since this is a use case draft, not requirement draft, this draft should only list down the requirement driven by the examples.
 SK> If there are specific concerns, we could discuss and update the draft/examples.

I see that the key requirement driven by the examples in Section 3 is to allow those Service Functions to be located  anywhere (i.e. not necessarily on the data path). Therefore, the key requirement should be needing dynamic steering policies to Service Nodes, routers, and switches

Linda

From: sfc [mailto:[email-masked]] On Behalf Of Ng, Tomy
Sent: Wednesday, May 07, 2014 2:23 AM
To: Qiong; Pham, Chuong D
Cc: Joel M. Halpern; Jim Guichard (jguichar); Haeffner, Walter, Vodafone DE; [email-masked]<mailto:[email-masked]>; Jeffrey Napper (jenapper) ([email-masked]<mailto:[email-masked]>)
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Hi All,

Agree with Chuong’s viewpoint and I disapprove the adoption of this draft.

Cheers

Tomy
...............................................

On Wed, Apr 30, 2014 at 7:35 AM, Pham, Chuong D <[email-masked]<mailto:[email-masked]>> wrote:
Separate drafts for pockets of environments will most likely overlook the opportunities for identifying commonalities, synergies and reuse factors between similar use cases for different environments. This is the painful situation today where silos exist while at this point in time where Mobile, Fixed Broadband and Data Centre are seeing strong forces towards convergence with SDN, NFV and Cloud technologies.

An overall draft such as draft-liu or similar must exist as a common reference point for more detailed level drafts addressing use cases for specific/pockets of environments while allowing for future migration/convergence.

Unless draft-kumar co-exists with high level draft-liu, I see more harm in divergence rather than benefits therefore I disapprove.

Regards,
Chuong

-----Original Message-----
From: Haeffner, Walter, Vodafone DE [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, 30 April 2014 2:56 AM
To: Joel M. Halpern; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Cc: Jeffrey Napper (jenapper) ([email-masked]<mailto:[email-masked]>)
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

I also support this draft. Being on DC level this draft will complement the other use case drafts. Beside typical FW or DPI etc. there should be not that much overlap with the more carrier services oriented use case drafts.

Cheers, Walter

-----Ursprüngliche Nachricht-----
Von: sfc [mailto:[email-masked]<mailto:[email-masked]>] Im Auftrag von Joel M. Halpern
Gesendet: Samstag, 19. April 2014 01:25
An: Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Betreff: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

I support adoption of this document by the working group.  It is a good starting point for addressing the material it covers, and the working group should cover that material.

Yours,
Joel

On 4/18/14, 6:31 PM, Jim Guichard (jguichar) wrote:
> Dear WG:
>
> This message begins a two week call for WG adoption of the document
> http://www.ietf.org/id/draft-kumar-sfc-dc-use-cases-01.txt ending 2nd
> May 2014.
>
> Please respond to the SFC mailing list with any statements of approval
> or disapproval.
>
> Please note:
>
>  1. This is not WG Last Call. The document is not final, and the WG is
>     expected to modify the document's content until there is WG
>     consensus that the content is solid. Therefore, please don't oppose
>     adoption just because you want to see changes to its content.
>  2. If you have objections to adoption of the document, please state
>     your reasons why, and explain what it would take to address your
>     concerns.
>  3. If you have issues with the content, by all means raise those issues
>     and we can begin a dialog about how best to address them.
>
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc
>

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

--
==============================================
Qiong Sun
China Telecom Beijing Research Institute

===============================================

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 30 Jun 2014 14:10:41 +0000

Surendra,

From: Surendra Kumar (smkumar) [mailto:[email-masked]]

-          I can't see how the examples listed in Section 3 drive the requirement listed in Section 5. The requirement listed in Section 5 are so general, that you don't need those examples listed in Section 3.

[Linda] I think that the requirement section should be removed from the draft because it is a use case draft, not a requirement draft.

Linda

Linda

Hi All,

Agree with Chuong's viewpoint and I disapprove the adoption of this draft.

Cheers

Tomy

Regards,
Chuong

-----Original Message-----
From: Haeffner, Walter, Vodafone DE [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, 30 April 2014 2:56 AM
To: Joel M. Halpern; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Cc: Jeffrey Napper (jenapper) ([email-masked]<mailto:[email-masked]>)
Subject: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Cheers, Walter

-----Ursprüngliche Nachricht-----
Von: sfc [mailto:[email-masked]<mailto:[email-masked]>] Im Auftrag von Joel M. Halpern
Gesendet: Samstag, 19. April 2014 01:25
An: Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Betreff: Re: [sfc] Call for adoption of draft-kumar-sfc-dc-use-cases-01

Yours,
Joel