Subject: Re: [sfc] #19 (nsh): Mandatory context headers

From: "sfc issue tracker" <[email-masked]>
Date: Tue, 12 Apr 2016 18:50:12 -0000

#19: Mandatory context headers

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => wontfix

Comment:

 This was discussed on list, no consensus for change.  Will leave as is.

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |       Owner:  draft-ietf-sfc-
  [email-masked]       |  [email-masked]
     Type:  defect                   |      Status:  closed
 Priority:  major                    |   Milestone:
Component:  nsh                      |     Version:
 Severity:  -                        |  Resolution:  wontfix
 Keywords:                           |
-------------------------------------+-------------------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/sfc/trac/ticket/19#comment:1>
sfc <https://tools.ietf.org/sfc/>

---

From: <[email-masked]>
Date: Wed, 13 Apr 2016 06:05:57 +0000

Hi Paul,

I object to close this issue.

Unless I'm mistaken, the consensus should be declared by the chairs otherwise this is biased. I'm not the only one who raised this concern, BTW.

Cheers,
Med

> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de sfc issue tracker
> Envoyé : mardi 12 avril 2016 20:50
> À : [email-masked]; [email-masked]
> Cc : [email-masked]
> Objet : Re: [sfc] #19 (nsh): Mandatory context headers
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: <[email-masked]>
Date: Wed, 13 Apr 2016 06:08:04 +0000

Re-,

I checked the tracker but I didn't found any answer to the technical issue that I'm recalling here:

"
For type 1, why are there four mandatory context headers, rather than 2, 3, 5, 10, etc.?
"

Can you please let me know where this answer to the main issue was provided?

Thank you.

Cheers,
Med

> De : sfc [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mercredi 13 avril 2016 08:06
> À : sfc issue tracker; [email-masked]; [email-masked]
> Cc : [email-masked]
> Unless I'm mistaken, the consensus should be declared by the chairs
> otherwise this is biased. I'm not the only one who raised this concern,
> BTW.
> 
> Cheers,
> Med
> 
> > -------------------------------------+----------------------------------
> --
> > -
> > -------------------------------------+----------------------------------
> --
> > -
> >
> > Ticket URL:
> <https://trac.tools.ietf.org/wg/sfc/trac/ticket/19#comment:1>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 13 Apr 2016 12:18:51 +0000

Med,

The Ticket reads:
> The draft contains no particular justification for this choice.
> 

Do you find that 2 or 6 is better than 4?

What exactly are you objecting to?

I do not disagree that adding a sentence that reads “It was found that using 4 context headers was the best trade-off between foo and bar, satisfying baz” would not hurt. But at the same time, it does not seem anything is gained either.

Thanks,

— Carlos.

> On Apr 13, 2016, at 2:05 AM, [email-masked] wrote:
> 
> Hi Paul,
>

---

From: <[email-masked]>
Date: Wed, 13 Apr 2016 12:38:22 +0000

Carlos,

I’m seeking to understand the rationale for fixing 4 mandatory context headers in the spec. Why not selecting 0, 1, 2, …10?

I’m not asking for text, I’d like to understand.

Am I allowed to raise concerns I have with the draft or all is already frozen?

I think the issue is clear enough.

Cheers,
Med

De : Carlos Pignataro (cpignata) [mailto:[email-masked]]
Envoyé : mercredi 13 avril 2016 14:19
À : BOUCADAIR Mohamed IMT/OLN
Cc : sfc issue tracker; [email-masked]; Paul Quinn (paulq); [email-masked]
Objet : Re: [sfc] #19 (nsh): Mandatory context headers

Med,

The Ticket reads:

Thanks,

— Carlos.

On Apr 13, 2016, at 2:05 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Paul,

Cheers,
Med

-----Message d'origine-----
De : sfc [mailto:[email-masked]] De la part de sfc issue tracker
Envoyé : mardi 12 avril 2016 20:50
À : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [sfc] #19 (nsh): Mandatory context headers

Changes (by [email-masked]<mailto:[email-masked]>):

* status:  new => closed
* resolution:   => wontfix

Comment:

--
-------------------------------------+------------------------------------
-
Reporter:                           |       Owner:  draft-ietf-sfc-
 [email-masked]<mailto:[email-masked]>       |  [email-masked]<mailto:[email-masked]>
    Type:  defect                   |      Status:  closed
Priority:  major                    |   Milestone:
Component:  nsh                      |     Version:
Severity:  -                        |  Resolution:  wontfix
Keywords:                           |
-------------------------------------+------------------------------------
-

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 13 Apr 2016 13:30:54 +0000

> On Apr 13, 2016, at 8:38 AM, [email-masked] wrote:
> 
> Carlos,
> 

My recollection is that this was already discussed on the list.

A quick search results in:
https://www.ietf.org/mail-archive/web/sfc/current/msg04087.html

Where it seems to me this was answered, and there was no follow-up requesting further clarification. Hence, seems like the answer clarified the query.

> Am I allowed to raise concerns I have with the draft or all is already frozen?

Of course you (anyone) can (should!) raise concerns. It’s not a question of being “allowed” to.

It is also appropriate to follow-up and follow-through with the responses to those concerns.

Thanks,

— Carlos.

> On Apr 13, 2016, at 2:05 AM, [email-masked] <mailto:[email-masked]> wrote:
> 
> Hi Paul,
> 
> De : sfc [mailto:[email-masked] <mailto:[email-masked]>] De la part de sfc issue tracker
> À : [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Cc : [email-masked] <mailto:[email-masked]>
> Changes (by [email-masked] <mailto:[email-masked]>):
> 
> * status:  new => closed
> * resolution:   => wontfix
> 
> 
> Comment:
> 
>  [email-masked] <mailto:[email-masked]>       |  [email-masked] <mailto:[email-masked]>
> Ticket URL: <https://trac.tools.ietf.org/wg/sfc/trac/ticket/19#comment:1 <https://trac.tools.ietf.org/wg/sfc/trac/ticket/19#comment:1>>
> sfc <https://tools.ietf.org/sfc/ <https://tools.ietf.org/sfc/>>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc <https://www.ietf.org/mailman/listinfo/sfc>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc <https://www.ietf.org/mailman/listinfo/sfc>

---

From: <[email-masked]>
Date: Wed, 13 Apr 2016 13:38:52 +0000

Re-,

No need to send me information that I already know.

Still, I don’t see any technical justification to the initial concern. We all know that we don’t solve technical issues with rhetoric.

Cheers,
Med

Envoyé : mercredi 13 avril 2016 15:31

On Apr 13, 2016, at 8:38 AM, [email-masked]<mailto:[email-masked]> wrote:

Carlos,

Thanks,

— Carlos.

Cheers,
Med

Cc : sfc issue tracker; [email-masked]<mailto:[email-masked]>; Paul Quinn (paulq); [email-masked]<mailto:[email-masked]>

Med,

The Ticket reads:

Thanks,

— Carlos.

Hi Paul,

Cheers,
Med

-----Message d'origine-----
De : sfc [mailto:[email-masked]] De la part de sfc issue tracker
Envoyé : mardi 12 avril 2016 20:50
À : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [sfc] #19 (nsh): Mandatory context headers

* status:  new => closed
* resolution:   => wontfix

Comment:

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 13 Apr 2016 14:49:26 +0000

Dear Med,

The answer in that email thread seemed to me concrete, specific, and to the point — not “rhetoric". I will copy/paste it here:

> PQ>  That's a very valid question.  The starting premise was simple: a bounded set of fixed metadata.   Based on some experience in the service space and some initial use case discussion with operators, 4 provided some balance: reasonable in that it provided some meaningful space, yet not so large as to become unwieldy, all the while forcing some discipline.  Overall that has proven to be true as implementations have been tested and mapped to use cases.  Of course you can come up with cases where 4 is too many, or too few, in which case the draft provides a means to accommodate that.

What I interpret from that paragraph is: 2 32-bit words is too small for the use cases, 6 is too big such that it can result in overly-creative uses/abuses, 4 is as small as possible but not smaller than needed. Further, the use-case documents made good use of 4, without needing more. It is an operational as well as technical consideration.

I am not sure how that could be better clarified, but I’ll leave it to others. The above paragraph answers directly the question on the ticket: “For type 1, why are there four mandatory context headers, rather than 2, 3, 5, 10, etc.?”

Best,

— Carlos.

> On Apr 13, 2016, at 9:38 AM, [email-masked] wrote:
> 
> Re-,
> 
> On Apr 13, 2016, at 8:38 AM, [email-masked] <mailto:[email-masked]> wrote:
> 
> Carlos,
> 
> https://www.ietf.org/mail-archive/web/sfc/current/msg04087.html <https://www.ietf.org/mail-archive/web/sfc/current/msg04087.html>
> 
> De : Carlos Pignataro (cpignata) [mailto:[email-masked] <mailto:[email-masked]>]
> Cc : sfc issue tracker; [email-masked] <mailto:[email-masked]>; Paul Quinn (paulq); [email-masked] <mailto:[email-masked]>