Subject: [sfc] TLV class of variable-length metadata should have a restricted range

From: Dave Dolson <[email-masked]>
Date: Thu, 14 Apr 2016 15:24:48 +0000

Regarding the TLV Class of variable-length metadata, https://tools.ietf.org/html/draft-ietf-sfc-nsh-04#section-3.5.1
It is common for such fields to reserve ranges, allowing for future growth into unanticipated uses.

E.g., off the top of my head,
classes 0 to 0x1ff --> types allocated by IETF
classes 0x200 to 0x7fff --> allocated by IANA
Classes 0x8000 to 0xbfff --> reserved, do not use
classes 0xc000 to 0xefff --> locally administered
classes 0xf000 to 0xffff --> experimental

Or similar? I'm not sure what the best practice for this is.

Generally, I'd want to try something experimentally before requesting IANA allocation for it (experimental),
or maybe types are too specific to warrant IANA allocation (locally administered).

Can something like this be added to draft-ietf-sfc-nsh ?

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 14 Apr 2016 11:29:59 -0400

That seems sensible.  (I am not sure why we need such a large range of 
classes, but I suspect I am missing something there.)

Yours,
Joel

On 4/14/16 11:24 AM, Dave Dolson wrote:
> Regarding the TLV Class of variable-length metadata,
> https://tools.ietf.org/html/draft-ietf-sfc-nsh-04#section-3.5.1
>
> Or similar? I’m not sure what the best practice for this is.
>
> Generally, I’d want to try something experimentally before requesting
> IANA allocation for it (experimental),
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: Dave Dolson <[email-masked]>
Date: Thu, 14 Apr 2016 15:32:48 +0000

I was just brainstorming some classes. I expect more experienced contributors can
make arguments to whittle it down.

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Thursday, April 14, 2016 11:30 AM
To: Dave Dolson; [email-masked]
Subject: Re: [sfc] TLV class of variable-length metadata should have a restricted range

Yours,
Joel

---

From: <[email-masked]>
Date: Mon, 18 Apr 2016 11:39:18 +0000

Hi Dave, all,

Thank you for raising this point.

IANA considerations should be sketched in reference to RFC5226 (see https://tools.ietf.org/html/rfc5226#section-4.1).

IMO, it is reasonable to define ranges:

·         assigned via Standards Action

·         assigned via Specification Required

·         reserved for Private Use

·         reserved for Experimental Use

Note that the ranges you are proposing are not aligned with the current TLV encoding (Type is encoded in 7 bits).

Saying that, I still do see value in reusing existing rich registries such as IPFIX. Doing so allows to use immediately a code point while ensuring interoperability. A dedicated field in the encoding of the TLV can be defined (or adjust TLV Class?) to point to the registry in use.

BTW, the IANA section should include more details about "TLV Class".

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Dave Dolson
Envoyé : jeudi 14 avril 2016 17:25
À : [email-masked]
Objet : [sfc] TLV class of variable-length metadata should have a restricted range

David Dolson

---

From: Dave Dolson <[email-masked]>
Date: Mon, 18 Apr 2016 15:21:00 +0000

Med,
I was discussing the "TLV Class" field, which is 16 bits.

But thank you for finding the BCP for writing IANA considerations.

-Dave

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 18, 2016 7:39 AM
To: Dave Dolson; [email-masked]
Subject: RE: [sfc] TLV class of variable-length metadata should have a restricted range

Hi Dave, all,

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Dave Dolson
Envoyé : jeudi 14 avril 2016 17:25
À : [email-masked]<mailto:[email-masked]>
Objet : [sfc] TLV class of variable-length metadata should have a restricted range

David Dolson

---

From: <[email-masked]>
Date: Tue, 19 Apr 2016 06:42:59 +0000

Hi Dave,

I'm puzzled here. Why do we need a large range of « TLV Class »?  Wouldn't few bits be sufficient (e.g., 3 or 4 bits)?

Thank you.

Cheers,
Med

De : Dave Dolson [mailto:[email-masked]]
Envoyé : lundi 18 avril 2016 17:21
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : RE: [sfc] TLV class of variable-length metadata should have a restricted range

Med,

-Dave

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, April 18, 2016 7:39 AM
To: Dave Dolson; [email-masked]<mailto:[email-masked]>
Subject: RE: [sfc] TLV class of variable-length metadata should have a restricted range

Hi Dave, all,

Cheers,
Med

David Dolson

---

From: Dave Dolson <[email-masked]>
Date: Wed, 20 Apr 2016 20:07:56 +0000

Med,

That's a question for others. I don't know why so bits are allocated for class. My sense is this is thought of as a vendor-ID field.

Comments anyone?

-Dave

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 19, 2016 2:43 AM
To: Dave Dolson; [email-masked]
Subject: RE: [sfc] TLV class of variable-length metadata should have a restricted range

Hi Dave,

Thank you.

Cheers,
Med

De : Dave Dolson [mailto:[email-masked]]
Envoyé : lundi 18 avril 2016 17:21
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>
Objet : RE: [sfc] TLV class of variable-length metadata should have a restricted range

Med,

-Dave

Hi Dave, all,

Cheers,
Med

David Dolson

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Wed, 20 Apr 2016 23:49:22 +0000

On Apr 20, 2016, at 4:07 PM, Dave Dolson <[email-masked]<mailto:[email-masked]>> wrote:

Med,

That’s a question for others. I don’t know why so bits are allocated for class. My sense is this is thought of as a vendor-ID field.

That's correct: it scopes the data to a particular "owner".  That probably isn't clear in the draft and will be clarified.  The intent is to reserve a range for "standards" use, and then allow vendors (for example) to have their scope as well.

Paul

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Wed, 20 Apr 2016 23:50:26 +0000

I replied to a later email in the thread, but this is example how we envisioned this working, along with some vendor allocations.   This should/will be added to the next rev.

Paul

On Apr 14, 2016, at 11:24 AM, Dave Dolson <[email-masked]<mailto:[email-masked]>> wrote:

Generally, I’d want to try something experimentally before requesting IANA allocation for it (experimental),
or maybe types are too specific to warrant IANA allocation (locally administered).

David Dolson

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Loa Andersson <[email-masked]>
Date: Thu, 21 Apr 2016 12:28:46 +0800

Dave,

A few comments and questions, though in general I agree with your approach.

> classes 0x200 to 0x7fff --> allocated by IANA

What is the difference between "alloacated by IETF"
and "allocated by IANA"? I think we should say.

classes 0 to 0x1ff --> types allocated by IETF consensus
classes 0x200 to 0x7fff --> RFC needed

> Classes 0x8000 to 0xbfff --> reserved, do not use

I don't understand why we need the reerved block of 16k classes
reserved?
> classes 0xc000 to 0xefff --> locally administered

what is this??
> classes 0xf000 to 0xffff --> experimental

this block is way to big , 4 or 8 values would be enough, e.g.

classes 0xfff6 to 0xfffe --> experimental

I'd also do

class 0xffff reserved - this is set aside for future use and will
require a standard track RFC to change.

/Loa

---

From: <[email-masked]>
Date: Thu, 21 Apr 2016 05:46:22 +0000

Hi Paul,

Thank you for the clarification. This is aligned with the interpretation I had for this field. It can point to another register, owner, etc. but still I don’t understand why we need to have 2^^16 values for this.

I won’t repeat my proposal to include IPFIX registry here as it is already raised in other threads.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Paul Quinn (paulq)
Envoyé : jeudi 21 avril 2016 01:49
À : Dave Dolson
Cc : [email-masked]
Objet : Re: [sfc] TLV class of variable-length metadata should have a restricted range

Med,

Paul

---

From: Dave Dolson <[email-masked]>
Date: Thu, 21 Apr 2016 16:09:05 +0000

Please also see Med's BCP-conforming suggestions:
https://mailarchive.ietf.org/arch/msg/sfc/1qWGtW1QVxXdG-OHy2T-bhh-C38

As for my "reserved" block, I realize that the "assigned by Standards Action" 
would suit my intended purpose of being reserved.

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Thursday, April 21, 2016 12:29 AM
To: Dave Dolson; [email-masked]
Subject: Re: [sfc] TLV class of variable-length metadata should have a restricted range

Dave,

what is this??

I'd also do

/Loa

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 22 Apr 2016 14:18:15 +0000

Hello Med,

This "size" of the field helps ensure that many organization/registries/owners can participate.  At this point, it seems prudent and we don't need to try to optimize since this accommodates a large-range of options.

Paul

On Apr 21, 2016, at 1:46 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Paul,

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Paul Quinn (paulq)
Envoyé : jeudi 21 avril 2016 01:49
À : Dave Dolson
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [sfc] TLV class of variable-length metadata should have a restricted range

Med,

Paul

---

From: <[email-masked]>
Date: Mon, 25 Apr 2016 05:48:33 +0000

Hi Paul,

Thank you for the clarification. I understand from your answer this is subjective, but I would not say that having 2^^16 owners is a “prudent” design.

I’m afraid this is not the only considerations that need to be taken into account for this optional context information. Below some of the key design criteria from my standpoint:

·         Allow for better interoperability especially in the context of  Multi-vendor Service Functions (https://tools.ietf.org/html/rfc7498#section-2.12)

·         Foster SFC innovation

·         Preserve compact message encoding

Having FEW bits for the class field would be the reasonable approach (while 16 bits are reserved for conveying the “type” of the context information).

I see that Joel kindly made a comment about the size of this field: http://www.ietf.org/mail-archive/web/sfc/current/msg04496.html

Cheers,
Med

De : Paul Quinn (paulq) [mailto:[email-masked]]
Envoyé : vendredi 22 avril 2016 16:18
À : BOUCADAIR Mohamed IMT/OLN
Cc : Dave Dolson; [email-masked]
Objet : Re: [sfc] TLV class of variable-length metadata should have a restricted range

Hello Med,

Paul

Hi Paul,

Cheers,
Med

Med,

Paul