Subject: Re: [sfc] A request for Metadata allocation schemes

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Wed, 6 Apr 2016 17:54:51 +0000

Hi Dave,

I guess my initial questions would be how do SF's achieve this today and why does NSH make that any different (except for the offset to the original payload in the packet changes) ?

Jim

From: sfc <[email-masked]<mailto:[email-masked]>> on behalf of Dave Dolson <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 6, 2016 at 10:13 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] A request for Metadata allocation schemes

To those authors of metadata allocations, I have a request.
I believe many types of service functions are going to want to distinguish up-link traffic from down-link traffic.
E.g., a security device treats in-bound to the protected device differently from out-bound.
E.g., an accounting system needs to know whether to charge the source or destination node.

So my request is to allocate a bit for up-link/down-link discrimination.
I think the alternative is to configure each SF about each path whether it is up or down, or to use something like an even/odd path ID scheme.

Does anyone else see this as useful?

I believe all of the allocation drafts have reserved bits.

David Dolson
Senior Software Architect
Sandvine

---

From: Dave Dolson <[email-masked]>
Date: Wed, 6 Apr 2016 18:01:22 +0000

I'm familiar with methods:

-          Service function has two physical interfaces, each with an "up" or "down" role;

-          A bit in the path identifier indicates direction

From: Jim Guichard (jguichar) [mailto:[email-masked]]
Sent: Wednesday, April 06, 2016 2:55 PM
To: Dave Dolson; [email-masked]
Subject: Re: [sfc] A request for Metadata allocation schemes

Hi Dave,

Jim

David Dolson