Subject: [sfc] draft-ietf-sfc-control-plane -- C2 interface

From: Dave Dolson <[email-masked]>
Date: Thu, 28 Apr 2016 17:55:57 +0000

In section 3.3.2, https://tools.ietf.org/html/draft-ietf-sfc-control-plane-04#section-3.3.2
the section is: C2: Interface between SFC Control Plane & SFF

- There is no mention of being able to instruct the SFF to load-balance an SFP across multiple (functionally equivalent) SFs
This is the service-function-group-name concept in OpenDaylight and in draft-penno-sfc-yang-14, as I understand it.
Identifying members of a group and identifying a group as a next-hop would be in the scope of the C2 interface, correct?

- Regarding chain (path?) termination, there should be some mention of how to forward packets per path after the NSH header is removed.
For example, it may be that different paths terminate at different physical interfaces or at different routing tables.
This isn't always relevant, but I would expect it to be in the scope of C2, no?
E.g., for IP encapsulation,  "if SPI=101 and SI=251 then terminate to routing table T1"
Or, e.g., for Ethernet encapsulation "if SPI=200 and SI=252 then terminate to Ethernet interface eth1"

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: <[email-masked]>
Date: Fri, 29 Apr 2016 06:05:49 +0000

Hi Dave,

Please see inline.

Cheers,
Med

De : Dave Dolson [mailto:[email-masked]]
Envoyé : jeudi 28 avril 2016 19:56
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : draft-ietf-sfc-control-plane -- C2 interface

[Med] This is in scope of C2, that is responsible for populating the SFC Forwarding Policy Table. The current text cites examples of additional to be used for lookup purposes (excerpt from Section 1.2):

      Additional information such as a flow identifier, Service Index

      (SI), and/or other characteristics (e.g., the 5-tuple transport

      coordinates of the original packet) may be used for lookup

      purposes.  The set of information to use for lookup purposes may

      be instructed by the control plane.

Load balancing is discussed in "Additional Considerations" section. Indeed, Section 4.10.1 includes the following:

   SF/SFP Load-balancing:   re-construct SFPs to distribute the workload
      among various SF instances.  Particularly, load distribution
      policies can be taken into account by the Control Element to re-
      compute an SFP or be provisioned as attributes to SFPs that will
      be installed using the control interfaces.

I suggest to make this change:

OLD:

   SF/SFP Load-balancing:   re-construct SFPs to distribute the workload

      among various SF instances.  Particularly, load distribution

      policies can be taken into account by the Control Element to re-

      compute an SFP or be provisioned as attributes to SFPs that will

      be installed using the control interfaces.

NEW:

   SF/SFP Load-balancing:   re-construct SFPs to distribute the workload

      among various SF instances.  Particularly, load distribution

      policies can be taken into account by the Control Element to re-

      compute an SFP or be provisioned as attributes to SFPs that will

      be installed using the control interfaces (C2 interface, typically).

Please let me know if further changes are required.

[Med] What about making this change?
OLD:

   An SFF can be instructed to strip the SFC information for the chains

   it terminates.

NEW:

   An SFF can be instructed to strip the SFC information for the chains

   it terminates. Forwarding policies for handling packets bound to

   chains that are terminated by an SFF may be communicated via this interface.

That text may be completed with the following sentence to further highlight that these forwarding instructions are not mandatory:

   By default, an SFF relies on legacy processing for forwarding these packets.

David Dolson

---

From: Dave Dolson <[email-masked]>
Date: Fri, 29 Apr 2016 13:57:30 +0000

Med,
Please see inline [DD]

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, April 29, 2016 2:06 AM
To: Dave Dolson; [email-masked]
Subject: RE: draft-ietf-sfc-control-plane -- C2 interface

Hi Dave,

Please see inline.

Cheers,
Med

De : Dave Dolson [mailto:[email-masked]]
Envoyé : jeudi 28 avril 2016 19:56
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>
Objet : draft-ietf-sfc-control-plane -- C2 interface

   SF/SFP Load-balancing:   re-construct SFPs to distribute the workload
      among various SF instances.  Particularly, load distribution
      policies can be taken into account by the Control Element to re-
      compute an SFP or be provisioned as attributes to SFPs that will
      be installed using the control interfaces.
[DD] This is in a section that seems to be about the controller making adjustments to move work-load to different paths. I'm concerned with the case when traffic of a single path is load-balanced across multiple workers in a dynamic manner that doesn't require controller micro-management.
[DD] To help clarify, it might be useful to think of the SFF having multiple next-hop entries for the same SPI/SI pair; as with ECMP routing or LAG, a local decision selects which to use.

OLD:

NEW:

Please let me know if further changes are required.
[DD] Although this change is correct, it doesn't address my concern. I would like to see language in section 3.3.2.
[DD] Perhaps, "The C2 interface may be used to configure groups of functionally equivalent SFs that may service a path."

   it terminates.

NEW:

[DD] OK, looks good.

David Dolson

---

From: <[email-masked]>
Date: Fri, 29 Apr 2016 14:32:12 +0000

Re-,

Please see inline.

Cheers,
Med

De : Dave Dolson [mailto:[email-masked]]
Envoyé : vendredi 29 avril 2016 15:57
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : RE: draft-ietf-sfc-control-plane -- C2 interface

Med,
Please see inline [DD]

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Friday, April 29, 2016 2:06 AM
To: Dave Dolson; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-ietf-sfc-control-plane -- C2 interface

Hi Dave,

Please see inline.

Cheers,
Med

OLD:

NEW:

[Med] Ok, what about this NEW text?

   The C2 interface may be used to configure groups of functionally
   equivalent SFs.  In particular, this group may be used for load-
   balancing purposes.

---

From: Dave Dolson <[email-masked]>
Date: Fri, 29 Apr 2016 15:06:39 +0000

Looks good, thank you.

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, April 29, 2016 10:32 AM
To: Dave Dolson; [email-masked]
Subject: RE: draft-ietf-sfc-control-plane -- C2 interface

Re-,

Please see inline.

Cheers,
Med

Med,
Please see inline [DD]

Hi Dave,

Please see inline.

Cheers,
Med

OLD:

NEW: