Subject: [sfc] NSH text enhancement suggestion

From: Lucy yong <[email-masked]>
Date: Fri, 13 Jan 2017 23:09:20 +0000

Length field in NSH base header contains value of total length of NSH.

" The length field indicates the "end" of NSH and where the original packet/frame begins."

"In that case, the MD Type 0x1 node, MUST utilize the base header length field to determine
   the original payload offset if it requires access to the original
   packet/frame."

Comment: above text does not accurate for the hierarchical SFC case (draft-ietf-sfc-hierarchical-02.txt)

suggested text:

" The length field indicates the "end" of NSH header; if the next protocol in base header is not "NSH",  it also indicates the original packet/frame begins. To locate the original packet/frame begins on NSH packet, a recursive process can be used until the next protocol in a based header is not "NSH"; the sum of total length of all NSH headers on a NSH packet is the offset of the original packet/frame.

Lucy

---

From: Jim Guichard <[email-masked]>
Date: Sat, 14 Jan 2017 10:50:38 -0500

Hi Lucy,

The current text in section 3.2 says "...The length MUST be of value 0x6
for MD Type equal to 0x1 and MUST be of value 0x2 or greater for MD type
equal to 0x2 .." To accommodate the hierarchical SFC case a simple addition
of "or greater" to the above text for MD type 0x1 should resolve the issue
you describe. I would also suggest adding text to
draft-ietf-sfc-hierarchical-02 to indicate that it MUST update the NSH base
header length to reflect both the original NSH header and any NSH headers
added to the packet/frame by that draft.

Thoughts?

Jim

On Fri, Jan 13, 2017 at 6:09 PM, Lucy yong <[email-masked]> wrote:

> “ The length field indicates the "end" of NSH and where the original
> packet/frame begins.”
>
>
>
> “In that case, the MD Type 0x1 node, MUST utilize the base header length
> field to determine
>
>    packet/frame.”
> “ The length field indicates the "end" of NSH header; if the next protocol
> in base header is not “NSH”,  it also indicates the original packet/frame
> begins. To locate the original packet/frame begins on NSH packet, a
> recursive process can be used until the next protocol in a based header is
> not “NSH”; the sum of total length of all NSH headers on a NSH packet is
> the offset of the original packet/frame.
>
>
>
> Lucy
>
>
>
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>
>

---

From: Lucy yong <[email-masked]>
Date: Sat, 14 Jan 2017 17:17:22 +0000

Hi Jim,

To accommodate the hierarchical SFC case, NSH draft  is necessary to specify the meaning of the length in base header:  1) length means the bytes of NSH header; or 2) length indicates the offset of the original packet/frame.

Lucy
From: Jim Guichard [mailto:[email-masked]]
Sent: Saturday, January 14, 2017 9:51 AM
To: Lucy yong
Cc: [email-masked]
Subject: Re: [sfc] NSH text enhancement suggestion

Hi Lucy,

The current text in section 3.2 says "...The length MUST be of value 0x6 for MD Type equal to 0x1 and MUST be of value 0x2 or greater for MD type equal to 0x2 .." To accommodate the hierarchical SFC case a simple addition of "or greater" to the above text for MD type 0x1 should resolve the issue you describe. I would also suggest adding text to draft-ietf-sfc-hierarchical-02 to indicate that it MUST update the NSH base header length to reflect both the original NSH header and any NSH headers added to the packet/frame by that draft.

Thoughts?

Jim

On Fri, Jan 13, 2017 at 6:09 PM, Lucy yong <[email-masked]<mailto:[email-masked]>> wrote:
Length field in NSH base header contains value of total length of NSH.

“ The length field indicates the "end" of NSH and where the original packet/frame begins.”

“In that case, the MD Type 0x1 node, MUST utilize the base header length field to determine
   the original payload offset if it requires access to the original
   packet/frame.”

suggested text:

“ The length field indicates the "end" of NSH header; if the next protocol in base header is not “NSH”,  it also indicates the original packet/frame begins. To locate the original packet/frame begins on NSH packet, a recursive process can be used until the next protocol in a based header is not “NSH”; the sum of total length of all NSH headers on a NSH packet is the offset of the original packet/frame.

Lucy

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Dave Dolson <[email-masked]>
Date: Sat, 14 Jan 2017 19:57:01 +0000

I think it must be (1). The length in the first header should not include the second header.

From: Lucy yong
Sent: Saturday, January 14, 2017 12:17 PM
To: Jim Guichard
Cc: [email-masked]
Subject: Re: [sfc] NSH text enhancement suggestion

Hi Jim,

Lucy

Hi Lucy,

Thoughts?

Jim

suggested text:

Lucy