Subject: Re: [sfc] MD Class registry

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 20 Feb 2017 10:12:25 -0000

Joel,
 
That's good modulo use of the word "reserve" which has special IANA meaning ("do
not allocate").
 
It may be helpful to write out the proposed text which is, I think...
 
OLD
12.2.4.  MD Class Registry
 
   IANA is requested to set up a registry of "MD Class".  These are 16-
   bit values.  MD Classes defined by this document are assigned as
   follows:
 
   0x0000 to 0x01ff: IETF Review
   0x0200 to 0xfff5: Expert Review
   0xfff6 to 0xfffe: Experimental
   0xffff: Reserved
NEW
12.2.4.  MD Class Registry
 
   IANA is requested to set up a registry of "MD Class".  These are 16-
   bit values. New allocations are to be made according to the
   following policies:
 
   0x0000 to 0x01ff: IETF Review
   0x0200 to 0xfff5: Expert Review
   0xfff6 to 0xfffe: Experimental
   0xffff: Reserved
 
   IANA is requested to assign the following value:
 
   MD Class | Meaning                    | Reference
   ---------+----------------------------+-----------
   0x0000   | IETF Base NSH MD Class     | [This.I-D]
 
   Designated Experts evaluating new allocation requests
   from the "Expert Review" range should principally
   consider whether a new MD class is needed compared to
   adding MD types to an existing class. The Designated 
   Experts should also encourage the existence of an
   associated and publically visible registry of MD types
   although this registry need not be maintained by IANA.
END
 
However, as I type this I do wonder whether 2^16 isn't a very lot of MD classes.
 
Ciao,
Adrian
 
> -----Original Message-----
> From: sfc [mailto:[email-masked]] On Behalf Of Joel M. Halpern
> Sent: 20 February 2017 01:59
> To: [email-masked]
> Subject: [sfc] MD Class registry
> 
> In the interim meeting, there was a discussion of clarifying the MD
> Class Registry.  Two changes were proposed.  This email is to solicit
> comments from the WG on those two changes.
> 
> First, the MD Class Allocation table.  It currently reserves 0 - 0x01ff
> for IETF review.
> 
> The proposal is to reserve 0x0000 for our work, and to reserve the
> remainder of that range (0x0001 - 0x01ff) for IEtF review.
> 
> Second, the proposal is to establish the registry for type codes within
> MD Class 0x0000 in the NSH document.  With a policy of RFC Required.  No
> values would be established in the registry by this document, that being
> left ot other documents.
> 
> Does anyone see problems with this proposal?
> Yours,
> Joel
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: <[email-masked]>
Date: Mon, 20 Feb 2017 10:40:59 +0000

Hi all,

Please see inline.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : lundi 20 février 2017 11:12
À : 'Joel M. Halpern'; [email-masked]
Objet : Re: [sfc] MD Class registry

Joel,

That's good modulo use of the word "reserve" which has special IANA meaning ("do not allocate").

OLD

   follows:

   0xffff: Reserved

NEW

   following policies:

   0xffff: Reserved

END

[Med] While we are discussing this MD#0, I'd like to remind this companion point that needs to be fixed in the draft too.

===

NEW:

x.x.x.  IETF Assigned MD TLV Type Registry

   This document requests IANA to create a registry for the type values

   owned by the IETF (i.e., MD Class set to 0) called the "IETF Assigned

   MD TLV Type Registry."

   The type values are assigned via Standards Action [RFC5226].

   No initial values are assigned at the creation of the registry.

======

[Med] I do personally think this is over-dimensioned. As reported in https://trac.ietf.org/trac/sfc/ticket/24, I'd prefer to reduce the length of the MD class to grab more bits for the length field.

Ciao,

Adrian

> To: [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>