Subject: [sfc] About minimal controller requirement

From: "Roberta Maglione (robmgl)" <[email-masked]>
Date: Wed, 29 Mar 2017 14:11:26 +0000

Hello Sumandra,
I listened to your presentation in sfc yesterday and I have a comment:
in slide 3, as part of the minimal configuration requirements you listed the SF Name. I agree with you that SF name is needed for the configuration, but when we first looked at this problem what we thought  it would be useful for the controller to have is an additional level of abstraction  for Service Function type. The reason for this is because there could be multiple  instances of the same SF type and the controller may be able to choose which instance to use to build a specific chain. The concept of  "service function type" is also part of the bgp/bess nsh draft.
Please let me know what you think.
Thanks
Roberta

---

From: Sumandra Majee <[email-masked]>
Date: Thu, 30 Mar 2017 19:36:58 +0000

Hello,

Thanks for your input. I noticed the SF type in the bgp nsh draft and keeping up with minimal controller/config requirement, why would controller need to know the type of service.

Having said that, I agree it is useful and a full-fledged orchestrator can use this to create dynamic service chains on demand based functionality. So if a chain requires 
FW <-> TCP-OPT<->NAT then one can connect those types appropriately. But then,
a) How does the controller know it if it is properly configured, is the type available once the brick boots up into a “proper” mode?
b) What would be the type of a multi function device. Advanced L7 devices are tcp-opt+adc+many other functions… so is it a multi function type. If the answer is yes then it is a set of type. 
c) Having a type means yet another semantics to deal with, again from the bare minimal requirement it might be non-essential but useful information.

Thoughts?

On 3/29/17, 7:11 AM, "Roberta Maglione (robmgl)" <[email-masked]> wrote:

    Hello Sumandra,